+ Start a Discussion

SFDX:Authorize an Org - Cannot

Newbie looking for desperate help.

I am trying to authorize an org in VSCode in my compnay environment but failing.

While it connects fine on regular networks, the process keeps failing and showing the "localhost didn’t send any data." 1717 problem that many others also faced.

The frustrating thing is that it works fine in my co-workers laptop but doesn't even when I copy his settings. I already tried cahnging arount the proxy setting on my desktop and on vscode but just cant seem to get it to work.

I have seen couple of similar/same problems but have not found an answer for mine.


Khan AnasKhan Anas (Salesforce Developers) 
Hi Han,

Greetings to you!

Please refer to the below links which might help you further with the above issue.




I hope it helps you.

Kindly let me know if it helps you and close your query by marking it as solved so that it can help others in the future. It will help to keep this community clean.

Thanks and Regards,
Khan Anas
Naveen MosuruNaveen Mosuru
Hello guys,

 If you are not able to find SFDX: Authorize an Org option in command palette then you have to first create a project and then try to find out.
I hope you have the extensions along with the CLI.

Best Regards,
Try following to resolve the issue:
Reload your Salesforce CLI again and check if can find the command. Also try with SFDX command: SFDX auth:web:login.

Mark this as a right answer if it resolves your problem!