+ Start a Discussion

Is it possible to migrate the complete data using the Apex Dataloader?

Hi ,


I want to migrate the data from one developer org to another. I am using Apex Dataloader(Dataloader CLIq) for this.

My steps:

I have created processess for all the objects which or createable or updateable.(Both for export and upsert)


Then I used ANT to call all the EXPORTprocesses. This ANT call exported all the objects' data. It is successful. Now I have the data in CSV files.

Next I tried to call another ANT target to execute UPSERT processes. (Here all the locations of .sdl, .csv are given correct). When I run the process, It ended up giving all errors. None of the record is created or updated.


My question is: Is this possible to upsert all the objects(Which are either creatable or editable) in a single call?

What are the precautions need to be taken for a successful upsert?

What are the permissions I have to give while upserting (Im using system administrator profile in this case)?

Is there any order for the standard objects to be Upserted?



Vinay Kumar.

Madhan Raja MMadhan Raja M

Hi Vinay,


Is the configuration for both the developer instance is same? If yes, then first you need to export the parent object followed by child object with updated Parent ID. Once you migrate the records to the new instance the Record ID will get changed.


If a reply to a post answers your question or resolves your problem, please mark it as the solution to the post so that others may benefit.


Madhan Raja M



Hi Madhan, Thanks for your reply and your time.


The configuration for both the developer instances is same. I just want to brief my process. First I exported all the objects by creating a process for all the objects with the Data Loader CLIq. I executed all the process with an ANT call. That exported all objects (Standard and Custom) to a folder. Then I created Upsert processes into another developer instance for all objects. Once creating all the processes, I executed all the processes with another ANT call. But the UPSERT process is failing and none of the object is successful. I hope you got my process. Can you guide on how to proceed in this? What process do I fallow for bulk UPSERT? Any help is appreciated.