+ Start a Discussion
Pawan Kumar 32Pawan Kumar 32 

Errors encounter in Migrating roles and territories

Hello Everyone,

I am trying to deploy roles and Territories using change set. But I am getting below error: 
User-added image

Please help to solve the problem.
Best Answer chosen by Pawan Kumar 32
NagendraNagendra (Salesforce Developers) 
Hi Pawan,

It could be several reasons. For example: When you are trying to deploy, at the same moment when someone tries to change roles or territories it may give you error.
  • My recommendation is to deploy again with the same change set. Just hit deploy in prod, no need to upload changeset again.
  • If you receive same error, divide deployment into 2 parts. Either you can create them manually in prod and push them  through changesets. Or you can divide into 2 parts, Create change set for folder, then try to deploy existing changeset.
Still if the error persists please contact the salesforce support team with the error id.

You can reach salesforce support on the below email address:

Please mark this as solved if it helps.

Best Regards,