+ Start a Discussion
Elias Sanchez in NOVAElias Sanchez in NOVA 

Update Contact Mailing Address: Automate Basic Business Processes with Process Builder

I really don't get this Trailhead... stuck and unable to move on and forward onto my next lesson (https://trailhead.salesforce.com/modules/business_process_automation/units/process_builder)

User-added image

I proceeded to create the flow in Process Builder as shown below...

User-added image


User-added image

User-added image

User-added image

Once done I proceeded to active this process then I went into an account and updated the Shipping Address be that the street, city, state or zip code and the process ran as intended and updated the contact mailing address. I tried with several records and the process works just fine. I really don't get this error message. I destroyed the process I built and re-created it again and same error message. Any guidance or tips to help me solve this conondrum will be greatly appreciate it. Thanks so much!



 
Best Answer chosen by Elias Sanchez in NOVA
Teja GattupalliTeja Gattupalli
Hello Elias,

Not a problem!!
Im glad the answer helped you.

Thanks,
Teja

All Answers

piyush_sonipiyush_soni
hi Elias Sanchez in NOVA,

you have need to active your process : click on active button and check again

User-added image

Hopes it will helps you ,
Please follow developer forums best practices (https://developer.salesforce.com/forums/ForumsMain?id=9060G000000MVrtQAG) :
Thanks
Elias Sanchez in NOVAElias Sanchez in NOVA
Hi Pisyush_Soni. The process is active and still I'm getting the same error message. The process works as I have tested updating the contact mailing address via updating the shipping address from the account record as the trailhead exercise requests. Very frustrating. User-added image

Challenge Not yet complete... here's what's wrong: 
An update to an account record failed to update the mailing address fields of all child contact records. Make sure that the process is correct and that it is activated.

User-added image
Teja GattupalliTeja Gattupalli
Hi Elias,

How do you do?

It looks like you have missed adding the condition for the "Mailing Country" in the "Immediate Actions" section.
Please refer to the below screen shot and let me know if you need further help. Hope it helps :)

User-added image

Thanks,
Teja
Elias Sanchez in NOVAElias Sanchez in NOVA
Hello Teja! Oh my goodness!!! That did it!!! THANK YOU for saving the day! I missed adding the Mailing Country! Once I deactivated and cloned this process and added the mising field and activate it I was able to complete this Trailhead! Thanks SO MUCH for reaching out and helping out! Truly apprecieate it!!! 
Teja GattupalliTeja Gattupalli
Hello Elias,

Not a problem!!
Im glad the answer helped you.

Thanks,
Teja
This was selected as the best answer