+ Start a Discussion
sairam v 14sairam v 14 

what is the error i am getting while entering into Dataloader?

what is the error i am getting while entering into Dataloader?

Hi ,i am using Developer account to learn salesforce i installed Dataloader trying to enter to oAuth option with production but i am getting some error.

Can you guys suggest and give the cause..

User-added image
Arpit Jain7Arpit Jain7

Please do below 2 steps and you should be good to go

Step 1: Download the Latest version of Java: 

Step 2: Go to Setup > Type Data Loader in Quick find and download and install the latest version of Data loader. 

NagendraNagendra (Salesforce Developers) 
Hi Sairam,

This is because you are using an out of data loader. Delete the current one and reinstall the latest version.

You are all set to go.

From Salesforce Spring ’16 Release Notes - Data Loader (https://releasenotes.docs.salesforce.com/en-us/spring16/release-notes/rn_forcecom_data_data_loader.htm)
Starting in the first quarter 2016, Salesforce will begin disabling the TLS 1.0 encryption protocol. After Salesforcedisables TLS 1.0, any inbound connections to, or outbound connections from Salesforce will need to use the TLS 1.2 encryption protocol. This change impacts API-based software that Salesforce makes available for download, such as data Loader. The Spring '16 version of Data Loader has been enhanced to support TLS 1.2.
To maintain access to Data Loader, you must upgrade to the Spring '16 version of Data Loader and Java JRE 1.8. We recommend that you begin planning to support TLS 1.2 as soon as possible.

See also Salesforce disabling TLS 1.0 (https://help.salesforce.com/apex/HTViewSolution?id=000221207#DataLoader)

Please let us know if this helps.