+ Start a Discussion
Helen ParkHelen Park 

Business Administration Specialist Superbadge - Challenge 1 error

I keep getting the following error message, even after trying in 3 new playgrounds: 
Challenge Not yet complete... here's what's wrong: 
Some billing state names do not meet data quality standards, or the data import was unsuccessful.

I followed all of the instructions:
1. Installed unmanaged package in the new playground
2. Added Residential picklist type to Accounts
3. Cleaned up Account list:
a. Removed "Household" from Account name (this wasn't specified, but it didn't seem necessary)
b. Removed duplicate records
c. Changed accounts in ALL CAPS to only cap first letter of first and last name
d. Changed state name to 3 letter State code
e. Saved as .CSV file
4. Imported list using Import Wizard

I received an email confirming the import was successful with 11 rows processed and I see the accounts when I search up accounts in the playground. 

Thanks in advance for any help!
Alain CabonAlain Cabon
Hi,

Add the value Residential to the Account object’s field Type.  There is a picklist field named Type in the object Account.

That is not the exact instructions.  You added unnecessary constraints.
a. Removed "Household" from Account name 
d. Changed state name to 2 letter State code  ( Nevada => NV, New Mexico => NM )
 
Helen ParkHelen Park
Oh, thank you SO MUCH, Alain! I mass deleted the previously imported accounts, added back "Household" to each account name and re-imported the file. (I mis-typed 3 instead of 2 for the letter state code). Wow, I can't believe removing Household was the hold up. I will be sure not to add unnecessary constraints in the future. Challenge 1 completed, finally!!
Helen ParkHelen Park
Oh, thank you SO MUCH, Alain! 
I mass deleted the previously imported accounts, added back "Household" to each account name and re-imported the file.
(I mis-typed 3 instead of 2 for the letter state code). Wow, I can't believe removing Household was the hold up. I will be sure not to add unnecessary constraints in the future. 
Challenge 1 completed, finally!! 
 
Ashutosh Mishra 73Ashutosh Mishra 73
I got the same error, but i made all the parameter correct mentioned above this is the  problemthese are the recordthis is picklist value
Ashutosh Mishra 73Ashutosh Mishra 73
please help me with this
samyuktha reddy etikayalasamyuktha reddy etikayala
Hi,

While am doing BAS, am getting an error as below.am not getting an idea what wrong I did.

Kindly can help me on this

Challenge Not yet complete... here's what's wrong: 
The Account object does not have the correct values for the 'type' field.

Thanks in advance.

Thanks and regards,
Samyuktha.
Shirish AshwatShirish Ashwat
Go to Setup --> Customize Fileds -> Accounts and click on Type Filed to activate Residential Picklist value.
Residential Picklist Value is not part of the Picklist Values. After Upload of Data - you need to activate the picklist value. 
Hope this helps
WEI WANG 55WEI WANG 55
same issue :(
Kathy RussellKathy Russell
All, I have followed the instructions and when I do upload of my file I get error 'Id not specified in an update call' in the file. Any ideas how to resolve?

 
Kathy RussellKathy Russell
All I was able to resolve my issue and wanted to make a note here incase someone else comes across the issue. Resolution: I didn't realized in the Data Loader for the 'Create or Edit a Map that I needed to Drag the associated mapping from above down to my associated list. Once I did that I was successful with the upload.
Alexandra HullAlexandra Hull
I am having a similar issue. I ensured that all of my accounts have a type but am still getting the error "all accounts must have a type." 
Here is a list of my accounts:
User-added image
Any suggestions on what to do?
 
Hugo LemosHugo Lemos
Hi Alexandra,
Please check the spelling of the Account, from your screenshot I think it's missing an r from Barrass.
Ethan SeagravesEthan Seagraves
@Alexandra,

I ran into the same issue as you and came across this thread after a google search. I had ALL the accounds with a type, as directed.

However, I tried what Hugo suggested, adding the missing R in Barass, and sure enough, challenge verified. Makes no sense but here we are.
Adinarayana SakeAdinarayana Sake
Excellant , it took almost 2 hrs to complete the Fix and import data
Paranthaman ganapathyParanthaman ganapathy
Points to note:

1. The excel file with accounts has 4 duplicate entries, please delete those rows.
2. Change the account names in capital (count names should not be in all capital letters.)
3. All accounts must have a Type (Residental)
4. All Billing States must use the two-letter state abbreviation instead of spelling out the full name. (Change state names to CO,NM,NV respectively)
5.  Enable Residental Picklist value from Account object filed setting (Click Activate on Residental Picklist value from Inactive Values tab)
6. Upload the CSV file through Data loader (or) data loader online (https://dataloader.io/)

Note:
Incase of any issues if we want to delete all the record imported we can use SETUP> Data > Mass Delete Records
Condition: Account alias owner - Equals - Your nickname in org (Will return all records created/Imported) by you.

Goodluck!
 
Alok ShakyaAlok Shakya
Hi, I am just starting the challenge and not able to understand how to add the Residential account type. Can someone help please?
Paranthaman ganapathyParanthaman ganapathy
Hi Alok,

You can enable the residential account type by navigating to Account > Fields & Relationship > Type > Inactive Values > Activate.

Note: Please ensure that the unmamaged package provided for the exercise is installed in your ORG, else you will not be able to see the Residential account type in Inactive section.

Good luck!
 
Alok ShakyaAlok Shakya
Hi Paranthaman,

Thanks for replying but I've installed "Residential Sales" packaged(as pre-requisite) but still not able to see Residential account type in Inactive section.
I navigated to SETUP > Object Manager > Account > Fields & Relationship > Type > Inactive Values(No entry in this section).
Alok ShakyaAlok Shakya
Hi Paranthaman,

I added 'Residential' as new picklist entity and did rest of the activities to complete the challenge. Thanks for your help. 
karriche hakimkarriche hakim
Hi Ashutosh Mishra 73
Please folow these steps 
1 : Add Residential to the Account Type field
2 : Delete All Accounts record in your Trailhead playground
3 : save the lines below in a csv file and import it in your Trailhead playground
Account Name,Type,Rating,Billing State/Province,Account Phone,website,Billing City,Billing Zip/Postal Code,Annual Revenue
Sam Heath Household,Residential,Hot,NM,1234567890,https://twitter.com/trailhead,Odessa,94114,45000
Imran Pope Household,Residential,Medium,CO,3456789012,https://twitter.com/salesforce,Denver,80206,70000
Alice Wilson Household,Residential,Hot,NM,4567890123,https://twitter.com/salesforce,Fort Sumner,88119,30000
Lauren Barrass Household,Residential,Cold,CO,5678901234,https://twitter.com/trailhead,La Junta,81050,50000
Nathan Milstid Household,Residential,Medium,NM,6789012345,https://twitter.com/salesforce,Ruidoso,88345,40000
Noreen Drake Household,Residential,Hot,CO,7890123456,https://twitter.com/trailhead,Colorado Springs,80919,35000
Katie Abbasi Household,Residential,Cold,NM,8901234567,https://twitter.com/salesforce,Tucumcari,88401,45000
Pat Heath Household,Residential,Cold,NV,1234567890,https://twitter.com/trailhead,Odessa,12345,30000
Whitney Kelm Household,Residential,Hot,NV,1234567890,https://twitter.com/trailhead,Las Vegas,89104,75000
Cari Barlow Household,Residential,Hot,NM,2345678901,https://twitter.com/salesforce,Pie Town,87827,50000
Marcella Peperini Household,Residential,Medium,NV,9012345678,https://twitter.com/salesforce,Duckwater,89314,55000
Praveen Javali 8Praveen Javali 8
I had the following mistakes.
1) Over assumed that 'Household' redundant word was to be removed
2) Made a mistake in Barrass - (had as Barass)
3) I had a old managed package. Had to reinstall the same.

FYI: The system removes duplicates if you check the correct parameters.
deep kaurdeep kaur
Hi,
I follow all the above-mentioned steps but still, there is an error. Please help me out.

User-added image
Reddeiah R 3Reddeiah R 3
Hi,
I got below error, please help any one.
Some billing state names do not meet data quality standards, or the data import was unsuccessful.

Data Excel
 
Reddeiah R 3Reddeiah R 3
Hey,
Finally complated task. please find the excel.csv data.
User-added image
 
KerstinVKerstinV
Did anyone complete the challenge with the new Playground Starter App? I installed the package and it is listed in my org, but still i get the error: Residential Sales assets unmanaged package is not installed. Can anyone give me a hint?
deep kaurdeep kaur
I still have the same error. Try so many times.
Reddeiah R 3Reddeiah R 3
Hi Deep Kaur,
billing State no need three laters, need two laters only.
1.plz see my screenshot image(Increase zoom size see screenshot)
 
Reddeiah R 3Reddeiah R 3
Hey Kerstin Vanselow 3,
Example: 
1.https://brave-fox-j061hu-dev-ed.lightning.force.com  = my  Playground url
 2.unmanaged package : /packagingSetupUI/ipLanding.app?apvId=04t36000000jWht
3.url=  plaground url /unmanaged package 
 
Shivanand Totar 10Shivanand Totar 10
Challenge Not yet complete... here's what's wrong:
Account names are not in the correct format.
Ekta Gupta 37Ekta Gupta 37

Here is Error. ANy help ?
I made sure
1)all names are good but please see screen shot of my data as well 
2) Type has data in each and every row
3) FIrst I formated the Account name with PROPER function and got the desired result . As challenge was not getting completed I downlated account sheet again and changed the name manually . But it didnot help as well.  

Any suggestion . 
BA challenge 1

User-added image

 
Ekta Gupta 37Ekta Gupta 37
I resolved my problem by manully mapping the fields ( does not make much sense but did as recommended above be KAthie) . THx
Shivanand Totar 10Shivanand Totar 10
Thank you so much your kind help
Shivanand Totar 10Shivanand Totar 10
Thank you so much for kind help
Shirish AshwatShirish Ashwat
@Peter – I do not see your question on the forum. Guess you must have resolved your issue. Shirish Ashwat TriageIT Consulting Inc. M : 412/498.4160
Shivanand Totar 10Shivanand Totar 10
Thank you so much for kind help i solved it
ColbridgeColbridge
After you clean up the data in the .csv file, use Data Import Wizard. Choose the Add Data option and once you upload the .csv file, all fileds will be automatically maped correctly and import will be successfully completed. 
Meghraj Kurmi 6Meghraj Kurmi 6
if you still getting 
Challenge Not yet complete... here's what's wrong: 
Some billing state names do not meet data quality standards, or the data import was unsuccessful. error after following above steps then  follow this step

-From Account make first letter capital (In Two accounts name in the list all letters are in CAPS make first letter caps and remaining lower case) and do not remove household.
-Make all types as Residentials
-Make State as 2 letter 
-There are only 11 accounts Name unique in list so delete remaining

Remaining all same as above. It worked for me. 
 
AbhynavAbhynav
Those who are still struggling.
It's a bit strange but worked for me.
Please try to query the account in query editor in developer console. If you aren't getting the imported accounts, please logout and login again. If still not seeing the records in query, then please add sub-domain to your org and login with that and relaunch it from trailhead. Now try to get the accounts in the query editor. If you don't see them please import the csv again and try to check the challenge.
 
Afonso de SouzaAfonso de Souza
Thanks a lot, Alan Cobain! The unnecessary constraints were my issue!!!
Lakshmi teja 13Lakshmi teja 13
I've tried with different playgroud it worked for me
francis oshobfrancis oshob
After you cleaned up the data in Ms Excel .csv file, Using Lightning Experience, Select Account Tab, Select All Account from the List View, Click the Import button to import your .csv file. Change Colorado to CO and LAUREN BARRASS HOUSEHOLD TO Lauren Barrass Household.
This was how I got my to work. Good luck!!!
francis oshobfrancis oshob
Also, add Residential to the Picklist Values.
vignesh vickyvignesh vicky
Hi all even correcting all the things still you facing issue it may be the problem 

you need save excel file in CSV UTF-8 (comma delimited) format

for that if you having newer version of excel you directly select the above format in save as option

older version means save the excel  file normally open file  with note pad then file save as< save as type should all files and encoding should be UTF-8<then save and import that file

Hope it will works thanks
Akshay choudalwar 3Akshay choudalwar 3
Thanks for idea!  after activating type - picklist field . i am completed the challenge. 
Luisa Gonzalez VasquezLuisa Gonzalez Vasquez
Thank you Hugo! That was what happening! 
Christopher Zenner 8Christopher Zenner 8
Hello, 

Here is my attempt to show what I have been hung up on. I believe my spreadsheet is solid but I keep getting these errors? I tried Field Mapping in setup and I am still lost. What process might I be overlooking? I can send more screenshots if it helps. I have been all over the place trying to figure out why this is not mapping. All the field names match from what I can tell?

Thanks

ChrisUser-added imageUser-added imageUser-added image
Nathan EckelNathan Eckel
I ran into all sorts of issues/errors before finding this thread.

The key for me was to figure out how & where to add the Residential picklist item FIRST, BEFORE adding the cleaned .csv file.
Once I did this, and ensured I was properly logged in, it was no problem.

Previous to this I was getting all sorts of issues in the weeds with the mapping upon import... it was irrelevant once I did the picklist piece first.

Hope you also avoid the weeds, thanks to so many on this thread for your helpful posts!
Michael TüchelmannMichael Tüchelmann

Hey Guys, I sorta have the same problem with the first point of this superbadge. 

I started with a brandnew playground, installed the managed package, but I get when I check this error. 
User-added image
The upload is working, the field are correctly filled, as you can see. 
User-added image
Anybody has an idea what I can try next? 
 

Thanks!

Leonard Parke 5Leonard Parke 5

Hi,

Just ran into issues on this task, for me, simply clear out all the accounts and then try to import your accounts again.

Michael Tüchelmann

 

Chanderpal SinghChanderpal Singh
Full Solution 

Challenge 1 -Fix and import data

Points to note:

1. The excel file with accounts has 4 duplicate entries, please delete those rows.
2. Change the account names in capital (count names should not be in all capital letters.)
3. All accounts must have a Type (Residental) and put same in excel sheet.
4. All Billing States must use the two-letter state abbreviation instead of spelling out the full name. (Change state names to CO,NM,NV respectively)
5.  Enable Residental Picklist value from Account object filed setting or add it from Accounts→Type→New → Residential and save it
6. Upload the CSV file through Data loader or Data Import wizard and do mapping correctly (or) data loader online (https://dataloader.io/)

or You can have the csv file from this link -https://docs.google.com/spreadsheets/d/1uD7qvW-72iModWj7SuIk-LBehIw1ikcrXrxBoh1uxbU/edit?usp=sharing (Upload Directly all above steps have been done in this)

Imp- Delete all accounts before uploading the csv in your org . As the challenge check all entries of account.

Note:
Incase of any issues if we want to delete all the record imported we can use SETUP> Data > Mass Delete Records


Challenge 2 -Create users 

Username and Nickname -
1.abalewa@CP101221.com - 
Profile - Chatter Free → Chatter Moderator Free User

2.lulrich@CP101221.com
3.lpark@CP101221.com
4.edonaghue@CP101221.com
5.stashi@CP101221.com