+ Start a Discussion
pooja h 1pooja h 1 

Need help to solve challenge"Simplify your brokers’ account layout"

Hi,
"Simplify your brokers’ account layout
Your brokers also need a customized page layout for their accounts. To do this, click on Mobile and Lightning Actions for the Account Layout page layout, override the predefined actions, and then customize them.
In the object manager for Accounts, edit the Account Layout so that Mobile Smart Actions is the first item for Salesforce Mobile and Lightning Experience Actions "

User-added imageUser-added image

Thanks!
sfdcMonkey.comsfdcMonkey.com
Hi pooja , after add action to Salesforce Mobile and Lightning Experience Actions section save your account page layout and, click on Page Layout Assignment button on page layout screen
User-added image
and assign account page layout to admin profile and check again

Thanks
pooja h 1pooja h 1
Hi Piyush
I found System Admin profile and I assigned the Account Layout to the same.But I get the same error.

Challenge Not yet complete... here's what's wrong: 
Could not find the 'Mobile Smart Actions' quick action in the publisher for the 'Account Layout' layout. Make sure you have overriden the predefined actions and the Mobile Smart Actions action is the first item.

Please help 
Thanks
Sherif SohyounSherif Sohyoun
User-added image
Got the same error and did all.
pooja h 1pooja h 1
Hi Sherif,
User-added image
 press the highlighted arrow
User-added image
Click OK
User-added image
Click on override predefined actions
Hope it works for you
Thanks
Sabrina BELLOSabrina BELLO
Hi everybody,
I have the same error and tried all the proposed solution but the error still retreive. Is there some other ideas to check this challenge? Thx all ;)
thirumoorthy kandasamythirumoorthy kandasamy
You guys might be creating the new 'Mobile Smart Actions' for the challenge just delete what you created. The action already exists in the account page layout just use them it will work.
afzal parwezafzal parwez
No we are not creating new 'Mobile Smart Actions', did anyone got a solution for this???
nazeer ahammed 1nazeer ahammed 1
Performed successfully.
Angel BenedictAngel Benedict
@nazeer, how did you make it work? I tried everything and the same error. Thank you for your kind explaination in advance. Or can you please screenshot?
becky hodgmanbecky hodgman
i feel that ive done everything successfully and still not able to pass challenge

@nazeer, can you walk us through step by step start to finish?
Poojan mitPoojan mit
I was able to resolve it by adding the "Mobile Smart Action" on Account Layout. For some reason this quick action is not visible in the list of action.
do a quick search for Mobile and you will see the action. drag it on the lightning experience actions

User-added image
Paul Koivula 6Paul Koivula 6
I had the same problem and nothing would resolve it.  I finally had to create a new playground, then do the challenge.  That made it work.
Yogesh PrajapatiYogesh Prajapati
Undo All your changes or CREATE A NEW PLAYGROUND.
Probably the changes are not getting reflected on mobile app. I was able to complete the challenge but changes were not coming in App.
But I think there is no need to create the Event layout and Record type for this challenge.
We already have a 'Mobile Smart Actions' in Page Layout --> Account Layout.
Just Go to AccountLayout -- > Mobile andLighting Actions --> Drag and Drop
Yogesh PrajapatiYogesh Prajapati
@poojan mit Creating a new Action will duplicate the 'Mobile Smart Actions' under Account Layout which will create more confusion for Users. I also experienced the same
Yathisha MedaYathisha Meda
@Paul Koivula 6 Even though i Created the new playgroud still i am not able to complete the challenge
🌟 Anne-Marie Cuinier 🌟🌟 Anne-Marie Cuinier 🌟

Hello,

I have the same problem. Il created 2 new playgrounds and I have always the same error message. I can't complete the challenge :(

Khalil BabikerKhalil Babiker
Step 1:
   Click on Object Manger and select Account >>then Select the page layout.You will see that Account layout is already created from previous lesson (if not create new layout for the Account Object with the same name Account layout  )
Be Sure that Account layout exist! Before we go further …


 
 
STEP2:
Select 1 and 2 as shown below:

 
STEP 3:
 
Drag the Item Mobile Smart Action to be first item in the mobile and lighting experience area  as shown below .Click “save” in the top left Account layout toolbar.   Enjoye it …and continue to next challenge !

 
🌟 Anne-Marie Cuinier 🌟🌟 Anne-Marie Cuinier 🌟
Thank you :)
sadhana kumarisadhana kumari
@ khalil Babiker
Thank u 
Ajay K DubediAjay K Dubedi
Hi Pooja,
For pass, this challenge follows written instruction.
Step 1- Click Object manager.
Step 2-    Select the Page layout from the left Panel.
Step 3- Click on Account Layout.
Step 4- Click on Mobile & Lightning Actions.
Step 5- Select Mobile Smart Actions.
Step 6- And Save.

User-added image

I hope you find the above solution helpful. If it does, please mark as Best Answer to help others too.
Thanks,
Ajay Dubedi
Meghraj KurmiMeghraj Kurmi
Guys, if still you are getting error then
 Change Trailhead Playground and make sure that there is only one 'Mobile Smart Actions'(Dnt create 'Mobile Smart Actions' if you have already crated)  on account page layout.
Also if there are more page layout for account then add 'Mobile Smart Actions' for all and check, it will definately work.
Wilmer Reyes AlfaroWilmer Reyes Alfaro
Hi Guys
I have the same problem and i have follow all suggestions without success.
I hope somebody can help me
Thanks.
Juan Cubillos 7Juan Cubillos 7
Hi guys, i need to solve callenge

Simplify your brokers’ account layout
Your brokers also need a customized page layout for their accounts. To do this, click on Mobile and Lightning Actions for the Account Layout page layout, override the predefined actions, and then customize them.
- In the object manager for Accounts, edit the Account Layout so that New Contact is the first item for Salesforce Mobile and Lightning Experience Actions
kishoreRedkishoreRed
The Quick Action is defined by default in Sales Force Classic and all you have to do is switch to classic and add it to the layout.
 
Adith Rajasekharan 9Adith Rajasekharan 9
Guys plz dont put Mobile Smart Action as first button in Salesforce Mobile and Lightning Experience Actions. Put the New Contact option in first instead of Mobile Smart Action. 

Regards
Thanks
RAJESH M 71RAJESH M 71
when you drag the new contac tto salesforce mobile lightning experience actions
after that you have to move new contact to first like thisUser-added image
LakshyaLakshya
Hey!

When creating the action named "New Contact", make sure that the value against "Name" is as follows :

User-added image

Then you can continue to add the "New Contact" button in the first place post overriding the "Salesforce Mobile and Lightning Experience Actions" section.

This worked for me.

Hope it helps you!