+ Start a Discussion
Jarrell DunsonJarrell Dunson 

How do I log into Salesforce iPhone App with Trailhead instance?

Hello. 
  I can't login to the Salesforce App, using my trailhead instance... 

- The iPhone app gives me two options:  Production and Sandbox.  
- I have the option of logging into these (or adding a new account) + selecting an alternate domain. 
 -- The format for adding an alternate domain is stated:  https://domain.my.salesforce.com
However, when using trailheads (e.g., like this one: Create Global Quick Actions Unit | Salesforce Trailhead
https://trailhead.salesforce.com/trails/force_com_dev_beginner/modules/salesforce1_mobile_app/units/salesforce1_mobile_app_actions_global
)
... I use a trailhead instance, where the URL is:  https://brave-raccoon-000000-dev-ed.lightning.force.com
 {where the 000000 is my trailhead domain number, which I masked for this question} 

How do I log into Salesforce App with my trailhead instance? 

Thanks
 Jarrell
 
Jayant DasJayant Das
If you know your username and password for the trailhead playground (TP) instance, you can login using the Salesforce app as you would login in to any other org. You will just need to choose Production while logging in to TP orgs and provide your username and password in the app. You may be required to verify your identity by entering the verification code that you will receive on your email registered with the TP org.

To find out the username and password for a TP org, refer to this link -- https://force.desk.com/customer/en/portal/articles/2659738-find-the-username-and-password-for-your-trailhead-playground?b_id=13478
J HorowitzJ Horowitz
I seem to have the same issue - downloaded the app on my phone and logged in successfully using my TP assigned informaiton but the changes from the admin beginner course do not appear in my app.  Could be a user error of course.  Any ideas?
Ahsan Abbas AsgharAhsan Abbas Asghar
Facing the same problem. I created a Global Quick Action on my TP and try to access it on mobile app but it is nowhere to be seen. I am logged in on mobile app using dev user / password, but I use exactly same user / password pair to login to TP as well. Not sure how to resolve this and need support here.

Regards,
Ahsan
Patricia Kazimirow KazimirowPatricia Kazimirow Kazimirow
Ahsan, 

    I am having the same issue with this particular module.  The first time I tried the mobile app worked but the Showing field did not displayed any data.   I created a new TP (#3) & now this TP is not displaying the mobile format but the desktop format.  I tried to go back to the old TP (#2) and now I cannot even get in, it tells my password is incorrect (I did reset it ! ). LOL ... Been working on this for a day !

P.
Alesia Dvorkina (Trailhead)Alesia Dvorkina (Trailhead)

This is what worked for me:

1) Ensure in User Settings that the email assigned to your User record is the one you can access. For some reason, my Trailheads keep getting created with an old (company) email and I have to update it to my personal. If the email is incorrect, update the email in personal settings and go to your email to confirm the change. Your User record will continue to show the old password until you confirm via email. 
2) In Trailhead Playground Org find the "Playground Starter" app and click the Get Your Login Credentials tab.
3) Note your username and click the Reset My Password button. 
4) Check your email and click the link to reset your password (follow the instructions, you might need to provide the Verification Code that is sent to your email).
5) Download the Salesforce Mobile app on your OS app store. 
Use your username for your Trailhead Playground Org and your new password.

Good Luck!