+ Start a Discussion
Stephen MelvinStephen Melvin 

Trailhead to Alexa Account Linking Issues

I went through the entire walkthrough here.
https://trailhead.salesforce.com/projects/build-a-private-alexa-for-business-skill-for-salesforce/

I am having issues account linking to Alexa.
I posted to Amazons Dev forums already. Amazon is telling me now this is a salesforce issue:
https://forums.developer.amazon.com/questions/164732/error-a-salesforce-account-is-required-to-use-this.html#answer-164936

It says I linked the account successfully to Alexa. But now I get this error:
"You need to relink your Salesforce account in order to use this skill. I've placed more information on a card in your Alexa app."

Any idea what I need to do at this point? 

Stephen 



 
Stephen MelvinStephen Melvin
I get this:
Successfully Linked

But then I go back to test Alexa and I type: Alexa, open salesforce demo. Then I get this message

"You need to relink your Salesforce account in order to use this skill. I've placed more information on a card in your Alexa app."​

Alexa Error





 
Stephen MelvinStephen Melvin
I am getting this now on the AWS cloud watch. Any ideas?

"errorCode": "INVALID_SESSION_ID", "body": [ { "message": "Session expired or invalid", "errorCode": "INVALID_SESSION_ID" } ], "statusCode": 401
 
Stephen MelvinStephen Melvin
11 days and no replys from Salesforce.
N BragardN Bragard
Hi,
I have the exact same issue. Were you able to solve it?
Thanks for your help
Cheers
Nicolas
Chloe EchiksonChloe Echikson
I had the same issue and I think it's because I was actually logging into my default org and not the Salesforce Playground used for the Trailhead.

Click "Use Custom Domain" when logging in through Alexa and enter your Playground address and use the username generated for your in the Playground to log in (you may need to reset the password in Setup).

 
Rex Petersen 1Rex Petersen 1
Can anyone verify what the solution was to this problem?
Shrikanth_HMShrikanth_HM
I am getting the same erro. I have created a new connected app and linked again with that. Still no luck
Aditya Talwar 17Aditya Talwar 17
Check your domain name in constants file it should be something like : https://fab-bear-dev-ed.my.salesforce.com . It should end with my.salesforce.com and redploy the file using ask deploy --force.
Jessica TroianelloJessica Troianello
Hi - Having the same issue. I have logged in and linked with the correct trailhead sandbox, but it still is stuck in the look. Link account - Try- response to to relink account. Has anyone found a way to make this work??
 
Mitesh TrailblazerMitesh Trailblazer
This is still an issue I am stuck with. Problem it seems lies in the fact that the Authentication which needs to be there is not present. But then the linking process completed successfully. Can someone help with this issue I am facing. 

alexa, open salesforce demo
{
    "body": {
        "version": "1.0",
        "response": {
            "outputSpeech": {
                "type": "SSML",
                "ssml": "<speak>You need to relink your Salesforce account in order to use this skill. I've placed more information on a card in your Alexa app.</speak>"
            },
            "card": {
                "type": "LinkAccount"
            },
            "shouldEndSession": true,
            "type": "_DEFAULT_RESPONSE"
        },
        "sessionAttributes": {
            "numAttempts": 0,
            "lastRequest": null,
            "HAS_CODE": null,
            "STATE": "_WAITING_FOR_CODE_MODE",
            "CREATED_CODE": null,
            "CHANGED_CODE": null
        },
        "userAgent": "ask-node/2.7.0 Node/v10.19.0 ask-sdk-v1adapter/2.7.0"
    }
}