+ Start a Discussion
Jovonny CapetilloJovonny Capetillo 

Set Up the Exchange Rate hands-on. Challenge Not yet complete... here's what's wrong: We couldn’t find Currency Type and Decimal with the correct information. Ensure that you have selected the correct currency type and entered the decimal information.

I'm doing the Set Up the Exchange Rate hands-on but keep getting an error. I've doublechecked thing and I'm still getting this message  
Challenge Not yet complete... here's what's wrong:  
We couldn’t find Currency Type and Decimal with the correct information. Ensure that you have selected the correct currency type and entered the decimal information.
Venkatesh KashyapVenkatesh Kashyap
Im getting the same error all over again. Hope somebody gives a reply. I have tried logging out and logging back in. Still not working.
Michael RuckerMichael Rucker
I'm also having the same problem. Tried various combinations of things. No Luck.
The Decimal issue needs to be 2
John LayJohn Lay
Same issue here... anyone found the solution?
John LayJohn Lay
FYI: I tried moving to the next Module and got the same error after enabling multi date currency. Its like its not seeing the currency. I've queried the base data and its is defined as expected.  I've even created a new sandbox and started fresh. Same errors.
Jose Manuel Gonzalez AriasJose Manuel Gonzalez Arias
Hi,
I have the same problems. Create a new playground, double-checked things, review my initial settings... 
Please, let us know when and how this issue will be fixed.
Thanks
Johan KarlsteenJohan Karlsteen
I have the same issue, I managed to pass the first step "Set Up the Exchange Rate" by finishing step 3-5 but I still can't finish step 2.

I get the exact same error:
Challenge Not yet complete... here's what's wrong: 
We couldn’t find Currency Type and ConversionRate with the correct information. Ensure that you have selected the right currency type and entered the conversion rate.
Johan KarlsteenJohan Karlsteen
I got it to work now, this is how I did it:
  1. Create a new Trailhead Playground
  2. Set Corporate Currency to USD under Company Information
  3. I also set Language to English, Locale to English and Timezone to Los Angeles
  4. Start with Step #1 and now you should be able to pass Step #2
I'm guessing that the problem is that the Corporate Currency on a new Trailhead org is dependent on your setting so if you get a non USD-org from the start you might end up with problems.

(I posted the same anser in https://developer.salesforce.com/forums/ForumsMain?id=9060G0000005ctjQAA)
Michael Rucker 40Michael Rucker 40
I tried creating a new Playgound - same error - :(
I tried watching the logs in the developer console to see what was going on, but no logs are generated.
Michael Rucker 40Michael Rucker 40
Ok - just passed. Set EUR as Corporate Currency worked for me.
John LayJohn Lay
Setting currency as EUR worked for me, after I completed all the other modules. Once I completed the first I was able to complete the second but I think my issue with the secod was with the rate, I first entered 1.3 instead of 1.13.
I believe Johan's advice might be the key by ensuring the corporate currency and locale are set.
ScottHarperScottHarper
Set EUR as Corporate Currency worked for me also!
Derek Bennett 5Derek Bennett 5
Had the same issue as everyone else and heres how I solved it: So the first challenege called "set up the exchnage rate" I could not pass and keep gettig the error code, so I competed the second challenge "update the exchange rate with ACM" and successfully passed it. Then i came back to "set up the exchange rate" and checked the challenge and it suddenly passed. So for me the steps followed in the second challenge is what needed to be done in the first challenege. 
Rayad KhanRayad Khan
I changed the corporate rate to Euro. Nothing changed. Then I turned on Advanced Currency Management and it worked.
Darrin RobertsDarrin Roberts
This is what worked for me:
  1. Went to the next step and completed the instructions.
  2. When changing the "Dated Exchange Rate", I noticed it was asking me to change from "1.5". 
  3. I cancelled out, so now changes we be made and it would as it was before.
  4. I went to double check the current conversion rates and strangely enough the conversion rate was "1.0"
  5. I proceeded with ACM exercise and completed as directed by changing the conversion rate to "1.13"
  6. I then changed the previous DATED CONVERSION RATE, which held the "1.5" value to "1.0".
  7. I verified the ACM challenge and passed.
  8. I went back to the Exchange Rate challenge and passed.
I am not sure when the Conversion Rate shows a 1.0, but somehow the original of 1.5 is held in another field and doesn't change. 

Oh well...thanks to all the different suggestions, I was able to create a troubleshooting path.

Thanks everyone and hope this fix works for you!
Darrin RobertsDarrin Roberts
This is what worked for me:
  1. Went to the next step and completed the instructions.
  2. When changing the "Dated Exchange Rate", I noticed it was asking me to change from "1.5". 
  3. I cancelled out, so now changes we be made and it would as it was before.
  4. I went to double check the current conversion rates and strangely enough the conversion rate was "1.0"
  5. I proceeded with ACM exercise and completed as directed by changing the conversion rate to "1.13"
  6. I then changed the previous DATED CONVERSION RATE, which held the "1.5" value to "1.0".
  7. I verified the ACM challenge and passed.
  8. I went back to the Exchange Rate challenge and passed.
I am not sure when the Conversion Rate shows a 1.0, but somehow the original of 1.5 is held in another field and doesn't change. 

Oh well...thanks to all the different suggestions, I was able to create a troubleshooting path.

Thanks everyone and hope this fix works for you!
LetteLette
Hello, this is what worked for me:
I put Euro: 1.13 instead of Euro: 1,13 ... so the problem was the comma :)
Antonio QuentalAntonio Quental
worked for me too: set Corporate Currency to USD, Language to English, Locale to English and Timezone to Los Angeles (GMT-8)
Sushma InalaSushma Inala
I Have the same issue.
I went back one step and noticed, i had the rate as 1.3 instead of 1.13. Changing this fixed this issue for me.
Felice TufoFelice Tufo

I had the same problem.

Solved by setting the "Default Language" and "Default Locale" to English in both the "Company Information" page and in my personal settings page (Click top-right profile icon -> Settings -> Language & Time Zone)