+ Start a Discussion
Manuel Bustos 9Manuel Bustos 9 

error id 334342124 accessing new object


Hi,

    I've been following this module in trailhead: Lightning Experience Customization

after creating the object (energy audits) in a new playground, if i create a new record in lightning i get errors:
This page has an error. You might just need to refresh it. First, would you give us some details? (We're reporting this as error ID: 334342124)
Tehnical details:
Uncaught afterRender threw an error in 'ui:inputSmartNumber' [Invalid regular expression: /[^a-zA-Z]k(?:\)|(\)?(?:\))?)?$/: Unterminated group]
throws at https://playful-badger-466160-dev-ed.lightning.force.com/auraFW/javascript/bZa2QajUSmHCPiEKj7zMjw/aura_prod.js:34:15. Caused by: afterRender threw an error in 'ui:inputSmartNumber' [Invalid regular expression: /[^a-zA-Z]k(?:\)|(\)?(?:\))?)?$/: Unterminated group]
eval()@https://playful-badger-466160-dev-ed.lightning.force.com/libraries/ui/inputNumberLibrary/number.js:3:382
Object.unFormatNumber()@https://playful-badger-466160-dev-ed.lightning.force.com/libraries/ui/inputNumberLibrary/number.js:3:350
Object.convertInputValueToInternalValue()@https://playful-badger-466160-dev-ed.lightning.force.com/components/ui/inputSmartNumber.js:9:401
Object.hasChangedValue()@https://playful-badger-466160-dev-ed.lightning.force.com/components/ui/inputSmartNumber.js:11:216
afterRender()@https://playful-badger-466160-dev-ed.lightning.force.com/components/ui/inputSmartNumber.js:12:408

if i swtich to salesforce classic it works fine. 

Could anyone help?
regards
Narender Singh(Nads)Narender Singh(Nads)
Hi Manuel,
This is usually a temporary issue which gets fixed on its own.
A suggestion:
-Logout from your org and trailhead both. Clear browser's cache and cookies. Restart your pc/laptop. Login again and try.

If the problem still persists, try contacting salesforce support.

Let me know if it helps,
Thanks!
Manuel Bustos 9Manuel Bustos 9
Hi Narender, thanks for the information.
I cleared cache and cookies, restarted pc and problem persists.
I also tried to using the developer edition instead of playground, but same problem. Moreover, i go to create a new opportunity and i got the same problem.
Tried to contact support, but when i log in using my developer account, it does nothing, like if were not logged in, and continues asking me i have to log in to contact support.
Also tried Firefox instead of Chrome and had same problem.
This is a developer account i was no using, it used to work ok, i was with winter 17 last time i logged in, could it be something with summer 18?
regards
Narender Singh(Nads)Narender Singh(Nads)
I can't say conclusively if it has something to do with summer'18 release.

Btw have you tried creating a new trailhead playground?
Manuel Bustos 9Manuel Bustos 9
yes, i created a new playground and same problem. Now i'm creating a new developer account, on the new account it seems to work, at least new opportunity works.
Narender Singh(Nads)Narender Singh(Nads)
Cool!
Manuel Bustos 9Manuel Bustos 9
but the problem seems to be with playgrounds, i create a new one and dont work. and loggin to support seems not to work.
Manuel Bustos 9Manuel Bustos 9
can anyone tell me how to get support on trailhead? i have a developer account and cannot contact support, but trying to follow the tutorials with a new playground is not working on lightning, even creating a new playground.
Ruth ForeroRuth Forero
Hi,
I got same error in a sandbox and in production, when I try to create a contact or a lead this error shows up. 
@Manuel Busto 9 from a developer you can't contact support, you need an instance. Sorry, but I'll keep you informed about the case that I posted with saleforce.

Regards.
Manuel Bustos 9Manuel Bustos 9
Thanks Ruth, let me know if you got it solved
Ruth ForeroRuth Forero
I got it, just set the currency locale in company information. Don't ask me why, but this solve the issue. :D
Manuel Bustos 9Manuel Bustos 9
Thanks Ruth, dont really know if that was what solved, because after reading your answer, before implementing it i tried to create an opportunity in the same playground that i had trouble and it worked, i did not change the currency locale. Very strange!
If it happens again i will do what you did and let you know