+ Start a Discussion
Grzegorz Krawczyk 7Grzegorz Krawczyk 7 

Trailhead challenge: Restrict Login Hours and IP Ranges

Hi Guys,

I get an error message when trying to solve Restrict Login Hours and IP Ranges Challenge from Protect Your Data in Salesforce badge:
"We couldn’t find the correct login hours. Review the login hours in the step."
I set the Login Hours as in challenge - Mo-Fr 8am - 6pm and Sa-Su 12am - 12 am. Time zone which is shown in Login Hours is GMT+2 (Berlin). I guess that this times should be in PDT (GMT -7). When I change Company Time Zone to PDT, in Login Hours it is still GMT+2. I read, that once it is set, it won't chang. That means, Considering GMT-7, login hours should be 11pm - 8am. But than I get an error that Start cannot by later then End. Any idea how to set this?

Thanks!
Best Answer chosen by Grzegorz Krawczyk 7
Chris KieranChris Kieran
I solved by just going back to the login hours editing, slecting 'clear times' on all fields and then re-entering them.

All Answers

Chris KieranChris Kieran
I'm currently stuck here as well my hours all match the input data. Il let you know if I figure it out.
Chris KieranChris Kieran
I solved by just going back to the login hours editing, slecting 'clear times' on all fields and then re-entering them.
This was selected as the best answer
Grzegorz Krawczyk 7Grzegorz Krawczyk 7
Thanks Chris! It worked for me :)
Partha Pratim SarkarPartha Pratim Sarkar
Hi Guys,
Not able to complete the part named "Restrict Login Hours and IP Ranges" under "Protect Your Data in Salesforce " project. Reference Error Id: YEESWZXP. Org# 00D6F000002L8YI. Please help
lakslaks
Same problem here. Anybody got around it ? Clearing and  re-entering did not work for me.
VANITA KAREERVANITA KAREER
Hello All, 
I got the error every time i use the org, even though i use the new developer edition. 
While working on this trailhead, Step not yet complete in vanita.kareer@cibc.com.sit
There was an unexpected error while verifying this challenge. Usually this is due to some pre-existing configuration or code in the challenge Org. We recommend using a new Developer Edition (DE) to check this challenge. If you're using a new DE and seeing this error, please post to the developer forums and reference error id: LWVABOFX

Pls help!!
Thnku
Samrendra Singh 1Samrendra Singh 1
Hi Friendz,

I need your quick help on to complete the below challenge:
Unit:
Restrict Login Hours on the Support Profile

Error: 
Step not yet completed: 
We couldn’t find the correct login hours. Review the login hours in the step.

Steps performed: 
From Setup, enter Profiles in the Quick Find box, and select Profiles.
Click Custom: Support Profile.
Under Login Hours click Edit and set up the schedule.
Field                Value
Sunday         12:00 AM to 12:00 AM PDT
Monday         8:00 AM to 6:00 PM PDT
Tuesday        8:00 AM to 6:00 PM PDT
Wednesday   8:00 AM to 6:00 PM PDT
Thursday      8:00 AM to 6:00 PM PDT
Friday           8:00 AM to 6:00 PMb PDT
Saturday      12:00 AM PDT12:00 AM PDT

Input Screenshot:
User-added image

Time Zone: 
User-added image
Many thanks,

Sam
Samrendra Singh 1Samrendra Singh 1

Error: We couldn’t find the correct login hours. Review the login hours in the step.

Clearing the times and re-entering it did not help. Appreciate your quick help plz.
Paul RamsayPaul Ramsay
I was unable to verify step with a trailhead playground, but it worked with a developer edition
shyamala sudhir 3shyamala sudhir 3
Hello, Sarendra/Paul, 

Were you able to figure out the solution? Please let me know. I am trying to get the issue fixed as well. Thanks ! Shyamala
Barb LeungBarb Leung
Hi everyone,
I also have the same problem.  I have tried in a dev org and trailhead playground and neither worked.  I tried clearing times and redoing and still didn't work.  Any help would be much appreciated!  Thanks in advance!
Graham P CurranGraham P Curran
Hi everyone,
I think I figured out what the problem is here.

TLDR; For Saturday and Sunday choose the 12:00AM option at the top of the dropdown list.

For Saturday and Sunday, there are two options for 12:00AM. One at the top of the dropdown and one at the bottom. I initially chose the bottom options and got the same error as everyone here.
I went back and cleared the times but then noticed the 12:00AM options at the top of the list. When I used this the test passed. Hope this helps!
Amol RautAmol Raut
Hello Team,

There are two profiles
1) Custom: Support Profile
2) Support User

Please make your changes to 1) Custom: Support Profile and then click on check challenge.

Regards,
Amol A Raut
Adrian StanAdrian Stan
Thanks Graham, that works for me.
pranavi jampanipranavi jampani
Hello Everyone!! Don't click on the 'edit' before Custom:Support  profile. Try to click on the Custom: Support Profile  and start seraching for login hours .. 
yk reddyyk reddy
@Graham P Curran--You are awesome! By selecting the first 12:00 AM in the drop-down list helped me to overcome the error. Thanks for the help!
Error: We couldn’t find the correct login hours. Review the login hours in the step.
Giritharakannan DevarajGiritharakannan Devaraj
@Graham P Curran -Its works for me, thanks a Lot.
 
raj muppallaraj muppalla
I had similar issues. none of the above suggested worked for me.:-(
I have also verified Help which got me confused (not so helpful note... may need rewrite)
https://help.salesforce.com/articleView?err=1&id=login_hours.htm&type=5
" NOTE The first time login hours are set for a profile, the hours are based on the org’s default time zone as specified on the Company Information page in Setup. After that, changes to the org’s default time zone on the Company Information page don’t affect the time zone for the profile’s login hours. The profile login hours remain the same, even when a user is in a different time zone or the org’s default time zone changes.
Depending on whether you’re viewing or editing login hours, the hours appear differently. On the profile detail page, hours appear in your specified time zone. On the Login Hours edit page, the hours appear in the org’s default time zone.
"

What worked for me  (based on my experience):
step1 ; "Clear all times"
step2: enter sunday start time 12.00am (I am in atlanta but ignedAll times are in (GMT-07:00) PDT (America/Los_Angeles)"
step3: enter sunday end time 12.00am (instead of monday start time)
step4: enter monday start time 8.am (ignore again "All times are in (GMT-07:00) PDT (America/Los_Angeles)")
step5: enter monday end time 6.pm (ignore again "All times are in (GMT-07:00) PDT (America/Los_Angeles)")
...........
............
step14:enter saturay start time 12.00am ( ignore "All times are in (GMT-07:00) PDT (America/Los_Angeles)"
step14:enter saturay end time 12.00am ( ignore "All times are in (GMT-07:00) PDT (America/Los_Angeles)"


and .. IT WORKED!









 
zied ben ayedzied ben ayed
thanks Graham, your solution worked for me
Nuca ConnectNuca Connect
Hi,
this thrailhead made me crazy!

As someone had told, could be 2 things to verify:
1) select the correct value of "12 AM", the above choiche (both for start and end value)
2) the most unpleasent problem, you need to use a correct playground, with the right Company  Default Time Zone setted to "(GMT-08:00) Pacific Standard Time (America/Los_Angeles)".
User-added image
I don't know why, but it is not enought changing this configuration after you had already created the playground. You need to create a new playground directly with this information. I had already had this problem with another thrailhead regarding currency configuration.