+ Start a Discussion
Ti Saunders 8Ti Saunders 8 

Process Builder - Flow Error

I created a new process to update an account field (call_stage__c) whenever a new task is created. Basically, it just changes the picklist value to increase to the next call (e.g. call1 to call2, call2 to call3, etc.). This is working just fine when creating tasks for Accounts, but I keep getting this error when creating tasks in Leads. 

I noticed that this only happens when I use a type formula in the process and doesn't seem to happen when type=formula. I have a separate process that works pretty much the same, but I'm using type=picklist (this is under "immediate actions"). The formula I'm using is:

IF(text([Task].Account.Call_Stage__c)= "call1", "call2",
IF(text([Task].Account.Call_Stage__c)= "call2", "call3",
IF(text([Task].Account.Call_Stage__c)= "call3", "call4",
IF(text([Task].Account.Call_Stage__c)= "call4", "call5",
IF(text([Task].Account.Call_Stage__c)= "call5", "call6",
IF(text([Task].Account.Call_Stage__c)= "call6", "call7",
IF(text([Task].Account.Call_Stage__c)= "call7", "call8",
IF(text([Task].Account.Call_Stage__c)= "call8", "call9",
IF(text([Task].Account.Call_Stage__c)= "call9", "call10",
IF(text([Task].Account.Call_Stage__c)= "call10", "call11",
IF(text([Task].Account.Call_Stage__c)= "call11", "call12",
IF(text([Task].Account.Call_Stage__c)= "call12", "call13",
IF(text([Task].Account.Call_Stage__c)= "call13", "call14",
IF(text([Task].Account.Call_Stage__c)= "call14", "call15",
IF(text([Task].Account.Call_Stage__c)= "call15", "call16",
IF(text([Task].Account.Call_Stage__c)= "call16", "call17",
IF(text([Task].Account.Call_Stage__c)= "call17", "call18",
IF(text([Task].Account.Call_Stage__c)= "call18", "call19",
IF(text([Task].Account.Call_Stage__c)= "call19", "call20",null)))))))))))))))))))

I'm getting "The flow failed to access the value for myVariable_current.Account.Call_Stage__c because it hasn't been set or assigned." whenever my process runs ONLY FOR LEADS.

​Any help is much appreciated!
kamala swarnalathakamala swarnalatha
Hi,

Did you select the process invoked by another process in the action.

Thanks,
K.Kamala,m
Sweet Potato Tec.
Ti Saunders 8Ti Saunders 8
No I did not.
Here is how I currently have setup:

User-added image
User-added image
User-added image