+ Start a Discussion
Magda FiluszMagda Filusz 

Visual Workflow Error in Preview Sandboxes

Hi Everyone,

We have a custom button on the opportunity object that launches a visual workflow. When we click on the button then we get the following error:

An internal server error has occurred An error has occurred while processing your request. The salesforce.com support team has been notified of the problem. If you believe you have additional information that may be of help in reproducing or correcting the error, please contact Salesforce Support. Please indicate the URL of the page you were requesting, any error id shown on this page as well as any other related information. We apologize for the inconvenience. Thank you again for your patience and assistance. And thanks for using salesforce.com! Error ID: 1111334745-41863 (1521962377)

The same error occurs in all preview sandboxes. The flow works correctly in the production and in our Non-Preview sandbox. So, I think it might be related to the Winter Release as it worked correctly when we were on the Summer Release.

Do you have any idea what might be causing this error?

Thanks,
Magda
NagendraNagendra (Salesforce Developers) 
Hi Magda,


Sorry for this issue you are encountering.

This type of error indicates that an error has occurred that hasn't been trapped by the platform - a low-level java exception for example.
 
If you need to move quicker than, start removing functionality from the component to isolate where the problem occurs and see if there are any other mechanisms you can use.

If the problem continues may I suggest you please clear all the cookies and cache and log out of all accounts and log in once again which should resolve the issue.

Still, if the problem persists give a try by attempting the same in a different browser which should do the trick.

Hope this helps.

Please mark this as solved if it's resolved so that it gets removed from the unanswered queue which results in helping others who are encountering a similar issue.

Thanks,
Nagendra
Magda FiluszMagda Filusz

Hi Nagendra,

Thanks for your answer.

We have tried to launch the flow using different browsers and we have also cleared our web browser's cache, cookies, and history. It still does not work. 

I have checked the syntax on my custom button and I get the following message: 
<span class="validStyle">No syntax errors in merge fields or functions.</span>

Is it possible that there is something wrong with my button that cases this issue?
The same error message appears after checking syntax on the button in the production and the process works there properly.