+ Start a Discussion
sarah john 4sarah john 4 

Talend - IOException: com.sforce.sw.ConnectionException: Failed to get next element

I have been using Talend for about two years to load data into Salesforce from files and have not had an issue. All of a sudden, over the weekend it has stopped working with about 20 of my standard loads (to different orgs).

Initially I got this error

"Exception in component tSalesforceOutputBulkExec_1_tSalesforceBulkExec (CustomerLoadSourcesNoEmail) org.talend.components.api.exception.ComponentException: UNEXPECTED_EXCEPTION"

I tried to just re-connect with a basic connection element and got this

"IOException: com.sforce.sw.ConnectionException: Failed to get next element"
I have been using Talend for about two years to load data into Salesforce from files and have not had an issue. All of a sudden, over the weekend it has stopped working with about 20 of my standard loads (to different orgs).

Initially I got this error

"Exception in component tSalesforceOutputBulkExec_1_tSalesforceBulkExec (CustomerLoadSourcesNoEmail) org.talend.components.api.exception.ComponentException: UNEXPECTED_EXCEPTION"

I tried to just re-connect with a basic connection element and got this

"IOException: com.sforce.sw.ConnectionException: Failed to get next element"

I assumed the issue was Talend or Java update so I have tried everything from rolling back java, reinstalling from scratch to installing on another fresh computer.

Current setup is:

Windows 10
Talend 7.01.20180411_1414
jdk1.8.0_171
So I am starting to get the feeling it might actually to do with a Salesforce release and not Talend or Java problem.

I noticed this old article with the same error https://developer.salesforce.com/forums/?id=906F00000008yx5IAA

Anyone seeing anything like this recently?
NagendraNagendra (Salesforce Developers) 
Hi Sarah,

Sorry for this issue you are facing.

May I suggest you please refer to below link from the stack exchange community exactly with a similar discussion which might help you further with the above issue. Hope this helps.

Kindly mark this as solved if the reply was helpful.

Thanks,
Nagendra