+ Start a Discussion
Efosa OgbomoEfosa Ogbomo 

Having trouble completing "Customize compact layouts"

1.Create a new event compact layout with the label: Showing Mobile Layout
2.Add the following fields to the compact layout in this order: Subject, Start, Property, Name.
3.Make the new compact layout the default for the Showing record type. (Hint: Do not change the primary compact layout for events. Enable the new 4.Showing compact layout in the Record Type Overrides section of the layout assignment editor.

For step 2. I don't have the option of the Property field and am unable to add it as a custom object to Event in the Schema Builder.
Also getting error id INDQUWUO
Best Answer chosen by Efosa Ogbomo
Wolfgang KampkötterWolfgang Kampkötter
Goto Activity Custom Fields and create a new field "Property", Text 255. In step 4 ensure that Event Layout is marked. Then you find this field in the event compact layout settings as well.

All Answers

Juan Jose DominguezJuan Jose Dominguez
Same here. I'm getting the exact same error. Not sure how to continue. Has anyone found a way to get this challenge passed?
Wolfgang KampkötterWolfgang Kampkötter
Goto Activity Custom Fields and create a new field "Property", Text 255. In step 4 ensure that Event Layout is marked. Then you find this field in the event compact layout settings as well.
This was selected as the best answer
Pablo Macias 3Pablo Macias 3
I did that and the field appeared and I added to the compact layout without a problem. Now in the point 3, I got this error message: "The 'Showing Mobile Layout' compact layout does not appear set as the default layout for the 'Showing' record type." Any help?
Zahid Akhtar 5Zahid Akhtar 5
Got same error on Step 3 while taking Challenge, Please advice

Challenge Not yet complete... here's what's wrong:
The 'Showing Mobile Layout' compact layout does not appear set as the default layout for the 'Showing' record type
Javier Peña LucenaJavier Peña Lucena
To avoid this error:
    The 'Showing Mobile Layout' compact layout does not appear set as the default layout for the 'Showing' record type

You have to create a new 'Record Type' called: Showing, and set the compact layout as default:

User-added image

good luck
Zahid Akhtar 5Zahid Akhtar 5
Thanks Javier, After adding "Showing" Record Type for Event object, It is working fine now. Thank you for help.

Note - Record Type name should be "Showing" only, otherwise it will not work properly.
 
Zahid Akhtar 5Zahid Akhtar 5
User-added image
Dexter MartinDexter Martin
This is extremely painful. It seems that it does not matter how many times you try and perform a Compact Layout Assignment to try and change the Record Type Overrides from the System Default to the Showing Mobile Layout and save it the system reverts back. It absolutely not allow you to save the Record Type Overrides from the System Default to the Showing Mobile Layout which is what the lesson is asking you to do. I am not sure anyone has solved this.
Sameer KhassawnehSameer Khassawneh
if you have 2 Record Types just make showing not active (edit ---> uncheck active) and this should work.
 
Sophath MeySophath Mey
I have been stuck on the Showing Mobile Layout for two days now. Thanks Sameer for your comment that was the right answer. I had to go to the Event Record Types and uncheck the active option and only make the Showing Record Type the active one. 
Peggy CHEUNGPeggy CHEUNG
Hello Dexter,

I experienced the same struggle as you and found that I didn't highlight the record type, and so no change can be applied.

You need to click  "Showing" under Record Type make sure it'll be highlighted as purple (and you will see the purple box next to "Compact Layout to Use"' showing "1 selected"). Then pick "Showing Mobile Layout" from the "Compact Layout to Use" drop list (the yellow box will now show as "1 changed"), and click "Save". This should work.
 User-added image
Joan PowellJoan Powell
I select and save on mine, and it doesn't seem to save it, keeps defaulting back and then I get the error on challenge.
User-added image
Joan PowellJoan Powell
Never mind.  Peggy I reread your comment and realized what you meant about highlighting.  Thanks! :)
An Ng 3An Ng 3
Thanks Peggy,

Again...select the row first!! .... "You need to click  "Showing" under Record Type make sure it'll be highlighted as purple"
Somnath GaraiSomnath Garai

@Efosa 

The solution has been given by Wolfgang Kampkötter

Kindly closed this question and mark as solved