+ Start a Discussion
Joe Doyle 20Joe Doyle 20 

Trailhead Button not showing

Hi, 

I'm currently doing the walkthrough for "Lightning Experience Customization". On the section of "Create a Custom Detail Page Button", I am trying to create a new button called "Map Location". The issue is that after I create the new button and add it to the page layout, it is not showing up. 

Trailhead says I should "Expand the actions menu, and select Map Location." but when I do that, it does not appear. 

I have already updated the page layout so I don't know why it isn't showing up. 

Thanks,

Joe

Best Answer chosen by Joe Doyle 20
Shawn KurugantiShawn Kuruganti
@Joe

I figured this out today, it seems ths Trailhead documentation is out of date for the Lightning experience. You need to actually change the page layouts "Salesforce1 and Lightning Experience Actions" to include the "Map Location" button you created. This is actually the section that edits this dropdown.

The Buttons section affects the classic page layout. So if you go to the classic layout you will see your button, but to see the change in the lightning dropdown you must add it the the "Salesforce1 and Lightning Experience Actions" section.

I hope this helps!

Thanks,
Shawn

All Answers

DeepthiDeepthi (Salesforce Developers) 
Hi Joe,

As explained in the module, you need to create a button for the Account object, and get that button added to the Account Layout. After creating the button, click on Page Layouts and then select the Buttons category visible on the left. Now, you can see the Map Location button and drag it to the custom buttons area and then save.

Hope this helps you!
Thanks,
Deepthi
Shawn KurugantiShawn Kuruganti
I'm having the same issue,

Please let me know if you figure it out... perhaps a limit to how many buttons will show up? Checked the button in the object settings, and made sure I have the proper layout assigned, but I can't see it.

Thanks,
Shawn
Shawn KurugantiShawn Kuruganti
@Joe

I figured this out today, it seems ths Trailhead documentation is out of date for the Lightning experience. You need to actually change the page layouts "Salesforce1 and Lightning Experience Actions" to include the "Map Location" button you created. This is actually the section that edits this dropdown.

The Buttons section affects the classic page layout. So if you go to the classic layout you will see your button, but to see the change in the lightning dropdown you must add it the the "Salesforce1 and Lightning Experience Actions" section.

I hope this helps!

Thanks,
Shawn
This was selected as the best answer
M.E. 10M.E. 10
Thank you!!
Joe Doyle 20Joe Doyle 20
Perfect, thanks Shawn!
Michele CoteMichele Cote
@Shawn - I've added the button to the section but it's still not displaying.  Wondering if you could help spot what I'm doing wrong...
User-added image
User-added image
Rahul VaishnavRahul Vaishnav
Hey Guys...! I Solve This Trouble. What u only have to do is :-
Go to Page Layout Section >> Account Layout >> Click On Mobile And Lighting Actions >> Then U See Map Location There >> Drag it To Salesforce Mobile and Lightning Experience Actions >> Then Quick Save it First >> Then Click on Save... And now you see Then It get to be added to your org.
Thanks
Somashekar Kempakumar 4Somashekar Kempakumar 4
@Rahul Vaishnav - Thank you. Your solution worked!
sushanth reddy mile 7sushanth reddy mile 7
@rahul Vaishnav thanks for the answer
Daria GMSDaria GMS
User-added image
Daria GMSDaria GMS
I thought visualizing it would help. I believe this piece of information is missing from the trailhead tutorial. 
Josh Comer 11Josh Comer 11
Hi,

I am running into a similar problem. I am currently doing the hands on challenge where it requires you to create a custom button. I am at the part right now where I have created the button, but it won't show up in the list for the buttons and is not in "click on mobile and lightning actions".

Any suggestions here?
Anwar MoideenAnwar Moideen
Hi All,

Try using a diffirent trailhead playground Org. Initially, i was unable to view using Dev org and later tried changing my org which worked for me. 
 
Iswarya RamasamyIswarya Ramasamy
Few information is missing in the trailhead instruction part. I had the same issue. As Rahul Vaishnav Mentioned earlier, following this step works. You can solve this unit.

Go to Page Layout Section >> Account Layout >> Click On Mobile And Lighting Actions >> Then U See Map Location There >> Drag it To Salesforce Mobile and Lightning Experience Actions >> Then Quick Save it First >> Then Click on Save... And now you see Then It get to be added to your org.