+ Start a Discussion
Kyle Johnson 46Kyle Johnson 46 

How do I edit the behavior of a custom 'Clone' button with product lines to exclude a field within in the product detail?

SalesForce Customer support has requested I seek assistance here, I am hoping you can help me!


I would like to exclude a custom object that we have called 'billing schedule' from our cloned opportunities with product lines.

I have followed the steps within the following links:

https://help.salesforce.com/articleView?id=000230954&type=1&language=en_US
https://success.salesforce.com/answers?id=90630000000iCIYAA2

But I am unable to accomplish what I need, here is an example of what I have:
User-added image

And here is the Field:

User-added image

Thanks!
Terri T JilesTerri T Jiles
Hi Kyle,

It looks like you may need to replace {!OpportunityLineItemId} with {!Opportunity.Id}, based on what I see Clone Opportunity Line Items section of the instructions you posted. https://help.salesforce.com/articleView?id=000230954&type=1&language=en_US

Good luck and please let us know if that works for you.  
Kyle Johnson 46Kyle Johnson 46

Terri,

Thanks for your reply. Unfortunately, I have tried that as well, I wonder if it could be an issue with not knowing HTML ID. I have searched for the HTML ID in the inspect window. 

User-added image

I also think I need to clarify, it is not copying the schedule over but is copying the product and within the product, there is a field called Billing Schedule and in that field, it is copying over the billing schedule number. The path where the issue is happening is Opportunity>Opportunity Product> Billing schedule.  Not Opportunity>Billing Schedule. 

Let me know if that helps to clarify. Also, I appreciate your help, I was given the 'opportunity' ( a task that I have loved, but can be frustrating) after our system admin left, to tackle implementing Financial Force into our org and it is 98% done with these small issues coming up. No previous coding, development, or anything else. So, thank you!

Terri T JilesTerri T Jiles
Hi Kyle,

My apologies for the delayed response.

I think you need to change the id to CF00N3100000Fuw2I_ilecell.  In the td tag you have highlighted, it is the id parameter.

Note:  If you are working in a sandbox environment, the id for that field may change when you deploy your work to production.  You may have to update the button in production.

Good luck!