+ Start a Discussion
AndrewTaylorAndrewTaylor 

Set Up Single Sign-On for Your Internal Users Challenge - Could not find SAML Enabled in your org's setup audit trail

I'm trying to complete the "Set Up Single Sign-On for Your Internal Users" Trailhead challenge, and was able to execute the description of the challenge successfully. However, I'm getting the following error when checking the challenge on Trailhead:
 
Challenge Not yet complete... here's what's wrong: 
Could not find SAML Enabled in your org's setup audit trail. Make sure that you have 'SAML Enabled' checked under 'Federated Single Sign-On Using SAML' in your org's 'Single Sign-On Settings'.

I've reviewed the settings, and "SAML Enabled" is true, and I'm connected to the right org when doing the challenge. Has anyone else encountered this?
Rick MasonRick Mason
I too have the same problem. It seems Trailhead is very buggy on some trails.
User-added image
User-added image

Any answers on this question?
AndrewTaylorAndrewTaylor
I never got a response on this, so still stuck on it.
Dawn Johnson 4Dawn Johnson 4
I got the same issue.  I have doubled check and everything looks ok. I tested two times and I was sucessful both times to login using the app.  This is frustrating.  I even ran the audit log and it shows that I checked SAML enabled.  Please fix the problem.  I want the badge.  This is also needed for a super badge I want.  Thanks in advance.
Tim VerheydenTim Verheyden
Same issue here, this is very annoying... :-/
Tim VerheydenTim Verheyden
@aj2taylo2010 I had a hunch for fixing this bug; I assume you're using your trailhead playground to do this challenge? As it is already using some sort of SSO I think Trailhead gets confused and bugs out. Sign up for a new developer org (and to be on the safe side configure it like they do with the e-mail and stuff, so it's a 1:1 copy) and try all the steps again. I just obtained my badge, so it works!

Let me know if that fixed the issue for you!
AndrewTaylorAndrewTaylor
Thanks Tim - that seems to make sense. At the moment, I'm at 10 connected orgs, which might be the limit (it's the limit in spinning up a new playground at least). Did you do this by creating the developer org, then connecting it to your Trailhead account after the fact?
Tim VerheydenTim Verheyden
Hey there, that is correct. Just create a new dev (not a playground) and then link it to your trailhead in your settings (or alternatively by clicking on "log into a developer edition") - by mindful that you might need to wait a few minutes before you can actually link it to trailhead, mine was returning an error after I just created it, but it linked up fine after a few minutes. You can see my new Jed-Eyetech org as the third option for a hands-on org to use since I already created it.

User-added image
Katie DaleKatie Dale
Thank you! Works for me now too :)
Tim VerheydenTim Verheyden
@katie Dale, @aj2taylo2010 - would you mind clicking on the thumbs up next to the answer? That way other users will also be able to find this
Peter Thompson 21Peter Thompson 21
I had this issue, and then I figured it out.
I un-enabled that checkbox in SSO settings, then re-enabled. Checked answer and it worked.
Dawid NawrotDawid Nawrot
Peter Thompson was right. It made sense because the error says we need to have an audit of enabling it, so the only way to do it is disable, save, and then enable and save
BerginBergin
Thanks to @Tim, it worked when I switched from Trailhead playground to my dev org.
 
updesh singhupdesh singh
@peter thomson 21  thanks, your suggestion worked
Kyle Cunningham 6Kyle Cunningham 6
I'm pretty sure what's actually being checked in the trialhead here is the event where SAML Enabled goes from False -> True. If you're using a trailhead org then this setting is already true. I was able to get around this by first setting SAML Enable = False, saving and then setting it to True and saving. Hopefully this works for some other people as well.
Remy Debertonne 6Remy Debertonne 6

I had the same issue that you guys. I was working on like the 4th org on my list.

What I have just done is login into the 1st org of my list.
Then I have disable the  'SAML Enabled" and then enable it again.
After that I launched my 4th org again where I was doing the challenge.

And bingo, I have been able to correctly check this challenge!

Richard Evans 23Richard Evans 23
YOU CAN USE A NEW PLAYGROUND ORG-DOES NOT HAVE TO BE A DEVELOPER ORG. The Playground already is created with SSO Enabled that is tripping everyone up. On Single Sign On Settings Edit > Uncheck SAML Enabled and SAVE. Then Edit Enable (check) SAML Enabled. If you followed along with the training for user sia@jedeye-tech.com (federated), then repeat what you have already done and BAM you get a "Shiny New Badge"
João Lopes 5João Lopes 5
Guys, got the same problem and managed to fix it very easily.
just go to single sign-on settings > disable SAML. > Enable SAML again and that's it.
Sai Bharadwaj GotetiSai Bharadwaj Goteti

I tried what Remy Debertonne 6 had said and it worked for me . Thanks . 

 
Asmit__cAsmit__c
I Encountered this issue and two things which are most important to resolve this are
1) Use your domain name in Federation Id which you can find from Setup -> MyDomain rather than just copying the one provided in the module.
2)After you are done with all the steps and you are still facing the issue,Just Deactivate the SAML and Enable it again. (Single Sign-on Settings-> Enable SAML)

User-added image
nirbhay shrivastavanirbhay shrivastava
I tried the workaround provided by Peter Thompson 21 and it work fine for me! Thanks
Gabriel ChapmanGabriel Chapman
I ran into this same issue, and it is because when you test out the integration, you are now logged in as Sia the test ser rather than yourself as owner of the Playground. I simply logged back into the org and got my badge!
Tim DarchTim Darch
I ran into the same issue as well - Thanks Peter Thomson 21
Tamal chakrabortiTamal chakraborti
Peter Thompson was right. It made sense because the error says we need to have an audit of enabling it, so the only way to do it is disable, save, and then enable and save!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Kr. Rohit YadavKr. Rohit Yadav
@Peter Thompson, that's correct, I did uncheck saved then check saved, then it worked. Thanks ! :-)
Devender Baghel 8Devender Baghel 8
Even I had the same issue and was trying to resove this one with plaground edition but it was giving same error message. Tried with my own dev edition org and it worked without any issue. Thanks :) 
Duc Le 8Duc Le 8
@Peter Thompson 21 is totally right. I wish somebody can ping his answer into the top!
Parul Singh 17Parul Singh 17

Hi @Devender,
In case you or somebody else haven't figured it out: you need to uncheck the box, then save, then check the box, and then save again.
If even that fails, get a new developer org (not a trailhead playground, simple dev org) and re-do the whole exercise in there.

Even it also works for me. !!

parul

Harun TürkogluHarun Türkoglu
I'm very relieved that "uncheck + save , check save" solved the problem, it was so frustrating....
Anish Vishwakarma 13Anish Vishwakarma 13
Hey Everyone, 

for this problem Just Uncheck the SAML Enable checkbox and save then check the checkbox again and save after that you shouldn't be getting this errror anymore.
Vikas Sawant 6Vikas Sawant 6
Thanks Anish it worked for me. This sounds wierd but worked, thanks a lot for the suggestion.
wvutriwvutri
This is what worked for me, using the actual login credentials of my org instead of the given ones in the example: 
"I Encountered this issue and two things which are most important to resolve this are
1) Use your domain name in Federation Id which you can find from Setup -> MyDomain rather than just copying the one provided in the module.
2)After you are done with all the steps and you are still facing the issue,Just Deactivate the SAML and Enable it again. (Single Sign-on Settings-> Enable SAML)"
genevieve mcculloch 22genevieve mcculloch 22
Hi All, 

 So glad that this thread is here.  I am slaving over this badge and it's driving me nuts.  Here are my questions/problems:

- I am doing this in a developer org
-  the Federated Single Sign-On Using SAML box SAML Enabled is checked.  And, per the discussion in this thread, I did try unchecking this, saving, checking again, and then saving. 
- in setting up the original Sia Thripio user, I had to modify the login name because the userid is elsewhere in the org.  So Sia' username in my org is:sthripio.alfie@jedeye-tech.com.  Now, that value is what should be in the Federation ID field of this userid, correct?
- on the Single Sign On Settings screen, I have some questions:
  ..  the value for Entity Id is the developer org url, https://na172.salesforce.com. I did not customize the domain, am just using this value from the url.  Was I correct in doing this?
  . I do not see the radio button Service Provider Initiated Request Binding, so I can't select HTTP Redirect.
  .
I do not see Salesforce Login URL at the bottom of this page; there is nothing after Just-in-time User Provisioning.

On the Axiom generate a SAML response, I have these questions:
. Username OR Federated ID is sthripio.alfie@jedeye-tech.com
  Recipient Url - if Salesforce Login URL is not at the bottom of the Single Sign On Settings screen, so I used this value from when I first set up the developer org: login.salesforce.com 
 . the default value for Entity id is https://saml.salesforce.com, but I should be using https://na172.salesforce.com, correct?

Btw, I did Generate Response and then tried to log in,using user-defined values:
. Recipient Url =  login.salesforce.com
.
entity id = https://saml.salesforce.com, also tried my own value of https://na172.salesforce.com.  Same results
. and got this message:

Insufficient Privileges
You do not have the level of access necessary to perform the operation you requested. Please contact the owner of the record or your administrator if access is necessary


I've tried this in a new playground, in a developer org; have started brand new each time.  Pretty much know the field values for all the screens by heart.  Would appreciate any insight on this.  Thanks!
Nitish GoyalNitish Goyal
I first disabled the SAML Enabled checkbox then enabled again and It works for me.Try this trick one more time.
Thanks,
POGULA SAI LAKSHMI PRASANNA GREESHPOGULA SAI LAKSHMI PRASANNA GREESH
Thanks, @Nitish Goyal it helped me.
Joey Maltese 5Joey Maltese 5
i am in the dev org. i have done all the coreect steps. It wont let me deselect checkbox for SAML. I still get the same error. Even though it wont let me deselect, meanign it is always selected i still get the same error. 

Could not find SAML Enabled in your org's setup audit trail. Make sure that you have 'SAML Enabled' checked under 'Federated Single Sign-On Using SAML' in your org's 'Single Sign-On Settings'.
Daniil PashkovDaniil Pashkov
Little Note: Salesforce sees it as one of the Playgrounds, which leads it to the common error message that we all get. I solved it by switching to the Developer version and then by going to > Single Sign-On Settings > Un-enabling SAML > Save > Enabling SAML > Saving and Checking the newly acquired badge. I hope that everyone will solve the current badge case. No need of creating a new playground and redoing the challenge, switching to Developer worked perfectly for me. 
manohar Reddy 95manohar Reddy 95
Thanks Danil , it worked for me
Sia Thripio 5333Sia Thripio 5333
hi  I solved it by switching to the Developer version and then by going to > Single Sign-On Settings > Un-enabling SAML > Save > Enabling SAML > Saving and Checking the newly acquired badge and switching to Developer worked perfectly for me. thanks alot.
Francis DiasFrancis Dias
Hi Folks,

To make it work you must disable and enable SAML again (plus refresh in both steps). It worked for me on Trailhead challenge "Set Up Single Sign-On for Your Internal Users"

Hope it helps!
 
rashmin prajapatirashmin prajapati
hey guys!
you are right just Single Sign-On Settings > Un-enabling SAML > Save > Enabling SAML  now chek it will work 
Ian Samuel Githegi KamauIan Samuel Githegi Kamau

Hey Guys!

I currently have 4 Trailhead Playgrounds and 2 of these playgrounds;- have been used to finalize the Trailhead Challenge(Set up Single Sign-On) (https://trailhead.salesforce.com/content/learn/modules/identity_login/identity_login_sso). After weeks of scratching my head; Today; I get my Badge. 

What I did on one of my latest playgrounds(Single -Sign-On Playground) was to actually UNCHECK the "SAML Enabled" under the Federated Single Sign-On Under SAML Enabled.  Once I did the above; I went back to the Challenge and Checked if the Challenge is correct.

I was greeted by a "Woohoo" Badge that has been awarded. 

My Theory is;

a) The 1st playground(Samuel Playground) that failed to award the Badge yet (Sia) Logging was successful. My Domain change and deployment was successful just to note.

b) 2nd Playground(Single-Sign-On Playground)  created has SAML Enabled already. Yet I was not able to login successfully through the 3rd Party Identifier - Axiom. 
So by UNCHECKING (SAML Enable Option) & Saving those settings on the 2nd playground and then re-checking the challenge and now I have passed.

PS: the Endpoints for the Unique Letters and Numbers generated under the Login URL did not come for both playgrounds yet I managed to successfully login on to my "Samuel" Playground. The above endpoints are auto-generated and come about with a successful My Domain deployment. (I could not be sure about that but I stand to be corrected.)

My Advice: For the whole Module - User Authentication should be done on a new playground.

Leandro Camargo 9Leandro Camargo 9
I had to ctrl + R few times and ALSO check if I was at the right org (by going to Setup > Users  and confirming if the "sia@jedeye-tech.com" Federation ID user was there).

And, believe me, wasn't there at first cause, for some reason, I was in a different org.

So I closed all orgs windows and reLaunch the Playground to open a new window and I did the steps:
1st) confirmed if "sia@jedeye-tech.com" user was there
2nd) un-enable > save;
3rd) ctrl + R;
4th) re-enable > save       yap! Keep the 4th!

After few hours trying, it worked. Don't give up
"Do or Do not. There is no try."