+ Start a Discussion
S.TurbojetS.Turbojet 

Wave Explore Insights on the Go The 'Top Engineering Sales' lens does not appear to have the correct query.

Hello everyone, I'm getting confused on this module for the mobile section... the directions state to build the lens as follows:
  • Dataset: DTC Opportunity
  • Add Group: Opportunity Owner
  • Change Measure: Count of Rows to Sum of Amount
  • Sort by: Dsc (Descending)
  • Filter by: Industry Equals Engineering
  • Filter by: Won Equals True
  • Chart Type: Horizontal Bar
  • Lens Name: Top Engineering Sales
  • App: My Exploration
I have my criteria setup as follows:

User-added image
User-added imageUser-added imageUser-added imageUser-added image

I am just not sure where I am going wrong!  I've tried deleting it and reconstructing it, but every time I get the error "Challenge Not yet complete... here's what's wrong: The 'Top Engineering Sales' lens does not appear to have the correct query. Please check the requirements and ensure everything is setup correctly."

Any help would be appreciated!
SandhyaSandhya (Salesforce Developers) 
Hi,

Please check if you have connected to same DE org where you have done your work in the trailhead(same DE where you have connected your wave mobile App).To do this click on" launch your hands on org" and select the DE org or trailhead playground where you have your work and then check challenge.

Hope this helps you!

If this helps you, please mark it as solved.

Thanks and Regards
Sandhya
S.TurbojetS.Turbojet
Sandhya, yes, I am definitely in the correct dev org.  I even tried starting a second Wave dev org to circumvent the issue but no luck.
SandhyaSandhya (Salesforce Developers) 
Hi,

Ok.Please give me some time I will try to do the challenge in new Wave org and let you know.

Thanks and Regards
Sandhya
Oscar HemmelgarnOscar Hemmelgarn
Good Day Sandhya, I'm receiving the same message when I attempt the challenge.
S.TurbojetS.Turbojet
Has anyone been able to figure out the answer to this one yet or successfully completed this module??
Melissa Sagendorph 11Melissa Sagendorph 11
I'm getting the same error still. Everything looks as expected with the query on my end.
Chris DuarteChris Duarte
Sorry for the issue. Wave Desktop Exploration and Wave Mobile Exploration both currently are not functioning as expected. We have a fix lined up and plan to release it next week. Hold off on the modules until then. Again, my apologies for the issue.
S.TurbojetS.Turbojet
Thanks for the update Chris- I'm just happy to know that I'm not a crazy person after all!
Chris DuarteChris Duarte
I'm very sorry you went through this. We're working on better ways to message in-app when we know something isn't working right.

We're also working on ways to give you tips when something *is* working right, but a common user error might be tripping you up.
S.TurbojetS.Turbojet
Believe me, it was a very minimal amount of frustration in compared to all the amazing things Trailhead has helped me learn so far!  Thank you for all that you and your team do! (And those enhancements sound amazing, I look forward to seeing them)
Chris DuarteChris Duarte
Issue resolved. Please sign up for a new Wave Developer Edition to complete the challenges. You can find the Wave Developer Edition signup in this unit: https://trailhead.salesforce.com/modules/wave_analytics_basics/units/wave_start_surfing_the_wave under the topic: Try Wave Analytics with a Developer Edition org

Again, my apologies for this issue.
Jason NiebauerJason Niebauer
Hi Chris, I've signed up for a new Wave Developer Edition recommended by your forum response to the Explore with Wave Analytics Wave Desktop Exploration Analyze Your Data Over Time (https://developer.salesforce.com/forums/ForumsMain?id=9060G000000I3mg) challenge issue. I was able to complete the desktop challenge successfully, but I'm still running into an issue with this challenge.
Chris DuarteChris Duarte
Hi Jason: You're still having an issue with which challenge?
Jason NiebauerJason Niebauer
Hi Chris, appreciate the quick response. I'm still encountering an issue with the Explore Insights on the Go challenge in the Wave Mobile Exploration module. I'm receiving the error, "The 'Top Engineering Sales' lens does not appear to have the correct query. Please check the requirements and ensure everything is setup correctly."

I set up a new Wave Developer Edition to complete the Analyze Your Data Over Time challenge in the Wave Desktop Exploration module. I ran into that issue as well, so once I completed the Analyze Your Data Over Time badge challenge with no problems I moved on to this challenge to wrap the Explore Insight on the Go badge. However, I still get the error message I metioned above.

I see that the "Sum of #" has been added as an option in the new Wave Developer Edition org, but the challenge requires the measure to be set as the "Sum of Amount." Not sure what the issue is, I've tried "Sum of Amount" and "Sum of #" with no luck.
RSovaniRSovani
Same issue here, even creating a fresh new Wave DE, I still hit the issue
Chris DuarteChris Duarte
Thanks so much for chiming in, Phil. Appreciate you responding!

Everyone - we had a few issues with these challenges, and resolved *most* of them, but as Phil said, this one is still having an issue. Thank you Phil for the workaround, and I'll update here again once the fix is live next week. 
Larry Burgess 5Larry Burgess 5
That worked!  I had to remove the lens from my phone first, then create it on my computer.
pchoipchoi
Great to hear, Larry. The real fix is coming soon. :)
S.TurbojetS.Turbojet
Thank you so much Phil and Chris!  I appreciate your help with this badge!
pchoipchoi
Glad we could help! Thank you for sticking with it. :)
Jason NiebauerJason Niebauer
Appreciate the help, thank you so much Phil and Chris!!
Sayuri Tanioka 5Sayuri Tanioka 5
Hi Phil,
I've tried your suggested workaround but still getting this error and can't get the badge :(
Any ideas?
pchoipchoi
Sayuri, the issue has been fixed so you need to do the hands-on challenge using the Wave mobile app. If you create the lens there and save it, you should pass the challenge. Let me know if you encounter issues. The workaround I posted above was just a temporary one and will no longer work, now that the fix has been released. Apologies for the inconvenience. Make sure you are using a Wave DE org created recently -- after February 15. Thanks!
Jason SinbadJason Sinbad
this module only will work if you have ios which not everybody has, for thoes who only have android are screwed as they would not be able to do this. why would Salesforce only build apps that is ios only and not support other mobile os.
Sayuri TaniokaSayuri Tanioka
Hi Phil,
Thanks for your response :)
I've tried the mobile app initially when the error happened, and so I searched to find alternative solution which was what was proviced above. But since it's no longer working...I've just created my Wave DE org so it should meet all the criteria given.
I'll try it again, thanks!
Sayuri TaniokaSayuri Tanioka
Yeah...still the same. I think I'll give up this badge, it has taken up a bit of my time :( 
The Real Scott MorrisonThe Real Scott Morrison
I'm getting the same issue, it's true that I don't have an IOS device but I thought doing the challenge on the desktop would work. Is there something different about how IOS sets up the lense? 
The Real Scott MorrisonThe Real Scott Morrison
hmm just read the accepted answer, I think SF should leave the "workaround" in place until Android is supported :) 
pchoipchoi
We'll test against Android. You're right that it's a poor experience for non-iOS users. We'll look at ways to make the badge earnable for all users. In the meantime, if you're unable to pass the challenge, ping me directly by email and I'll see what I can do to help.
iUmairiUmair
Any updates on this badge yet? I followed the instructions and created the report on my laptop - still getting the error:
The 'Top Engineering Sales' lens does not appear to have the correct query. Please check the requirements and ensure everything is setup correctly.
pchoipchoi
Umair, the desktop workaround no longer works. You must use Tge mobile Wave Analytics app in iOS to pass the challenge.
iUmairiUmair
Thanks pchoi . I was able to complete this *borrowing* an iPad. 
pchoipchoi
Thanks for sticking with it, Umair. Apologies for the trouble. We'll consider how to manage the gap until Android is at parity. Congrats on the badge. :)
The Real Scott MorrisonThe Real Scott Morrison
I have a first gen ipad, also doesn't work :) 
Elizabeth HoegerElizabeth Hoeger
I am having a similar issue. The mobile apps have never worked for me and I always end up using a workaround, but since the workaround for this no longer works i can't get the badge.
pchoipchoi
Elizabeth, can you explain what isn't working for you with the mobile app? Are you unable to log in as your Wave DE org user?
Elizabeth HoegerElizabeth Hoeger
I can log on just fine it is just that I can't see any of the data and I have tried following the directions, but I can't find the info/action panel at all on any of the screens
pchoipchoi
Check out the mobile help for iOS here to see if that helps. The action panel pops up when viewing a dataset or lens and you tap the Explore option (if that's what you're referring to). 

https://mobile-analytics.docs.salesforce.com/en-us/3.0/ios/bi_mobile_intro.htm
Daniel Politzer 4Daniel Politzer 4
I've tried this on the mobile app. Made sure to delete any previous versions. Still doesn't work for me. Using iOS. Driving me nuts. Any suggestions as I've done this over and over, including in slow motion to make sure I'm not inserting typos or other dumb mistakes. Thanks in advance.
Daniel Politzer 4Daniel Politzer 4
Update: of course, now that I've posted, I realized I hadn't deleted all of the desktop versions. Finally did, re-did once more on iphone and it worked fine. Thanks for helping me resolve ;)
Erik Van AschErik Van Asch
Non-iOS user here still stuck. Desktop solution not working either.
Darn! Was hoping to have entire course completed today, but it seems this seems to be ongoing for 5 weeks now. Hmmm.
Daniel Politzer 4Daniel Politzer 4
I was able to get the iOS version to work after first deleting all previous versions of the lens.
Ramkrishna BharadRamkrishna Bharad
I agree - when they fixed mobile version, they turned-off desktop version. Not everyone would have iOS so I wish they would have kept desktop version on as well after fixing their iOS version. This BUG is the only between me and completion of my whole TRAIL :( 
pchoipchoi
Very sorry about that, Ramkrishna. The Android version is quickly moving towards Explorer support. I realize that's no consolation. We're looking at the roadmap to see if an interim solution is warranted. Appreciate the feedback.
Jeremy King 5Jeremy King 5
I'm getting an error when taking the challenge for "Explore with Wave Analytics>Wave Desktop Exploration Become a Data Explorer"  for the "Top Laptop Industry" lens. I've triple checked it and still receiving "Challenge Not yet complete... here's what's wrong: 
The 'Top Laptop Industry' lens does not appear to have the correct query. Please check the requirements and ensure everything is setup correctly."
Lucky123Lucky123
Hi Pchoi,
I am trying to complete this on Laptop and getting an error as some people listed above. Do i have to complete this on iphone?
Thanks
Lucky123Lucky123
Please disregard my question. I was able to complete on iphone. 
pchoipchoi
Great. Yes, until Android supports explorer, you must complete this challenge on a supported iOS device. Congrats on passing the challenge!
Ramkrishna BharadRamkrishna Bharad
Thanks Pichoi for response and no worries, as Android version is moving fast in roadmap so we can wait. if this BUG would have been between me and new job offer then I would have been more nervous :) After I win few trails, I hope Salesforce Einstein digs trailhead data and recommends me for a job to your recruiting division :) . 
On serioud note, I know Salesforce's 1:1:1 model which donates effort/license to non-profit organization so is there anyway I can provide free Salesforce service to such organization. Pl note down my email rkmapgwp@gmail.com and would love to connect offline. 
pchoipchoi
@Jeremy King 5, are you still having an issue? Can you please post a screenshot of your lens? It seems like you may have put in the wrong lens name: "Top Engineering Sales" should be the name you use.
Jarod EvensonJarod Evenson
It's been over a month since the "fix", yet Android users still can't earn this badge. 
Saad Ansari 7Saad Ansari 7
I am still facing this issue, tried creating from iphone and laptop both. Still getting same error
Rachel J DewRachel J Dew
I'm still facing this issue as well. I've recreated it on the desktop...even borrowed someone iphone and no luck. @pchoi
Mathew WilliamsMathew Williams
It's now 5/30/2017, and I still have no way of completing this on Android. I have no access to any Apple devices, and can't complete the challenge on desktop. Someone needs to do something about this; it's absolutely ridiculous to penalize people for not buying Apple.
pchoipchoi
@Jarod @Mathew, our apologies. It's not our intent to penalize anyone based on platform; it's just a matter of what's currently supported. The Android app is adding functionality with each release and we should soon be able to complete the challenge from iOS or Android. That said, I completely understand your frustration. I'm an Android user myself. Let me check on the roadmap and see if there's something we can do in the interim. 

@Rachel and @Saad, please try this: Delete all lenses named Top Engineering Sales across your Wave DE org. Wipe them completely. Then try again from your iOS device. The problem is that the API name underlying the lens needs to be unique, and we're validating against the first instance of that name. So, if you created more than one, they'll start to have API names like top_engineering_sales_2, etc. Apologies for the blunt-force validation approach. We're looking at refining it to be smarter. Let me know if that works.

Thanks, everyone. We appreciate your interest (and patience).
Miguel Sampaio 7Miguel Sampaio 7
I have the same problem with the trailhead: Challenge Not yet complete... here's what's wrong: 
The 'Top Laptop Industry' lens does not appear to have the correct query. Please check the requirements and ensure everything is setup correctly.
I follow all the steps, but I don't know how to solve this query problem.
mrcoqtailmrcoqtail
I have the same issue as other members. At the challenge 'Explore with Wave Analytics >  Wave Desktop Exploration >
Become a Data Explorer ' you're asked to make a new lens for 'Top Laptop Industry'.

See below the assingment (screenshot #2). I've created this as described, but still getting the error with the validation (screenshot #2).

Any thoughts?

User-added image
User-added image
Mike IannottiMike Iannotti
I'm also having trouble with the challenge validation on Become A Data Explorer. Same error as several have reported: "Challenge Not yet complete... here's what's wrong: The 'Top Laptop Industry' lens does not appear to have the correct query. Please check the requirements and ensure everything is setup correctly."

I'm doing this via PC on Chrome 58.0.3029.110 (64-bit). I've tried the usual suspects (do it over, log out/in, close browser, restart) not no avail. If screenshots or further details would be helpful, by all means let me know and I can provide.
François MiterniqueFrançois Miternique

Same problem for me :/

Challenge Not yet complete... here's what's wrong: 
The 'Top Laptop Industry' lens does not appear to have the correct query. Please check the requirements and ensure everything is setup correctly.

Does anyone have the solution ? :)

Isabel Bach 2017Isabel Bach 2017
I am having the same issue. Also tried changing grouping, redo everything, changing browser from Internet Explorer 11 to the latest Google Chrome version. Nothing helped.
Help is very much appreciated! :)
Isabel Bach 2017Isabel Bach 2017
By the way: same for the 'Analyze Your Data Over Time' challenge
pchoipchoi
Please vote up this reply. We've discovered that there is a problem with the validation code in the "Become a Data Explorer" and "Analyze Your Data Over Time" challenges. The problem came from changes introduced by the new Explorer. We are working on a fix, which should be out next week. In the meantime, please hold off on attempting to complete these two units. Extremely sorry for the frustration and time lost. The updated challenges will be much improved. We're really sorry for the poor experience. Will post an update to this thread when resolved. Thanks for your patience!
Pedro Freire (isobar)Pedro Freire (isobar)
Please do fix it soon. Currently it isn't working neither on desktop (Windows) nor on mobile (Android and iOS).
Dominique EdeDominique Ede
Hi, i'm having the same issue. When will this be fixed? Thanks
vleandrovleandro
Count me as another trailblazer trying to get my Analytics badge and it seems all of the Hands On Challenges are broken.  I'm still working through the challenges; but its frustrating not getting my badges.  LOL.  Its all about the badges....
pchoipchoi
We're working on a fix now and will deploy as soon as we can. Thanks for your continued patience.
Isabel Bach 2017Isabel Bach 2017
It seems that the issue is fixed now. I validated the challenge and earned my missing points. :-) 
Thanks for fixing!
Pedro Freire (isobar)Pedro Freire (isobar)
I confirm that it is working now. I just had to delete and redo the stuff for one of the challenges, the other one was validated without any changes. Thanks guys!
Kelly Sullivan 18Kelly Sullivan 18
I am still having the same issue.  I've deleted any copies of it from both my phone and my laptop.  I also logged out and back in.  @pchoi,  Is the fix deployed so that the issue is mine or should I wait a bit and try again?
Duane DeRouen 5Duane DeRouen 5
I am having the original issue that started this thread. Wave Explore Insights on the Go The 'Top Engineering Sales' lens does not appear to have the correct query. I have read throught this entire thread and tried everything, but I still receive this error message. Can someone help since I am required to have this trailhead completed?
pchoipchoi
ANNOUNCEMENT: The hands-on challenges for "Become a Data Explorer" and "Analyze Your Data Over Time" have been fixed and deployed. Before trying the challenge again, please delete all previously created lenses with those names and make sure you're using a Wave Developer Edition org. It's also important to follow the order of the challenges. 

Once again, we're really sorry for the trouble. I know you all worked really hard for your badges and our errors blocked you from getting them. Appreciate the patience and determination. Please continue to raise issues if you have problems with challenges. Thanks!
pchoipchoi
@kelly Sullivan 18 and @Duane DeRouen 5: Sorry you're still having problems. To complete this challenge, you need to be using an iOS device. Try first deleting all lenses named Top Engineering Sales before trying again from your phone. You need to make sure you're logged in to your recent Wave DE org. If you still see issues, please post screenshots of your lenses. Thanks!
Kelly Sullivan 18Kelly Sullivan 18
Just gave it another shot:  It didn't validate and here's the Lens shot:

User-added image
Duane DeRouen 5Duane DeRouen 5
thanks for your quick response @pchoi. I am using an iOS devide. I have deleted all lenses named Top Engineering Sales and I am trying from my phone. I have confirmed that I am logged in to my recent Wave DE org. My screen shots look exactly like what S.Turbojet posted at the top of this thread.
Kelly Sullivan 18Kelly Sullivan 18
On the plus side @Duane DeRouen 5, we will know this module incredibly well once we get past these issues!   Thanks for all your efforts @pchoi.  :)
pchoipchoi
FYI that I've deleted my post about the desktop workaround from this thread, so as not to cause confusion. Let me dig in to this issue. Will report back. 
Angelica Veness 12Angelica Veness 12
@pchoi I am also having the same problems as @Kelly Sullivan 18 I have deleted old lenses, I'm using an iOS device & I've followed the instructions in order. But I also get the 'lens does not appear to have correct query' error message.
pchoipchoi
Folks, I have some bad news. While we fixed the two desktop challenges, we found a persistent issue with the mobile challenge -- an error with the validation code. Unfortunately, it's not possible to pass the "Wave Mobile Exploration: Explore Insights on the Go" challenge right now, so please don't spend time trying to pass it until we resolve the issue. You've all proven what amazing explorers you are with your persistence and patience. I wish we could fix this right, but it looks like we may need to wait until the next scheduled release in later July. I know you're probably tired of my apologies by now -- I know I am -- but we truly are sorry and will fix this as soon as we can. I'll post updates here. :(
Chris DuarteChris Duarte
@pchoi thanks for posting.

Everyone, Phil is correct. We unfortunately can't do another release for a couple of weeks, which means you'll need to hold off right now on this module. I apologize for the trouble here. We're targeting the last week of July for a fix. 

We are working on tooling that will allow us to publish faster. Thanks for hanging in there with us, and again, my apologies.
 
Gowri KaranamGowri Karanam
Thanks for the update @pchoi.... sad I won't get that badge till end of Jul :(...
vleandrovleandro
While you're at it, I'm seeing problems with "Service Analytics App" Badge as well.  In Step 2: Create Service Analytics Using the Wizard, when I try and launch "Trailhead Data Manager" and click on the Trailhead Data Manager tab, I get a "URL No Longer Exists" page.  Additionally, the Dashboard called Service Manager Overview doesn't exist.

It should be noted that I did follow Step 1: Get Started with Service Analyics and spun up a brand new Org.

Please let me know if I need to start a new thread or report this up through Support.  
pchoipchoi
@Gowri, I know, I'm sad too. Sorry about that!
Kelly Sullivan 18Kelly Sullivan 18
@Gowri.  Just keep trailing.  It will come eventually and by then, you'll know many more aspects of the tool!
 
Paul Dreyfus 2Paul Dreyfus 2
@vleandro: Checking to see what's going on with the Service Analytics App module. I'll post here after I know more.
Paul Dreyfus 2Paul Dreyfus 2
@vleandro: just created the Service Analytics app, and Trailhead Data Manager tab worked fine. Can you try that again? You're right about "Service Manager Overview" dashboard--that should be "Service Analytics Overview"--we recently redid a lot of the content around new dashboards with new names, and we didn't catch that one. I'll fix that and check the other dashboard names in Trailhead to be sure others don't encounter the same thing. Thanks! and please let me know if you get the Trailhead Data Manager to work. If you don't, I'll bring others into this to see what might be going on. (I'm the writer for the Service Analytics App module.)
vleandrovleandro
I tried it again this morning and it's now working.  As a point of reference, yesterday when I tried it, I was on a wireless network at the airport...so who knows....gremlins in the ether I suppose.  Thanks for taking up and commenting on the Dashboard.  I definately appreciate it!
Gowri KaranamGowri Karanam
@Pchoi and @Kelly... thanks. I am trailing on, can't let one road block stop me from becoming a mountaineer!! LOL..
pchoipchoi
Great to hear, @vleandro. Thanks for pushing through the issues. :)
Heather GrayHeather Gray
This has not been fixed.   I just started the challenges on July 10th and I have the same error issues with Becoming an Explorer the others were having back in June before the "fix" and I'm having the same issue with the Mobile challange as well.  I am unable to complete my mandatory badges because of these issues.   
Chris DuarteChris Duarte
@Heather yes, we're aware that it's not functioning as expected. Phil's post of June 27 in this thread explains this:

Folks, I have some bad news. While we fixed the two desktop challenges, we found a persistent issue with the mobile challenge -- an error with the validation code. Unfortunately, it's not possible to pass the "Wave Mobile Exploration: Explore Insights on the Go" challenge right now, so please don't spend time trying to pass it until we resolve the issue. You've all proven what amazing explorers you are with your persistence and patience. I wish we could fix this right, but it looks like we may need to wait until the next scheduled release in later July. I know you're probably tired of my apologies by now -- I know I am -- but we truly are sorry and will fix this as soon as we can. I'll post updates here. :(
Heather GrayHeather Gray
Desktop is not working Heather Gray - PMP, CSM, CMP *Innovation and Transformation Executive* Mobile 201-739-8583 hgray@salesforce.com
Su Wang 3Su Wang 3
@pchoi Has this issue been fixed yet?  I am using iphone to do this challenge but got the same error as the first post said.  Deleted the lens on the mobile app, re-did the challenge, same error.
pchoipchoi
There is a known issue with this challenge that's being fixed with the upcoming July Trailhead release. Thanks for your patience. I'll announce the fix on all relevant threads.
Su Wang 3Su Wang 3
@pchoi  Thanks for the update!  You are the best in following up with questions and concerns.  Wish other SF coordianitors would be all like you!  SF is a CRM platform but sometimes, I don't feel like SF cares about Customer Relationship at all.
Matthew BertschMatthew Bertsch
I'm having the same issue
pchoipchoi
@Su Wang 3: Thanks so much. You know, Salesforce definitely does care about the customer relationship. I'm sorry if you haven't always had great experiences in other situations. Please feel free to send me feedback if there's anything I can do to help. Sometimes, we don't have enough resources dedicated to providing forum and community support. A lot of us on the boards are the content creators, who are doing our best to help everyone earn their badges and learn about our great products. Thanks for sticking with it! Really appreciate it. 
Isabel Bach 2017Isabel Bach 2017
Absolutely agree with @Su Wang 3! You do a great job @pchoi. Thanks for all your patience and support!
Matt BevinsMatt Bevins
Also getting this error when completing the 'Explore Insights on the Go' trailhead.
William SummersWilliam Summers
I'm glad I found this thread.  About to throw my iPhone and iPad in the ocean.  Let us know when we can complete.
pchoipchoi
Despite the app formerly being called Wave, we don't recommend using the ocean to turn off your device. :) For this particular challenge, we changed the exercise to a quiz. This solves the technical issue we were having with validating using the API, but it also will allow Android users to earn their badges. Fix is being released early next week. I'll announce. Please keep your devices dry until then!
pchoipchoi
Okay, everyone. The moment has finally arrived. The Explore Insights on the Go challenge has been fixed. In fact, it's been replaced by a multiple-choice quiz, so you  can earn this important badge whether you're an iOS or Android user! 

Check it out here: https://trailhead.salesforce.com/modules/wave_mobile_exploration.

Once again, we appreciate your enduring patience with this delay. Please continue to let me know about any Trailhead issues you see for Analytics content. Now, go earn your well-deserved badges! And give yourselves extra credit for all the unexpected trouble. Thank you! :)
Su Wang 4Su Wang 4
@pchoi Well, I took the 100 points test.  After click the "Check Challenge", it did not say I had any wrong answer but only gave me 25 points.  Very weird.
Gowri KaranamGowri Karanam
@pchoi, i faced the same issue as @Su Wang. I know did not have any wrong answers.
pchoipchoi
We're looking into the points right now. Looks like the code is correct, but something's not right. Should be 100 points. Will report back....
Gowri KaranamGowri Karanam
@Pchoi, could you find out what the issue was? is it resolved. really appreciate your responsiveness and all the help you provide. Thanks.
Daniel SaaltinkDaniel Saaltink
@pchoi, I have the same problem. Challenge Not yet complete... here's what's wrong: 
The 'Top Laptop Industry' lens does not appear to have the correct query. Please check the requirements and ensure everything is setup correctly.
Any update about this isseu?
Regards Daniel
pchoipchoi
@Gowri and @Su Wang 4, we've fixed the issue with assigning the incorrect number of points. FYI. 

@Daniel Saaltink, this thread is about the mobile unit. Are you still having trouble with the hands-on challenge for "Become a Data Explorer" unit of the Desktop Analytics Exploration module? As of now, there are no known issues with this challenge. Can you provide a screenshot of your lens? Or describe the situation? Can you check this thread to see if it helps?: https://goo.gl/FXUyZp. Thanks!
Daniel SaaltinkDaniel Saaltink
@pchoi, removed it. Build again and now it's working. Thanks!
 
David Lau 3David Lau 3
I passed this challenge by removing Filter by: Product Family Equals Laptops and Filter by: Won Equals True then Sort by: Dsc (Descending) then re-add those two filters. I wonder why it doesn't work by just adding the steps in no particular order.
jin lasjin las
That's really great idea to use the script for service or product page. I want to use it for my local country page of engineer in Texas (https://jacobmartin.com/).