+ Start a Discussion
priyanka narisettypriyanka narisetty 

You cannot deactivate a user who is receiving cases or notifications as part of your case assignment/escalation rules. <br/><br/>Click <a href="/ui/setup/Setup?setupid=Case">here</a> to view your case assignment / escalation rules.

Hi 

I am trying to deactivate the users but the user is not part of escalationa and assaignment rules but still getting the below error. Please help me to deactivate the user.

You cannot deactivate a user who is receiving cases or notifications as part of your case assignment/escalation rules. <br/><br/>Click <a href="/ui/setup/Setup?setupid=Case">here</a> to view your case assignment / escalation rules. 

Thanks,
NagendraNagendra (Salesforce Developers) 
Hi Priyanka,

Usually, for the above issue, you have to remove the user in your Assignment rule and Escalation rule. Then change the ownership of the particular user records.But as you are saying that no users are part of escalation rules and assignment rules may I suggest you please follow the below steps which should probably resolve the issue.

1. Click on Customize
2. Click on Cases 
3. Click on Escalation Rules name "Standard Escalation Rule"
4. Click on Edit on the first rule entries 
5. Change the name on Notify"Test User" and put some other user on notify     owner lookup.
6. Click on Save

Best Regards,
Nagendra.
Brian BartlettBrian Bartlett
I am having the same issue here, checked all Assignment & escalation rules but still get the msg when I try to de-activate the user?
Please help
Thanks
Eric Smith 56Eric Smith 56
I am also having this issue. Any help in moving forward with a solution would be greatly appreciated.

Thank you
Kelsey MillerKelsey Miller
You need to change the support settings. Go to Customize> Case > Support Settings. change the Defualt Case Owner and Automated Case User to someone other than that User.
James ShearerJames Shearer
We ran into the same issue and the above solutions were not the fix. We did not have any Assignment or escalation rules even set. We found the issue was part of Support Settings. Kelsey was correct, but I believe she was using Classic. 

In Lightning:
1. Go to Setup and search for Support.
2. Click "Support Settings" - (Feature Settings->Service->Support Settings)
3. At the top of the list you will see the Default Case Owner and Automated Case User, click edit and update both of those
4. Click Save
5. Retry your deactivation

Thanks
Ken ShvetzKen Shvetz
I was receiving the same error in a Trailhead module even after removing the user from all the Support Processes, and she was not a member of any of the queues or escalations either.  The only way I could get the error to stop was to delete all my escalation rules. Maybe you'll need to do that and re-create them all as a last resort. Seems like a bug.
Alex StroeAlex Stroe
Hello guys... I cannot find Customize. I have the same issue. I tried both of the solutions here, and still doesn`t work. Did someone find a solution for this?
Jim Padrino 10Jim Padrino 10
I had this issue, and all the steps above did not work. I solved the issue by: Setup - Service - Escalation Rules where the user's email was listed to be notified. 
admin 2790admin 2790

This can be casued by various reasons depending on where the user is being used. If above solutions did not work for you, then please try this. 

  1. Make sure the user is not part of Lead Assignment rules
  2. If that does not help then this user must be an active user with the 'View All Data' permission. Before changing the user settings or profile, select a different user for Executive Opportunity Alerts. (You may need to change assigned users in Big Deal alerts)
Jose FiolJose Fiol
Hello there the solutions that I found out is this:
1. Go to Setting and search Escalation Rules.
2. Select Escalation Rules and Delete it.
3. Try to deactivate the user again.

That's what worked for me.