+ Start a Discussion
L2BrewL2Brew 

Trouble installing DataLoader on Mac

I'm having trouble installing DataLoader on my Mac.  I'm downloading the latest version "DataLoader for Mac" from the Setup Menu.  Once downloaded, I move it to the Applications folder and tell it to Replace any old versions.  When I go to Launchpad to open DataLoader, the icon I see is the older version of DataLoader and it is greyed out.  

User-added image
When I try to open it, it says "The application “Data Loader” can’t be opened."  

User-added image

I've tried dragging it to the Trash and starting again, but it won't let me.  I've also tried installing an older version but received a different kind of error with that....."Failed to parse detail........"  

User-added image

Does anyone have any ideas on how I can resolve?  I've searched documentation as far as I know how and I'm not getting anywhere!  Thanks in advance!!!

 
Best Answer chosen by L2Brew
SandhyaSandhya (Salesforce Developers) 
Hi,

I would suggest you try for below things.
Go to System Preferences, Security and Privacy, click the padlock, type in the password, check option Allow apps downloaded from: Anywhere.

Before downloading new data loader remove all older versions of dataloader on Mac.

Hope this helps you!

If this helps you, please mark it as solved.

Thanks and Regards
Sandhya

All Answers

SandhyaSandhya (Salesforce Developers) 
Hi,

I would suggest you try for below things.
Go to System Preferences, Security and Privacy, click the padlock, type in the password, check option Allow apps downloaded from: Anywhere.

Before downloading new data loader remove all older versions of dataloader on Mac.

Hope this helps you!

If this helps you, please mark it as solved.

Thanks and Regards
Sandhya
This was selected as the best answer
L2BrewL2Brew
Thank you!  That led me to the right solution.