+ Start a Discussion
Pieter SannenPieter Sannen 

Superbadge - Data Integration Specialist - challenge 1

Hi,
I'm stuck at the first challenge where it always returns me:
Could not find an entry in the ServiceCredentials custom setting named 'BillingServiceCredential' with the specified username and password. Ensure the you have entered the data correctly into the custom settings record.
I think that I did everything right. The unmanaged package came with a custom setting called ServiceCredentials:

User-added image
I clicked manage and added the BillingServiceCredential

User-added image

With following details
User-added image

Still giving me above error!
Any ideas?

Regs,
Pieter

Best Answer chosen by Pieter Sannen
Pieter SannenPieter Sannen
Found it myself, switched values of Username & Password :facepalm:

All Answers

Pieter SannenPieter Sannen
Found it myself, switched values of Username & Password :facepalm:
This was selected as the best answer
Mathew Andresen 5Mathew Andresen 5
yep, I did the same thing
Venkata NagarajaraoVenkata Nagarajarao
Add BillingServiceCredential under ServiceCredentials Detail with bsUser1/bsPass1 working fine
Bruce StewartBruce Stewart
Check the order of the fields in the form and the values you are entering.  This got me, too!  You're used to User, then password left to right, but look at the order on the page layout.
Venkata NagarajaraoVenkata Nagarajarao
Thanks Bruce,
I mean Username/Password only.The order in Custom setting is Password then Username.
Swapnil Barad 34Swapnil Barad 34
Hi,
This custom setting configuration is working fine for me. 
User-added image

Thanks,
Swapnil.
Yashita Goyal 17Yashita Goyal 17
Hi,

Am getting this issue:

Superbadge Data Integration Specialist - Step 1

Can someone please help.

Thanks.
janardhanareddy gowkanpallijanardhanareddy gowkanpalli
Complete each challenge to earn your superbadge
Challenge Not yet complete... here's what's wrong: 
Could not find a named credential with the URL of 'https://sb-integration-pms.herokuapp.com/projects'.
1
Configure outbound application and integration security
Install the unmanaged package from the prework if you haven’t already. Configure a named credential and remote site according to the specifications outlined in the business requirements. Enter the billing service credentials in the custom setting


please helpme anyone
Chidanand MChidanand M
@Yashita,

1. click on setup
2.Quick search 'Named Credentials'
3. Create new Named Credentials as specified in the reqquirement.

 
Jaap ScheperJaap Scheper
This one got me, too.
Who expects that you have to fill in your password first, and then your username?
I don't :)
Tushar Jain 11Tushar Jain 11
I also did the same mistake. Really who fills password first and then username...
susheela kuchimanchi 7susheela kuchimanchi 7
create a new  Named Credential with below details 
Label:ProjectService
Name:ProjectService
URL:https://sb-integration-pms.herokuapp.com/projects
Ajinkya Kasabe 29Ajinkya Kasabe 29

@Pieter Sannen 

Facing same issue got the trick thank you

Akshay GuptaAkshay Gupta
@Bruce Stewart you are my life saviour :) nice man
 
Michael CeryakMichael Ceryak
Had the same issue... An idea was just posted to get this fixed here: https://success.salesforce.com/ideaView?id=0873A000000LtZBQA0 
Ilya Grebtsov 5Ilya Grebtsov 5
This is fun, so I was not the only one who was stuck at this place and had to double-check everything again.