+ Start a Discussion
Vandana Rattan 4Vandana Rattan 4 

Outbound Message to webservice 403(Forbidden)

I am trying to create a workflow triggered outbound message that would invoke a soa web service. However I keep on getting 403 Forbidden when I try to execute the outbound message. Kindly suggest.
NagendraNagendra (Salesforce Developers) 
Hi Vandana,

Typically, Status code 403 responses are the result of the web server being configured to deny access, for some reason, to the requested resource by the client.

As a problem determination step, what happens when you

* Open Setup / Outbound Messages /
* Click on the name of your message bundle
* Click on the Endpoint URL

When you are opening the endpoint URL please check if that is also returning the same error message.

May I also suggest you please give a try by testing it as explained in the below blog. Please mark this as solved if it's resolved.

Best Regards,
Nagendra.

 
Vandana Rattan 4Vandana Rattan 4
Hi Nagendra,

Thank you for your reply. I am able to test the Outbound message using PutsReq URL. But when I change the URL to my webservice URL I again get 403 Forbidden. If I click on the URL I am able to get to the page where it requires inputs to invoke the webservice:

User-added image

If I enter data here and submit I am able to invoke the web service.

Thanks