+ Start a Discussion
Mike CorbettMike Corbett 

Attempting to get access token fails

Hi all,
I am testing receiving the authentication token for my connected app so i can continue to build a simple consoleapp for salesforce.As a new developer of salesforce, I am having issues with testing Oauth through postman. 
User-added image
I followed this guide here https://blog.mkorman.uk/using-postman-to-explore-salesforce-restful-web-services/ , but to no avail. 
When i click "request token", the salesforce login appears, however when i input my UN and PW i am given an error message reading
"Could not complete OAuth2.0 login"

I've also tried this way, and recieve an invalid_grant error, and have tried every body configuration.
User-added image

Could someone point me in the right direction? I'd appreciate any help/tips. Thanks in advance!
Nissam PSNissam PS
Hi Mike,

Check your header, it should be like below, replace the current one with your instance_url.

User-added image


Let me know if this helps you.

Thanks!
Mike CorbettMike Corbett
@Nissam PS, thanks for the reply!
I actually just discovered it was a small issue in the connected app settings. I just needed set Permitted Users to All users may self-authorize
I appreciate the response regardless!
Sunnel MishraSunnel Mishra
Hi Mike Corbett, 

Where to get this  Permitted user, please send details. Thanks 
TRIPTI JAIN 2TRIPTI JAIN 2
User-added image

i got the error while used the userid password option
Tyler McCartyTyler McCarty
Did you find solution for this? I'm also having same issue using the password option