+ Start a Discussion
Sourav PSourav P 

Custom fields deployment to production from standard object

Dear All,
I have created many custom fields in the stand object Account, and trying to deploy to prod. I am using the outbound chnage set. But if i choose the custom fields, there are many, should i have to use one by one, choosing multiple at a time also not working, Or Is there a process i can deploy all new custom fields from the account at once ? thanks
Best Answer chosen by Sourav P
Rahul_kumar123Rahul_kumar123
Hi Sourav,
  • You can include standard objects in your Force.com IDE projects in either of two ways:
 
  • Add the custom fields on a standard object to a package.  This will create a .object file for the standard object, containing only the custom fields on that standard object that are in the package, e.g. src/MyPackageName/objects/Account.object
 
  •  Add the name of the fields or the object to src/unpackaged/package.xml.  Warning: Be cautious not to inadvertently damage your production Field-Level Security settings.  See note below.

- Option A. Add a CustomField type section:
<types>
  <members>Account.MyCustomFieldName1__c</members>
  <members>Account.MyCustomFieldName2__c</members>
  <name>CustomField</name>
</types>
  • Option B. Add the standard object name to the CustomObject type section:
<types>
  <members>*</members>
  <members>Account</members>
  <name>CustomObject</name>
</types>

Please refer the link for further reference.
I hope it will be helpful.

Please mark it as best Answer if it resolved the issue.

BestRegards
RahulKumar

All Answers

Rahul_kumar123Rahul_kumar123
Hi Sourav,
  • You can include standard objects in your Force.com IDE projects in either of two ways:
 
  • Add the custom fields on a standard object to a package.  This will create a .object file for the standard object, containing only the custom fields on that standard object that are in the package, e.g. src/MyPackageName/objects/Account.object
 
  •  Add the name of the fields or the object to src/unpackaged/package.xml.  Warning: Be cautious not to inadvertently damage your production Field-Level Security settings.  See note below.

- Option A. Add a CustomField type section:
<types>
  <members>Account.MyCustomFieldName1__c</members>
  <members>Account.MyCustomFieldName2__c</members>
  <name>CustomField</name>
</types>
  • Option B. Add the standard object name to the CustomObject type section:
<types>
  <members>*</members>
  <members>Account</members>
  <name>CustomObject</name>
</types>

Please refer the link for further reference.
I hope it will be helpful.

Please mark it as best Answer if it resolved the issue.

BestRegards
RahulKumar
This was selected as the best answer
Sourav PSourav P
Thanks a lot Rahul, let me try this.