+ Start a Discussion
Iswari Makam 8Iswari Makam 8 

stuck on challenge Import Data using Data Import Wizard

Getting an error The matching field you chose (Name) is not mapped and is required for an Update and Insert operation.
Any help how to fix this error Thankful  for any guidance
Amit Chaudhary 8Amit Chaudhary 8
Please post your code and share the error screen shot so that we can help you
Srikanth DorepalliSrikanth Dorepalli
Hi,
Iswari Makam 8,if this is your challenge follow below steps properly.
If this is your challenge..

1)Launch import wizard
2)select account and contact in standard object.Because you have to import contact data
***3)Match contact by "Name"(Note:Use 'Name' for matching contact records mentioned in challenge)
4)upload the file downloaded from challenge section
5)map Fname to contact:First Name
6)map Lname to contact:Last Name
7)map cell to contact:Mobile
8)Next and start import and ok.
 
Meghan CasaultMeghan Casault
Hello - I am having a similar problem. I uploaded the edited file and when attempting to map it gives me the same error when I chose Fname to contact: First Name OR when I try Fname to contact: Name. Any insights would be helpful.

Thank you,

M.C.
MuVaMuVa
Hi,
    Me too faced the same issue when I used the Lightning Experience,but it got resolved in Salesforce classic.Please try.
Pavan PattedPavan Patted
Hi
Facing this error--The matching field you chose (Name) is not mapped and is required for an Update and Insert operation, Any help how to fix this error
Sandeep K 49Sandeep K 49
Try using salesforce classic and it wil be upload
Barbara GrossBarbara Gross
After selecting a field to map to, you need to click the button "Map" at the bottom of the list. In some cases this button may not be visible because of the zoom in your browser. For me this was the case as I had Chrome zoomed to 150%. Because of this I could never see or click this "Map" button - I just saw (and clicked) the "Next" button (which is the wrong one here) and kept getting the message listed in this thread, even in Salesforce Classic.
The solution in this case is to zoom out until you can see and use the map button. Select the field to map to and click Map, then repeat for all the fields that are still unmapped. Once they are all mapped, you click on next.
Akash Kesarwani 6Akash Kesarwani 6
After uploading the csv file click on Map of First Name select->"Salesforce Field" and click on "Conatct: First Name" then zoom out as it happens your browser may be zoomed in by default you will show "MAP" button. Click on Map and then next you will see your results.
Zoom out for Map button.
Sravan Kumar 213Sravan Kumar 213
Thanks Barbara. The issue is with the browser which doesnt show you the option to "MAP". You need to zoom out
Subba MogantiSubba Moganti
Use command minus on chrome to see the MAP button after choosing the First Name and go ahead with others. I was stuck on this issue for some time and finally figured out.
SaiKumar SiripuramSaiKumar Siripuram
Try to Zoom out and see the MAP button, it took me sometime to figure it out.
Billie Jo Creamer 8Billie Jo Creamer 8
I am at the very beginning at "navigate to the Data Import tab on the SolarBots app and select Import." I am doing that but I am getting  "server error. Sample data import failed. Check error logs".
Ravicharan MahasivabhattuRavicharan Mahasivabhattu
Faced the same issue but it worked the moment i switched to classic. Thanks guys
Saw Eh Ta TawSaw Eh Ta Taw
Yah! There was Zoom issue. I Zoom Out and found the Map button so everything looks good to me, Thanks to Akash Kesarwani!
Matt GeiselMatt Geisel
I am getting the same error. I have an import of accounts only (no contacts) and I get the same error.

User-added image

A snipit of the data:

User-added image

Zooming out doesnt show any additional options or fields to map. This error is super vague and not helpful at all.

Any assistance with this is greatly appreciated.
 
Preeti khilnaniPreeti khilnani
Faced the same problem but Zooming out works! Saw the Map button.
Aruna MulikAruna Mulik
Switch to classic view and follow same steps as given in the challange, it works.