+ Start a Discussion
Alvaro MattosAlvaro Mattos 

Please, anyone facing error "Challenge Not yet complete.here's what's wrong: Could not find a properly routed case. Ensure that you've setup Omni-Channel correctly by following the requirements" on Omni-Channel Basics -> Start Routing with Omni-Channel.

Best Answer chosen by Alvaro Mattos
Alap MistryAlap Mistry
Hi Alvaro Mattos,
All Steps are in the unit. So you also set it as unit's steps.
Regards,
Alap Mistry

All Answers

Alap MistryAlap Mistry
Can you post your screenshots?
Alvaro MattosAlvaro Mattos
Dear Alap, thank you for your help. Please download zip file with 10 images on link below, with screenshots of all steps. I am using two DevOrgs, but both are included on My Trailhead Playground. I have no idea why this challenge can't be completed. Case was sent to Queue (you can see the history on Related List), I accepted from Queue, it works perfectly, but I received an error msg when Check challenge. 

https://1drv.ms/f/s!AgnyPpk1FIuihTzm19tb4FKigE-2
Alap MistryAlap Mistry
Hi Alvaro Mattos,
  1. In Routing Configurations> under Routing Settigs>Push Time-Out (seconds) value is null, but you set 120 seconds.
  2. App label=Omni-Channel Console, But you set it as Omni-Channel.
  3. Navigation Tab ItemsCases
    1. Home
    2. Accounts
    3. Contacts
    4. Omni Supervisor
Check all conditions and set as above values.
If this post is helpful, then it is mark as Best Answer.
Regards,
Alap Mistry
Alap MistryAlap Mistry
Hi Alvaro Mattos,
All Steps are in the unit. So you also set it as unit's steps.
Regards,
Alap Mistry
This was selected as the best answer
Alvaro MattosAlvaro Mattos
For sure Alap. Actually, I missed the step From the console, click Omni-Channel in the console footer to open up the Omni-Channel widget. Set your status to Available - Cases. After executed this item, I got the desired result. Thank you very much for your attention.
Alap MistryAlap Mistry
Hi Alvaro Mattos,
You are most welcome.
Regards,
Alap Mistry
Hiren Patel 26Hiren Patel 26
From the console, click Omni-Channel in the console footer to open up the Omni-Channel widget. Set your status to Available - Cases.
how to execute this? snapshot please?
Wade Lovell 1Wade Lovell 1
Hi Hiren: I completely understand your request. In the bottom right hand corner of my console footer there is a red X next to Omni-Channel. It looks like it sits above an icon for an inbox. In any case, the only "persence status" available is "Offline". I have tried this in two old Playgrounds and a NEW playground with the same outcome. The only thing I can think of is premissions in my browser may be too restrictive. Have you found a solution? Are you actually having a different issue? Post here and let's both complete this Challenge.
Umang ModiUmang Modi
Hi All,

Just wondering if you were able to fix the issue. I am facing the same issue.

Best,
Umang
Gowri KaranamGowri Karanam
I was stuck in this challenge as well. I followed instructions to the dot and reviewed it a dozen times. I realized i was not passing the challenge as i am not opening the high pririty case from a push notification on the app. hence i went back to omni-channel console settings and enabled push notifications for cases. I opened the app from app launcher, change my status from offline to available. I got a notification about the high priority case, I opened the case and challenge completed. hope this helps someone.
Umang ModiUmang Modi
Hi Gowry,

Thanks for responding back. Can you review my routing configurations as I suspect there should be an issue. Reason is I am not getting a push notofication within 120 sec.

Routing Config

Thanks in advance.
Best,
Umang
Gowri KaranamGowri Karanam
@Umang, very sorry, i just checked you response. 

Please go to omni-channel console setting, there you have option for push notifications... read carefully, it is easy to miss. Enable it then you will get the notification to pass the challenge.
Winston SucherWinston Sucher
This got me for quite a while. The key for me is that I was offline. Though the instructions were clear, I still overlooked in the very bottom right hand corner of the browser window a red "X"  infront of the text "Omni Channel" indicating I was offline (see image). I clicked on this "X" and then clicked the "Offline" text link in the popup window and changed to "Available" then I was able to be routed the case.
User-added image
hema rajendranhema rajendran
Thanks Gowri Karanam.. I completed the Challenge after following your steps
Patrick NesbittPatrick Nesbitt
It took me a few laps but I discovered (and subsequently validated by attempting to create a new Service Channel) that the Service Channels default value for "Salesforce Object" is broker, by changing this value to case my request came through and I was able to complete the exercise.
GT1945GT1945
I cant see this widget on my browser https://developer.salesforce.com/forums/servlet/rtaImage?eid=9070G000000JChd&feoid=Body&refid=0EM0G000000J2xC
 
Anne JungeAnne Junge
@Gowri: How can I access the Omni-Channel Console SETTINGS and allow push notifications? I see the widget on my page and did all the steps required but it still says: 
Challenge Not yet complete... here's what's wrong: 
Could not find a properly routed case. Ensure that you've setup Omni-Channel correctly by following the requirements.
Thanks!
Thomas Græbe 1Thomas Græbe 1
Hi Anne
I missed to set the omni-chanel base salesforce object to Case. The rest I did correct and got the same error even after correcting base object in step 1. To make it work, I hade to delete the created case in step 6 "Route a Case" and redo it. Then it passed :-)
Anne JungeAnne Junge
Thanks, Thomas. I changed the omni-channel base salesforce object to case but get the same error message. I also don't get push notifications in the case widget.... Can you help?
Wilson MoyWilson Moy
@Thomas Graebe 1
This works for me, and also you need to pay attention to the widget on the lower right side of the screen, it will prompt you to click on the "Accept" link and I passed challenge.

And yes, follow step 6 "Route a Case" carefully, or delete it completely and redo, and then click on the accept link in your widget.

Let me know if this works?

Thanks!
Eileen Kingsley-HammEileen Kingsley-Hamm
I am stuck in the Start Routing with Omni-Channel exercise too. I have created the service channel and routing configurations, linked the routing configurations to a queue, set the presence status for agents, and added Omni-Channel to a console. Several times. And I am still getting the error that my case is not properly routing. I have tried all of the suggestions in this thread and am still getting the error message " Challenge Not yet complete... here's what's wrong: Could not find a properly routed case. Ensure that you've setup Omni-Channel correctly by following the requirements." Does anyone have any other tips and tricks to help me out with finishing this challenge?

Thanks!
Wilson MoyWilson Moy
@Eileen Kingsley-Hamm
Did you try to delete the case and re-create it again?
Did you get the "Accept" link from the widget?
Eileen Kingsley-HammEileen Kingsley-Hamm
@wilsonmoy 
Yes, I deleted the case (several times) and re-created it. I was able to log in to Omni-Channel and accept the case so I'm stumped as to what is not routing correctly.
Lauren Milstid 12Lauren Milstid 12
Where exactly is the Omni Channel Console Settings to push notifications? Thank you.
Sujal Gupta 10Sujal Gupta 10
I tried everything mentioned in the post. But, still no luck. Can somebody help me to get through the module?
yoga srinivash rajaram 7yoga srinivash rajaram 7
If omi-channel console components is not enabled, enable it first. Once case created and owner is changed, you will receive accept notification in console components. Accept it. Your challenge will be completed.

User-added image
Albane RigaudAlbane Rigaud
Hi, same as Anne, I can't get the notification in my widget neither ... Can you tell me how to enable the notifications? Thank you User-added image
venkat davuluri 31venkat davuluri 31
@Albane Rigaud,

You have to change the case owner to High-Priority Cases and refresh the page.

Thank you
 
Marcus FerrerMarcus Ferrer
Hi, Same as above.  I've followed all the 5 steps to set up the user, routing  configuration, queue, presence status, omni channel setup.  I created the case with high priority and web channel, changed the owner but still no notification in the omni channel widget. 
I've had the console component set up as well.User-added image

Any advise what else could i've done wrong?
GieGie
Hi, Does anyone know how to resolve this? A message: "Connection Error. Omni-Channel is currently unavailable." It is not possible to set Available - Cases. Omni-Channel is currently unavailable
SamWendtSamWendt
Hi, I've done everything right, however when I click on the Omni-Channel footer, it doesn't even give me the option to change from Offline to Available. Literally the only option is Offline. I have followed the instructions to a T on two different trailhead playgrounds. Can someone point out what I'm missing?
Sintiche SuwandiSintiche Suwandi

This is crazy, finally i can passed this test after the 5th try.
Thanks to Alvaro & Alap.

The keyword I am missing here is "footer" : "click Omni-Channel in the console footer to open up the Omni-Channel widget. Set your status to Available - Cases". 

"Alvaro Mattos
For sure Alap. Actually, I missed the step From the console, click Omni-Channel in the console footer to open up the Omni-Channel widget. Set your status to Available - Cases. After executed this item, I got the desired result. Thank you very much for your attention."

Reinaldo Sobrinho 1Reinaldo Sobrinho 1
Hi fellows, I have the same problem of @Liang, I don't connect on my Omni-Channel and receive the same error. Anybody can help me?User-added image
Yara ParedesYara Paredes
So far i tried this trailhead like 5+ times and i couldn´t set Omni-Channel Available... i used differents playgrounds and nothing, always the same. 
 User-added image