+ Start a Discussion
Sales DevelopmentSales Development 

Lightning Sync with Google Calendar

Hi everyone, 

I followed all the instructions that Salesforce provided us with to set up the Lightning Sync and Lightning Gmail Integration to Salesforce. It works perfectly for Contacts but it does not work for the Events. I don't get it, because if nothing worked, ok, but only contacts work and not events.
I tried to fix any error I woud have done but i need your help here.

Thank you very much, hope you are all having a nice day !

Mathieu
Satish PrajapatSatish Prajapat
Hello Mathieu,
Its very easy to integrate salesforce with google apps. In your case you want to integrate the Google Calender.
So I am putting all steps so that you can solve your problem.
Gmail Integration with Salesforce:
*********************************
1. Go to setup
	enable lightning sync.

2. Open
	https://console.cloud.google.com/cloud-resource-manager?previousPage=%2F
	https://admin.google.com/technoclusters.com/AdminHome
	https://help.salesforce.com/articleView?id=lightning_sync_admin_google_prep_google.htm&type=5
	login.salesforce

3. 	https://console.cloud.google.com/cloud-resource-manager?previousPage=%2F
	create project
	enable api into salesforce.
	create credential-> Service Account key -> Json File ->> create
	Select the check box of "Service account keys" and click on " Manage service accounts".
	on right hand (Three vertical dots) click edit.
	"Enable G Suite Domain-wide Delegation" check it.

	click view client Id : 110684578070040320926 (Later it will help in admin panel, for the authentication of the user.)



4.	https://admin.google.com/technoclusters.com/AdminHome
	Security-> advance setting -> click "Manage API client access" link
	put client Id : 110684578070040320926
	url : add url comma seperated(	https://www.googleapis.com/auth/contacts.readonly, 
									https://www.google.com/m8/feeds,
									https://www.googleapis.com/auth/calendar.readonly)
	click on authorise button.

5. Go to setup
	enable lightning sync.

6. Setup -> Remote site setting
	add  https://www.googleapis.com url

7. sync setup
	edit ->> check checkbox
	edit ->> select OAuth 2.0 for Google
	upload file json
	Connection Test (satish_technoclusters@technoclusters.com) (the mail id which you have logged in into 	https://admin.google.com/technoclusters.com/AdminHome)

8. Sync Configuration
	create new "Lightning Sync Configuration Edit"

Let me know is it helpful or not?
Thanks.
MalakondaiahMalakondaiah
Hi Sathish,
https://www.googleapis.com/auth/contacts.readonly, https://www.google.com/m8/feeds, https://www.googleapis.com/auth/calendar.readonly
these urls are entered into "manage api client access" click on authorize. then i checked in salesforce "user sync status" and "test connection of user setup"  in salesforce,  unable to sync. got errors in test connection.
please help.
 
Satish PrajapatSatish Prajapat

Hello Malakondaiah,
I have mentioned the each steps clearly above follow that one,
Still, your doubt exist. then feel free to ask me.
and make sure that you have GSuite account or any other account (like: xyz@oracle.com, abc@mydomain.com), in that case you can sync your event in calender  from salesforce.

Thanks.
Enjoy Development.

MalakondaiahMalakondaiah
Hi Sathish,
those steps are working fine. 
 We need to add below urls into "manage api client access" click on authorize in Google admin.
Below Urls working fine as expected.
https://www.googleapis.com/auth/contacts.readonly , https://www.google.com/m8/feeds , https://www.googleapis.com/auth/calendar.readonly