+ Start a Discussion
MellycooksMellycooks 

Winter '18 Breaks Community Palette Branding

Has anyone else using Communities in a preview org seen that default text color and size is no longer controlled by the branding Palette?  All components in my community, custom and OOTB are defaulting to what looks like a standard Salesforce color, #0059a7.

As an example, if I add a Rich Content Editor component and add text, it does not obey the Text Color Set in branding.

In the screenshot here you can see the Branding editor is defulating text color to #51515, but without adding any custom coloring in the Content Editor, the text is showing up as #0059a7.  This behavior is consistent in all components, custom and Standard.  
Incorrectly Colored Text

This issue occurs whether or not I have upgraded my Napili Template.

I'm also attaching a screenshot of the inspector, which shows the computed style and rule.

Inspector
Pasan   EeriyagamaPasan Eeriyagama
2nd screenshot is not clear to me. Great if you could copy the markup/code instead a screenshot, or rather a bigger image.

If I'm not misunderstood, I believe Rich text editor content usually does not obey styling because Richtext itself carries own different font styles, styling, color, etc. 
MellycooksMellycooks
The rich content editor does follow the branding palette by default in non-preview instances, as do any custom components that do not have specific styling that would over-ride it.  I can't grab a bigger screen grab from the inspector right now, but the point is that there appears to be a default text color applied accross the board in the Winter '18 release, and the branding palette does not allow you to control text color in Communities.  

I'm using the content editor example to keep this as simple as possible, eliminating the possibility this is due to any custom code.

User-added image