+ Start a Discussion
onur ahmetonur ahmet 

Leaflet map and Locker service compatibility issue

Hi,
I used leaflet map to develop app. However after I change the version of lightening component from 39 to 40 then I got following error whenever I click to leaflet map.  Please also check attached screenshot.  How can I fix this error?

"Unrecognized Content-Security-Policy directive 'referrer'."


Thanks,User-added image
Onur
amidstcloudamidstcloud
Locker Service gets enabled in Version 40. If You want to avoid the locker service, then use any version less than 40.  If You want to work with Version 40 and locker service then use below versions of Leaflet which are compatible with Locker Service.

Leaflet          0.7.7 and 1.0.2
onur ahmetonur ahmet
Hi,
neither the v0.7.7, nor v1.0.2 seem to work in v40 API.