+ Start a Discussion
Grace ChabutGrace Chabut 

data security: control Access to Fields

I'm having issues completing this challenge. I don't know if I'm missing a step or what. Could someone please walk me through this step by step?
It keeps telling me the 'Account' profile did not have the appropriate object and field-level security for the Account object. 
Thanks!
NagendraNagendra (Salesforce Developers) 
Hi Grace,

Sorry for this issue you are encountering.

Please follow the below steps which allowed me to pass the challenge.
  • Step1 Setup->Manage Users->Profiles->New Profile->Named:"Basic Account User"->save
  • Step2 In Basic Account User page-> Field-Level Security->Account[ View ]->Uncheck Rating Visible->save
  • Step3 Setup->Customize->Accounts->Fields->Rating->Set Field-Level Security->Uncheck Basic Account User Visible->save
  • Step4 Setup->Manage Users->Permission Sets->New->Named : Account Rating->save
  • Step5 Click Account Rating-> Apps Object Settings->Accounts->Check both permissions of Rating
For more information please check with below link. Hope this should help you pass the challenge.

Kindly mark this as solved if the information was helpful.

Thanks,
Nagendra