+ Start a Discussion
Patrick McClellanPatrick McClellan 

Business Administration SuperBadge Challenge #2

I'm having trouble validating challenge 2, with regard to Shinje Tashi's user settings.
ERROR: 
Challenge Not yet complete... here's what's wrong: 
Shinje Tashi does not have the user settings he needs.

The instructions say: "This sales data quality specialist supports the entire company and needs to be assigned a role that can see and access all account, contact, and opportunity records for the entire company. Use the Standard User profile."

First off, it seems odd not to handle this through a separate profile, but I'm trying to follow the directions. So...

I created Shinje as an active user, User License: Salesforce, Profile: Standard User. There isn't a role specified for him, and the instructions suggest providing access to all acct, contact and oppty records through a role assignment, so I created a Sales Data Admin role, reporting to the CEO. That role should provide RECORD access. Additionally, for OBJECT access, I created a permission set granting full access (CRED, View All, Modify All) to Acct, Contact, and Oppty objects and assigned it to Shinje. I created a separate permission set granting access to the Language preference field on Acct, named that permission set "Bilingual Pilot" as instructed, and assigned it to Shinje.

I'm not sure what I'm missing...

 
Best Answer chosen by Patrick McClellan
Eric JJ van HorssenEric JJ van Horssen
Permission set not needed, The role you created will not be able to see teh records owned by the role above (CEO)

Set the Role simply to CEO

All Answers

Eric JJ van HorssenEric JJ van Horssen
Permission set not needed, The role you created will not be able to see teh records owned by the role above (CEO)

Set the Role simply to CEO
This was selected as the best answer
Patrick McClellanPatrick McClellan
@Eric JJ van Horssen, thanks for the tip. That seems like an odd use of Roles, but it works. Earned the Superbadge today!
Eric JJ van HorssenEric JJ van Horssen
Trailhead has shown me many things, I did not know, but on the other sometimes, I would have made other choices.

I have often suggested for Admins, to have an Admin Role, above the CEO, but indeed not for a user to be compared with the CEO
Karan Singh 68Karan Singh 68
Sorry, i made his role as CEO but still it is showing the same error
Laurent AMIELLaurent AMIEL
Hi Karan, same pb.

CEO role isn't enough.
Have to make a permission set called Bilingual Pilot , and allow ALL  the objects permissions from Read to Modify, and select for Language Preference Field Read and Edit Access.
By the end , affect this permission to Tashi by Manage Assigments.

One hour for this step, well helped by this blog, but it's working ;)
Martin Hurst 9Martin Hurst 9
Hello, 
I created the permission set called Bilingual Pilot.
I clicked on View All and Modify All checkboxes - all the checkboxes are now checked under the "Object Permissions section".
Beside the "Language Preference" field I checked the Edit checkbox.

I assigned Tashi to this permissions set under Manage Assigments.

BUT the verify challenge is still not passing!!??

What am I doing wrong?
Martin Hurst 9Martin Hurst 9
Also, Tashi is in the CEO Role and active.
Martin Hurst 9Martin Hurst 9
BUT the verify challenge is still not passing!!??

What am I doing wrong?
Martin Hurst 9Martin Hurst 9
I solved my own problem.

I originally set Shinje Tashi with the User License of "Salesforce Platform"
and the Profile of "Standard Platform User".

To be able to pass the verfication step, I had to changed the User License to "Salesforce"
and the Profile to "Standard User".

I also had to delete the permissions set "Bilingual Pilot" and then re-create the "Bilingual Pilot"
permissions set with the profile of "Standard User".

Under Object Settings for Accounts, I then selected "View All" and "Modify All" and Create checkboxes,
and under Field Permissions for the "Language Preference" I selected both Read Access and Edit Access checkboxes.

I was then able to added Shinje Tashi to the Manage Assignments because the profile for Tashi and the "Bilingual Pilot" permission set now matched.

The verification check passed now.
 
Brian_ParkerBrian_Parker
This one was a doozy! I completed almost exactly the same as Martin Hurts 9 above, but I created the permission set to not be attached to a specific license and then just added that user to the set and it finally worked. took me forever!
Adriana AndreiAdriana Andrei
Hello, I am trying to complete this challenge as well, but I have some errors:
1. when I try to set for Lance Park a Custom: Sales Profile, I cannot find any in my pickup list values.
2. when I am trying to set Lincoln Ulrich as marketing user, the select box is not selectable. Also, I cannot select the Standard Profile, my only option is Standard Platform User. 

User-added image
What am I doing wrong?

Thanks,
Adriana
Panagiotis AxaopoulosPanagiotis Axaopoulos
Hello, I face problem with the step of Bilingual Pilot.
I follow your instructions but the error message remains:  

"Challenge Not yet complete... here's what's wrong: 
The solution for extending access is not assigned to the right user or is not granting access to the right field."

Can you give me more specific instructions?

Thank you in advanced,
P.A.
Yoanna DimitrovaYoanna Dimitrova
Hi @Adriana Andrei, I have the exact same issues. Did you find a wa yo to resolve them?
Thanks a lot!
Kind regards,
Yo
 
rizki asharirizki ashari
Hi Adriana and Yoana,

The reason you dont see standard user in your pick list is because you already have more than 2 active users in your org.
Salesforce developer edition only provide 2 active licenses.

Deactivate other user with "Salesforce" as their user license. the only remaining user with "Salesforce" as user license should be yourself (the admin).
Go back to lincoln ulrich user page, you will see "salesforce" available in the user license picklist.

Rizki
Karthik Mallappa 3Karthik Mallappa 3

Hi All,

Those who are still getting the issue as "Shinje Tashi does not have the user settings he needs" even after providing the CEO role, please do follow below steps

1. Create a permission set as "Bilingual Pilot" and give read, create, edit, delete, view all and modify all to Accounts, Contacts and Oppurtunity objects (by also making Language Preference as Edit Access) under Object Settings.
2. Once Saved click on "Manage Assignments > Add Assignment" and assign it to the Shinje Tashi User.

Check your challenge and your done :)

Note: Before you assign the Permission set, please make sure Shinje Tashi User has the details as below

Role: CEO

User License: Salesforce

Profile: Standard User

 

Cheers,
Karthik

Kevin ThorntonKevin Thornton
Need Help. Still getting error of Challenge Not yet complete... here's what's wrong:
The solution for extending access is not assigned to the right user or is not granting access to the right field.
Close errors.

Everything I have done matches with Karthik, but still stuck. any help is appreciated. 


 
Melody Goede 6Melody Goede 6
OMG that was painful!!!  I set up a record type, page layout, permission set, a sales ops role that reported above/inline with CEO... I guess it was something wonky in my role designation because I treid, out of frustration, to assign ihim/her to the CEO role and it FINALLY pased.
Marc Feeney 1Marc Feeney 1
Just ran up against this problem myself.  If you have for any reason changed the name of your permissionset after the fact, make sure the API Name is "Bilingual_Pilot"  I skipped over this little detail about 30 times before I found it.  delete whatever the current API name is, Enter "Bilingual Pilot" in the Labe field, then tab to allow the API field to auto-populate.  Then smash your palm against your forehead like I did.
Smita HodiggeriSmita Hodiggeri
@Thanks Eric Ya assigining the Role of CEO finally worked! 
Kavita Badgujar 10Kavita Badgujar 10
I was also getting the same error as I have set the Role to CFO. So Setting the role to CEO worked for me and completed the challange.

Thank you @Eric. 
hakimi Elias 12hakimi Elias 12
Simply give the CEO Role to Shinje. Then create a permission set name " Bilingual Pilot " give read, create, Edit, Delete, View all, Modify all, as well  Language Preference read-edit access  to the mentioned Onjects.  and assign permission to to Shinje. go and complete your challange.  
Evan SveumEvan Sveum
CEO role works to solve step #2 in the challenge.  But, in real context, is not a good solution.  The CEO role should be for the CEO.  You can also drive a nail with the handle of a screw driver, but a hammer is the best tool! :)
priyanka p 30priyanka p 30
Hi ,
On step:2 iam getting below error:
The solution for extending access is not assigned to the right user or is not granting access to the right field.
Close errors.

tried erverythig but still facing issue.
William FroelkeWilliam Froelke
Pain is right.  BUT, I learned a lot from this thread.  Thank you!
Swapnagandha HawaldarSwapnagandha Hawaldar
Role: CEO
User License: Salesforce
Profile: Standard User
1. Create a permission set as "Bilingual Pilot" and give read, create, edit, delete, view all and modify all to Accounts (by also making Language Preference as Read, Edit Access) under Object Settings.
2. Once Saved click on "Manage Assignments > Add Assignment" and assign it to the Shinje Tashi User.

Last but not the least, make sure user Shinje is Active. I had missed this step and that's why it wasn't working for me.

I feel that Delete permission is not needed on Account but turned it on out of sheer frustration. Also you do not need to change object settings on Contact and Opportunity.
Swapnagandha HawaldarSwapnagandha Hawaldar
@Evan Sveum, I agree with what you say about the use of role CEO for this.
Leo.KLeo.K
On step:2
I got below error:
The solution for extending access is not assigned to the right user or is not granting access to the right field.
Close errors.


I tried erverythig but still facing issue.

At last I changed [Language & Time Zone]
Locale : English(United States)
Language :  English

completed this challange!
 
Mauricio Forero GomezMauricio Forero Gomez
Please Check if the Playground language is in English for people how are doing it in other langauge. 
Mạnh NguyễnMạnh Nguyễn

maybe I missed something but who can tell me what should I put in the User's License, Profile and role? 

example for April Hansen

Tks

耕一 平岩耕一 平岩
@Leo.K thanks for the tip! The problem that could not be solved has been solved! :-)
Azure LuAzure Lu

I did everything but still got the error:
The solution for extending access is not assigned to the right user or is not granting access to the right field.

Then I made change to user Shinje Tashi
Time Zone:(GMT-07:00) Pacific Daylight Time (America/Los_Angeles)
Locale : English(United States)
Language :  English


But still got the error. Then I found a solution in a local forum.
So I made change to the playground admin user 
Time Zone:(GMT-07:00) Pacific Daylight Time (America/Los_Angeles)
Locale : English(United States)
Language :  English


Then I completed this challange!!!

Wei Du 6Wei Du 6
@Azure Lu Thanks a lot, you resolved my issue!!
Ganesh BoraGanesh Bora
the license and profile are set incorrectly for ada balewa issue got resolved with
For Ada Balewa user you can set User License : Chatter Free and Profile : Chatter Moderator User