+ Start a Discussion
Praneeth Jonna 2Praneeth Jonna 2 

sfdx update - panic: Get https://developer.salesforce.com/media/salesforce-cli/sfdx-cli/channe ls/stable/windows-x64: dial tcp 151.101.201.145:443: connectex

I have installed salesforce cli windows 64 bit and I also installed it through npm globally. 
I am on windows 7 machine and behind a company firewall and I have proxy set on my computer

C:\Users\XXXXX>sfdx update
panic: Get https://developer.salesforce.com/media/salesforce-cli/sfdx-cli/channe
ls/stable/windows-x64: dial tcp XX.XX.XX.XX:443: connectex: A connection att
empt failed because the connected party did not properly respond after a period
of time, or established connection failed because connected host has failed to r
espond.

goroutine 1 [running]:
panic(0x6632a0, 0xc0420067b0)
        /usr/local/go/src/runtime/panic.go:500 +0x1af
main.must(0x7b92c0, 0xc0420067b0)
        /home/ubuntu/.go_workspace/src/github.com/heroku/cli/io.go:115 +0x63
main.GetUpdateManifest(0x6a4875, 0x7, 0x6a3c0d, 0x3, 0x7b92c0)
        /home/ubuntu/.go_workspace/src/github.com/heroku/cli/install.go:104 +0x2
72
main.GetUpdateManifest(0x6a4875, 0x7, 0x6a3c0d, 0x3, 0x0)
        /home/ubuntu/.go_workspace/src/github.com/heroku/cli/install.go:102 +0x2
f4
main.Install()
        /home/ubuntu/.go_workspace/src/github.com/heroku/cli/install.go:33 +0x10
0
main.main()
        /home/ubuntu/.go_workspace/src/github.com/heroku/cli/main.go:18 +0x3a

 
Best Answer chosen by Praneeth Jonna 2
Praneeth Jonna 2Praneeth Jonna 2
Set http_proxy and https_proxy on windows computer. Proxy value is specfic to the company. 
This article explains how to set the proxy.
https://docs.cloudfoundry.org/cf-cli/http-proxy.html



 

All Answers

ramya sree 9ramya sree 9
@praneet: did you resolve this issue. If so please let me know how. thanks.
Christophe L'HOTELLIERChristophe L'HOTELLIER
I have the same issue !
AbhisekAbhisek
You need to set the environment variables : https_proxy and http_proxy. I had the same issues and after setting the environemnt variables, worked fine.
ramya sree 9ramya sree 9
@abhisek panda Can you please guide us how did you set those. I tried but getiing some different error
 
PRIYANKA K2PRIYANKA K2
Hi @Abhisek,
I also tried same. but it did not work.Getting same error.Can you guide on same.
Neeti SatarkarNeeti Satarkar
Hi All,
I just faced same issue. So I set proxy as mentioned in above posts and typed sfdx. It updated the sfdx CLI and then it worked!
PFB log details.

sfdx-cli: Updating to 6.0.26-3d23012... 18.2 MB/18.2 MB
Usage: sfdx COMMAND

Help topics, type sfdx help TOPIC for more details:

 force    tools for the Salesforce developer
 plugins  manage plugins
 update   update CLI
Praneeth Jonna 2Praneeth Jonna 2
Set http_proxy and https_proxy on windows computer. Proxy value is specfic to the company. 
This article explains how to set the proxy.
https://docs.cloudfoundry.org/cf-cli/http-proxy.html



 
This was selected as the best answer
Sashibhusan PandeySashibhusan Pandey
I have a different error with same command.. I am behind a company firewall and have my proxy setting done at both system and user level. I have a windows x64 machine. i am getting the below error while issuing "sfdx update".   

Error message : "S3 host is not reachable".

Please help !
gauthami byreddy 1gauthami byreddy 1
Hi Sashibhusan Pandey,

I have similar issue.
Error message : "S3 host is not reachable".
Were you able to fix this? If so, could you please provide me the step?
 
Amanjot PurewalAmanjot Purewal
For me, i use SFDX CLI that is nehind my office Proxy . It was working fine and stopped working when i changed my password . Even after updatign all my Proxy settings to point to my new passwords, it still did not work.
Weird , but my colleague shared that sometimes when passwords have "#" or few special characters , it creates issues. and GREAT , i replaced the "#" in my passowrd to "_" and it started working:)