+ Start a Discussion
Holly Havelka 10Holly Havelka 10 

Help With Batch Apex Job Stuck in Holding Status

Hi All,

I have a Batch Apex Job that gets dynamically submitted when a user clicks a custom button on a record details page.  

The issue I am having is that the job is getting stuck in 'Holding' until 11:00 pm, same day, vs. going next when resources are available.  I am not sure where to even look to see why this issue is occuring.  I have a UAT environment that is set up exactly like production, but I am not having this issue in UAT.  The batch apex job is firing just fine.  

Any thoughts on where I can look for this issue?
Best Answer chosen by Holly Havelka 10
jigarshahjigarshah
Holly,

Looks like this a Known issue from Salesforce (https://success.salesforce.com/issues_view?id=a1p3A0000008g2NQAQ) and fixed as a part of the Summer 17 release. Resolution mentioned is to raise a case with Salesforce support to get more details around what is causing this to happen and to get it resolved.

Have your tried changing the API version of your Apex class to the most recent version? That could possibly help. One other crude thing to try is to manually abort and re-run the Batch job to see if it executes then. Although not a great option but may help you move forward.

Please mark this thread as SOLVED and answer as the BEST ANSWER if it helps address your issue.