+ Start a Discussion
Frankie CollyerFrankie Collyer 

security specialist superbadge challenge 2

I don't know why, but Trailhead does not see that I've setup a user Samantha Cordero with the profile Field Sales User. I've create the Field Sales User profile, created the user Samantha Cordero, activate the user, generate a password, and logged in as the user. I even logged in as her in Salesforce 1, but I still get this message:
error message
Here is what her user detail page:
User-added image
Field Sales User profile:
User-added image
NagendraNagendra (Salesforce Developers) 
Hi Frankie,

May I suggest you please follow the below steps to complete challenge 2 of the security specialist super badge.

1. Navigate to "Sharing Settings"
2. Edit "Organization-Wide Defaults" and set "Opportunity" to private in the drop-down menu and save.
3. Scroll down to "Opportunity Sharing Rules" and click "new"
Rule1.
1. Label can be anything you like
2. Rule type = "based on criteria"
3.  Field = Type, Operator = Equals, Value = Existing Customer - Upgrade (the last one will be in the lookup using the icon right next to it)
- the second field will be: Field = Stage, Operator = Equals, Value = Closed Won (also use the lookup icon)

***Make sure you created a public group called "Project Managers" prior to this step if you haven't already***
4. "Share with" should be "Public Groups" in the first drop-down, and "Project Managers" for the second drop down.
5. Opportunity access should be set to "read-only"
Rule 2.
1. Label can be anything you like
2. Rule type = "Based on Record Owner"
3. Opportunity: owned by members of = Roles and Subordinates, and choose Sales Executives for the second drop-down menu
4. Share with: Roles, and choose Inside Sales Users for the second drop-down menu
5. Opportunity access should be set to "Read/Write"
Save both of these rules.
Type "Apex" into your quick search and choose Apex Test Execution
- Click Select Tests
- Choose "All namespaces" from the drop-down menu
- Choose "BeAwesome" and click run.
Your results should be 2/2.
Now navigate to the app launcher, and launch the "Sales" tab, and click on "Opportunities"
1. Click New
2. Name the opportunity anything you want
3. Choose Stage "Needs Analysis"
4. The close date should be picked as a value in the future.
5. click save
6. Create another "New" opportunity and name it anything you'd like again
7. For type, select "Existing Customer - Upgrade"
8. Set the date as whatever today's date is
9. Set the stage to "Closed Won"
10. Save

Now we need to make these opportunities owned by your user "Samantha Cordero"
1. Open the first opportunity you created, and click on the details tab
2. Under "Opportunity Owner" select "Change Owner" and change it to Samantha Cordero
3. Repeat steps 1-2 on the second opportunity.
***You might run into a bug where it doesn't allow you change the ownership to Samantha Cordero***
if this happens, you need to edit the "Field Users Profile" you created by going into it's "Object Settings" and setting the Read/Create/Edit configuration outlined in the Super badges Field Sales User Outline.

It's very important that you set up the previous opportunities, or the error will still throw.
Once the opportunities are created and you have configured everything else, the error will be gone.

TADA! You just passed step 2!!
If you have any more questions, feel free to ask

Kindly mark this as solved if it's resolved so that it gets removed from the unanswered queue which results in helping others who are encountering a similar issue.

Thanks,
Nagendra
Frankie CollyerFrankie Collyer
Nagendra,
Thanks for all of the help! I ran the test and the results are 0/2. I installed the Trailhead Superbadge package before I started the project.  Here are what the details say: User-added imageUser-added image
Kellie HughesKellie Hughes
Thanks Nagendra!
Stamen Nikolov 4Stamen Nikolov 4

Hello everyone,

Just like Frankie Collyer I`m having issues with the Apex Test. I was getting 0/2 just like him. Currently I`m getting 1/2, but still not able to complete successfully the test. Anyone having the same issue?

 

Thanks!

Stamen Nikolov 4Stamen Nikolov 4

It`s again me :) 

Just now was able to successfully pass the Apex test. I found why I wasn`t able to do it before and why at some point i was able to pass one of the two. The apex is related to the sharing rules for the Opportunity object. They have to be created first before Apex can be executed successfully.

Bohdan SavchukBohdan Savchuk
Hey guys,

I created the Public group " Project Managers" but when i am tring to creat Shareing Role "Project Managers" is not poping-up form the "Public Groups"  drop down list. ( Project Managers is a public group).

Anyone having the same issue?
Stamen Nikolov 4Stamen Nikolov 4
Hello Bohdan,

Could you please share a screenshot with the PG that is being setup and also a screenshot from the window you're setting up the sharing rUle? The only reason I could think of is you've been logged to the wrong environment. It happens sometimes. 
Bohdan SavchukBohdan Savchuk
Sharing Settings
Bohdan SavchukBohdan Savchuk
And sorry what is PG? 
Stamen Nikolov 4Stamen Nikolov 4
Hi Bohdan,

PG stands for Public Group. Did you verify that you`ve created the public group and you did that in the same environment? Please double check the same.
Bohdan Savchuk 8Bohdan Savchuk 8
Yes, absolutly. My PG and sharing rules in the same enviroment. 
Ramona SilvaRamona Silva
Hello everyone,
Can someone help me to complete this badge,
I followed all the steps above but still I am having the same issue.
User-added image

Can someone tell me why this error encountering again & again.
Also I have another issue with Apex test,
There I cannot find out "BeAwesome" test.
User-added image

I tried soooooo much but I couldn't find the solution.
Please help me?


 
Ramona SilvaRamona Silva
Can someone explain me how pass this error ''The sharing rule that shares Opportunities owned by Field Sales users with Inside Sales users does not appear to be setup correctly.''
Is there anything wrong in my roles,profiles & other users or something?
But I created them correctly?
 
Shobha JamesShobha James
Did you try using a new Play Ground..i was having the same error ''The sharing rule that shares Opportunities owned by Field Sales users with Inside Sales users does not appear to be setup correctly.''and also my Apex test run was failing .When i tried with the new play ground i passed the 2 nd challenge .
Rich FiekowskyRich Fiekowsky
The point here is that the Apex tests, and the Trailhead challenge-checker, also test the requirement that Inside Sales users can read all Opportunities. This can be satisfied only with a sharing rule. ( Using "View All" in the Inside Sales profile is forbidden by the instructions.) By using "Roles and Subordinates" in a sharing rule, and picking the top of the role hierarchy, one is in effect specifying "All" Opportunities, so this rule gives the right access. 
Neelakanta VasanthNeelakanta Vasanth
Thanks Nagendra for your detailed step on challenge 2
Luz Dary Ferreira 8Luz Dary Ferreira 8
Hello 
Nagendra  

I done all steps but I cannot test my class:
Done
1. Navigate to "Sharing Settings"
2. Edit "Organization-Wide Defaults" and set "Opportunity" to private in the drop-down menu and save.
3. Scroll down to "Opportunity Sharing Rules" and click "new"
Rule1.
1. Label can be anything you like
2. Rule type = "based on criteria"
3.  Field = Type, Operator = Equals, Value = Existing Customer - Upgrade (the last one will be in the lookup using the icon right next to it)
- the second field will be: Field = Stage, Operator = Equals, Value = Closed Won (also use the lookup icon)

***Make sure you created a public group called "Project Managers" prior to this step if you haven't already***
4. "Share with" should be "Public Groups" in the first drop-down, and "Project Managers" for the second drop down.
5. Opportunity access should be set to "read-only"

Rule 2.
1. Label can be anything you like
2. Rule type = "Based on Record Owner"
3. Opportunity: owned by members of = Roles and Subordinates, and choose Sales Executives for the second drop-down menu
4. Share with: Roles, and choose Inside Sales Users for the second drop-down menu
5. Opportunity access should be set to "Read/Write"
Save both of these rules.

Pending
Type "Apex" into your quick search and choose Apex Test Execution
- Click Select Tests
- Choose "All namespaces" from the drop-down menu: I cannot select "All namespaces"
User-added image

- Choose "BeAwesome" and click run.
Your results should be 2/2.

I installed the Trailhead Superbadge - Security, but it is Not Passed in AppExchange Ready
User-added image


It could be the problem?


 
Jessica besser 8Jessica besser 8
I am having the exact same issue with the Apex test Luz. It also says not passed and i select any test. Following your question now. 
Asma FatimaAsma Fatima
@Luz Dary: I just completed the step 2 and encountered the exact issue. Idk why that happens tbh but I found a way around it. 
Click on Developer Console.
User-added image
User-added image
You should be able to see the result/status under the Tests Tab.
Hope that helps!:)
Bhanu Chander 10Bhanu Chander 10
The way I read the (poorly written) requirements, Field Service should have CRE on their own Opportunities, Sales Executives should have RVA on all Opportunities, and Project Managers should have R on the Opportunities that meet the 'Existing Customer - Upgrade' + 'Closed Won' criteria. Though nowhere in the requirements, Opportunities should be shared with Inside Sales.
Sonja HalseSonja Halse
Heeelp!! Where do I find "beawesome"??? it also doesnt show for me so I cant pass this step. :(
Sia GowdaSia Gowda
Hi Nagendra, after following all the steps that you have listed I do get the same error that Frank gets:

Error :- System.QueryException: List has no rows for assignment to SObject 
Stack race :- Class.sb_security.BeAwesome.createUser: line 133, column 1 Class.sb_security.BeAwesome.setup: line 124, column

Please help
Devin JuryDevin Jury
I have completed all of the steps prior to running the Apex test.  When I try to run the Apex test, there is no option for me to select the sb_security.BeAwesome test in the playground that I am completing the superbadge in.  All that shows up under the "[All Namespaces]" is "th_con_app.PlaygroundInstallerTests" and "th_con_app.WelcomeFinderTests".  However, if I log into my regular developer edition hands-on org, the "Apex test execution" allows me to select the "BeAwesome" test.  But obviously I dont have any of the work for this superbadge in that org because it could screw up future work in there.  How do I get the "BeAwesome" test on my trailhead playground?
Hussain Peera1Hussain Peera1
@Sia Gowda, Please verify the Sales Executive User profile name. The profile name might be causing the issue.

Thanks,
Hussain
Ahmed Djallel BOUISRIAhmed Djallel BOUISRI
Hello all,

Wonder if this thread is still active, I came across it when looking to solve an issue i faced in the 2nd step of the "Security Specialist" Superbadge and found that other people faced the same issue but didn't find the answer here.
Fortunately i managed to find the problem after trying for several days, and i am sharing it with you guys to save you some time, so for people who couldn't pass the tests because of the following error :
Challenge Not yet complete... here's what's wrong: The unit tests in the managed package have not passed successfully. Make sure you run all test in your org before checking this section. Ensure that they all pass.
And on the developer console the error message :
System.QueryException: List has no rows for assignment to SObject
The error message is not precise and the fail message on the challenge is not pointing towards the problem as well.
And the problem for me was that i had the name of a profile wrong, or at least not as expected by the assertEquals method, i had a profile named "Sales Executive User" instead of "Sale Executive User". And that's why the query was returning no rows in the test and hence the exception.

Not easy to spot, especially since you don't expect a problem for roles and profiles after you pass the first step, but very easy to solve, so for those of you facing the same exception, verify the names of your roles, profiles, users ... and make sure they match the ones in the challenge.

Good luck for you all.
James PostmaJames Postma
Thank you Nagendra for writing out the steps. This is what I needed!

As I progressed through the steps, I suddenly found myself on steps 3&4 and was unable to continue as I could not select Sales Executive from step 3 below:
3. Opportunity: owned by members of = Roles and Subordinates, and choose Sales Executives for the second drop-down menu
Step 3

I was also unable to select Sales Users for step 4.  
4. Share with: Roles, and choose Inside Sales Users for the second drop-down menu:
Step 4

Let me know how I can populate the Sales Executive and Sales Users.
In the mean time, I’ll continue to search for others who may have encountered this issue from either this Superbadge Challenge or previous Challenges.

On a related note, I selected Edit from the Sharing Settings page as I read from Bohdan Savchuk's post who had "All Internal Users" about to be selected.
In an effort to replicate this in order to move forward I selected Manual User Record Sharing and Manager Groups, which could have been a mistake. See lower rigth corner of screenshot.
Sharing Edit
After noticing I cannot make the changes, I went to reverse the edit back to what it was previously, but I cannot select the Manager Groups check box.

Manager Groups edit
Can I continue from here?  Pls confirm. Thank you.


 
Courage WorldwideCourage Worldwide
QUESTION: The requirements say that the Field Sales User should be able to read and edit all accounts. According to what I am finding in these posts, they didn't mean "ALL Accounts" but All accounts under the Sales Executive Role. Those are 2 different permissions. Anyone know which one it is?

Same with Inside Sales User:  view, create, and edit all accounts and opportunities (but not delete them). Do they mean ALL or All under the Sales Executive Role? If it is under the Sales Executive Role they should make that clearer.

In both cases its a matter of changing the Sharing rule to apply to "All Internal users" or "Roles and Subordinates: Executive Sales Role".

Anyone know for sure? I can't get my test to pass anway but I would like to rule this out. My error is: System.QueryException: List has no rows for assignment to SObject.
Ahmed Djallel BOUISRIAhmed Djallel BOUISRI

@Courage Worldwide

check my answer two comments up, you should verify that you named your users, roles, profiles ... correctly

Courage WorldwideCourage Worldwide
Thanks! Miss typed one role and it passed. Appreciate the help!
Arpon AkhandArpon Akhand
Hi Everyone

Don't know if you guys can solve the Security Specialist Superbadge Challenge 2 or not. But I today I solved the problem. Yah!! I am excited to share the process that I follow.

A big thanks to Nagendra for showing me the path.

But there are some issues with this. Few things are not cleared.

So, here I write down what I do.

1. Create the public group where I assign only the project manager.
2. Create the new opportunities that required for the challenge.

Here comes the tricky part of the challenge.

3. I create 3 "Opportunity Sharing Rule" to pass the "Apex Test Execution"
Criteria Based Rule - (Stage Equal Closed Won) & (Type Equal Existing Customer - Upgrade). This is read only. I shared this with the project manager through public group that I created
Record Owner Based Rule - Record Owner (Role: Field Sales) & Shared With (Role: Inside Sales). This is read/write. 
Record Owner Based Rule - Record Owner (Role and Subordinate: Sales Executive) & Shared With (Role: Inside Sales). This is read only. 
4. Check "Apex Test Execution". I hope if you follow all the steps i mentioned you will pass the test.

Hope you guys follow the steps and pass the challenge 2.

Let me know you pass or not.

Thanks
​​​​​​​Arpon
sonali godsesonali godse
which licence should give to inside sales user and field sales users profile. because only 2 salesforce licence are available and already i had give 1 for admin and another for sales executive.
 
Ahmed Djallel BOUISRIAhmed Djallel BOUISRI
Hello Sonali godse,

You give them all salesforce platform access and deactivate users by alternating between them, while having only two active users at any single time. Only the admin should be active all the time.

Good luck.
sonali godsesonali godse
ok. thanks.
 
Elaine Leung 4Elaine Leung 4
I followed the steps suggested and passed Apex test but still getting the message "Challenge Not yet complete... here's what's wrong: 
Could not find a user named Samantha Cordero with the Field Sales User profile.
" .

I created user Samatha Cordero and logged in as Samatha and created 2 opportunities but still getting this message. 
User-added image

User-added image
Ahmed Djallel BOUISRIAhmed Djallel BOUISRI
Check that your user and that your roles and profiles are named correctly !
Cansu Asli AsciCansu Asli Asci

Hello Everyone I PASSED CHALLENGE 2!

So what I would suggest it check Developer Console -> Logs after clicking check challenge.
There will be a step like below.
User-added image
Assertion Failed step with operation /services/data/v36.0/tooling/executeAnonymous is the log for trailhead tests.When you click on it Execution Log will open and operations will be listed from earliest to latest.
Check the log and see after what operation assertion fails.

For me, assertion failed because it could not find any opportunity with a tempuser.Then I checked my opportunities and they were really created under sysadmin name , their owner was not 'Samantha Cordero'.
After I changed the owner to Samantha it worked.
User-added image

User-added image
 

Elaine Leung 4Elaine Leung 4
Thanks for the replies to my question. I turns out that I had to reinstall the managed package and run the APEX test again even though I have done it several times before. So the error message was not helpful. But I have not passed the challenge! 
vuthyra kim 6vuthyra kim 6
I was able to get it passed. I first working at Profiles level, then I assigned Sale Executive role , higher than Inside Sale User and Field Sale User. 
Inside Sale User Profile: 

I set it to this rule at Account, And I got it pass eventhough the instruction seemed to suggested something differently. 
I basically set View All and Modify Alll checked. And then all test pass. 

User-added imageUser-added image
Fenil MehtaFenil Mehta
Hi Nagendra,

Stuck on this
Challenge Not yet complete... here's what's wrong:
The sharing rule that shares Opportunities owned by Field Sales users with Inside Sales users does not appear to be setup correctly.

User-added image

User-added image

pls suggest me what did i wrong ??
Manuela ArangoManuela Arango
I have worked on this the oast 2 days and I cant figurate it out. It keep showing the following message. Challenge Not yet complete... here's what's wrong: The sharing rule that shares Opportunities owned by Field Sales users with Inside Sales users does not appear to be setup correctly.

Also, when i try to run the Apex test I cant find "beawesome"

Please help, thank you!
 
Fenil Mehta 13Fenil Mehta 13
i have completed Security Specialist Superbadge
Fenil Mehta 13Fenil Mehta 13
Hi Manuela Arango,
Field Sales USer Profile - Opportunity - View all
apex 2 test should be pass

User-added image

Add Role Sales Executive in CEO

make sharing role like this

User-added image

run apex test suite- shouls be run 2 test method
then make that two  opportunity record
change owner to Samantha...........
hope it will help...
 
Philip CurllPhilip Curll
Can anyone help me? I keep getting this error after multiple tries in multiple orgs...: Challenge Not yet complete... here's what's wrong: The unit tests in the managed packagehave not passed successfully. Make sure you run all test in your org before checking thissection. Ensure that they all pass. 

I have pass 0/2 in apex test.

I've created Samantha Cordero.. Assigned her Field Sales Role, and assigned her needs analysis and closed won opportunities.

Sharing rules:

User-added imageUser-added image
Field Sales User:
User-added image

Inside Sales User:
User-added image
Sales Executive User:
User-added image
VISHAL SARASWATVISHAL SARASWAT
Can anyone please help me? 

User-added image
OxanaOxana
@Asma Fatima Thanks so much! I was able to run the tests through develper console and passed!!
Asma FatimaAsma Fatima
I'm glad that helped!! 👍
Kelsey Jolitz 20Kelsey Jolitz 20

Unable to pass tests for 2nd Challenge for Security Specialist Superbadge.

Using Apex Test Execution -- 

Error Message: 
System.QueryException: List has no rows for assignment to SObject

Log Details (from Dev Console):
10:57:19:010 SOQL_EXECUTE_BEGIN [132]|Aggregations:0|SELECT Id, Name FROM Profile WHERE Name = :tmpVar1
10:57:19:015 SOQL_EXECUTE_BEGIN [133]|Aggregations:0|SELECT Id FROM UserRole WHERE Name = :tmpVar1

Details of my configuration - 

Roles: Field Sales, Inside Sales, Sales Executive User 

Active Users: 
Cordero, Samantha with Role as Field Sales and Profile as Field Sales User
Myself as the System Admin

Public Group:
Project Managers - Field Sales Roles, User = Samantha Cordero

*Test Opportunities are owned by Samantha Cordero*

Sharing Settings:
Opportunities 

  • Org. Wide Defaults
    • Internal Access = Private
    • External Access = Private
  • Sharing Rules
    • (Opportunity: StageEQUALSClosed Won) AND (Opportunity: TypeEQUALSExisting Customer - Upgrade) Group: Project Managers Read Only
    • Owner in Role: Field Sales shared with Role: Inside Sales Read/Write
    • Owner in Role: Sales Executive User shared with Role: Inside Sales Read Only
I am not sure what other information to provide but this all seems relevant to the error I received in the log in the Developer Console.
This is driving me crazy because I feel like I have done every possible thing with no successful outcome, several times. 

Is there something wrong with my configuration settings? Is there something else I should be looking at?

Very lost at this point. Should I try uninstalling the package and re-installing? Or...

Please advise, thanks!
 


 

Peyton MorrisPeyton Morris
Hey Kelsey, check your Role names use the image provided in the challenge instructions. I only used 2 sharing rules, the frist one you have is good, but I would delete both your sharing rules, then follow Nagendra's post at the top. This is what I did and I was able to pass the Apex test and challenge. 
Vanessa Garza 7Vanessa Garza 7
I finally passed the Apex issues. Like others, mine was a naming issue. I had played around with the the label of roles and had not caught that the Label and Role Name did not match in one of my roles. As soon as I changed that, I passed the Apex tests and 2nd section. 
Kelsey Jolitz 20Kelsey Jolitz 20

I had tried everything mentioned in this thread before I decided to comment.

I have the same exact Users, Role names, and Profile names in setup, provided from the Challenge. Per your advice, I have one sharing rule now - the Opportunity criteria-based one. 

The Role Names and their Labels match, too. 

Getting this error still:

Error Message: System.QueryException: List has no rows for assignment to SObject


Stack Trace: Class.sb_security.BeAwesome.createUser: line 133, column 1
Class.sb_security.BeAwesome.setup: line 127, column 1

I don't know where this is pulling from and i'm not a developer so it's not easy to comprehend. 
Hmm..

Kelsey Jolitz 20Kelsey Jolitz 20
Screenshots for errors

The Apex Test Run in the Playground

The log in the Dev Console
Arun AmalrajanArun Amalrajan
Hi all, Can anyone help. I am stuck in this for past 2 days.

error message...
Challenge Not yet complete... here's what's wrong:
We couldn't find the Sharing Rule that shares Opportunities owned by Field Sales users with Inside Sales users. Please check if the setup of this Sharing Rule is correct.
User-added image


User-added image

User-added imageUser-added image
Muhammad HairullahMuhammad Hairullah
Hi, I hope someone can help me out this is the error which I get "We couldn't find the Opportunity record owned by Samantha Cordero with the expected Stage. Please make sure the record exists and it contains the correct values according to the requirements."But I have already created opportunity for samantha. Do we need to create 2 opportunity under the same stage name?Help me pls

User-added image
User-added image
padala vasudhapadala vasudha
Hi,
I am facing trouble while assigning the owner to samantha cordero and while configuring the opportunities I am not able find the roles as inside sales user.
can anyone help me with these steps. I am stuck up. 
Mars Rover 1481Mars Rover 1481
I'm facing problem in passing the test cases again and again. Though tried running the failed tests in developer console .Any help would be appreiciated. Thank you  in advance.
Ranil Goonesekera 5Ranil Goonesekera 5
@Mars Rover 1481  Can you elaborate on what you have done so far?  Please include any screenshots.  Did you look through what @Nagendra proposed above?
Ranil Goonesekera 5Ranil Goonesekera 5
@padala vasudha  @Nagendra has offered a solution to your first question.  You can also login as Samantha and create the opportunities.  For your second question, you first have to create the Inside Sales User role under roles before being able to pick that role from available options.  Hope this helps.
Idris WrightIdris Wright
Just for anyone passing 1/2 in the apex test, with error message ( Error MessageSystem.AssertException: Assertion Failed: Inside Sales users should be able to read all Opportunities but the test did not find all records. #sadtrombone: Expected: 3, Actual: 2), in my case after following @Nagendra post, the only change i made was to create another sharing rule as follows:

Rule 2.
1. Label can be anything you like
2. Rule type = "Based on Record Owner"
3. Opportunity: owned by members of = Roles and Subordinates, and choose Field Sales (not sales executive) for the second drop-down menu
4. Share with: Roles, and choose Inside Sales Users for the second drop-down menu
5. Opportunity access should be set to "Read/Write

I have all three rules and it passed apex test
 
Colince FOTSO 14Colince FOTSO 14
Thank you @Nagendra, you save my week :)
Aman Singh 120Aman Singh 120
Hi,
Can anyone help me please.
I am not getting 'BeAwesome' test with the 'sb_security' under Apex Test Execution in my Trailhead Playground. But, when i loginto my developer account I am able to find the same.
What should i do please suggest. Stuck on this

Thanks
Sanjay M 13Sanjay M 13

@Muhammad Hairullah

Hi,

It seems like both your opportunities created are with same name try adding 1 & 2 in the end, and I also see that both your opportunities are in 'Closed Won' stage. Make one opportunity (Ex. Opportunity-1) stage to 'Need Analysis'.

Please let me know if you still have issue.

Regards,
Sanjay.

Sanjay M 13Sanjay M 13
@Aman Singh,

Hi,

Do you have multiple playgrounds? If yes, when you try to install the managed package. By default, the installation will be directed to the 1st playground. So just change the URL with your current playground and try installing it.
Also, you can check if the installation happened in the right playground as below:

Setup>Apps>Packaging>Installed Packages or just search 'Installed Apps'. There you should see the package installed. Otherwise, my above assumption is right.

Installed Packages in the right PG

Please let me know if you need more assistance.

Regards,
Sanjay
Sanjay M 13Sanjay M 13
@Aman Singh,

Hi,

Do you have multiple playgrounds? If yes, when you try to install the managed package. By default, the installation will be directed to the 1st playground. So just change the URL with your current playground and try installing it.
Also, you can check if the installation happened in the right playground as below:

Setup>Apps>Packaging>Installed Packages or just search 'Installed Apps'. There you should see the package installed. Otherwise, my above assumption is right.

This image is not available because: You don’t have the privileges to see it, or it has been removed from the system

Please let me know if you need more assistance.

Regards,
Sanjay
Sanjay M 13Sanjay M 13
@Arun Amalrajan

Hi,

Try changing the second Opportunity Sharing Rule to Read/Write (In your case, it is S2). And for the 'Public Group' try adding the User "Carla Rodriguez". Please let me know if you need more assistance. 
Sudharsan C 11Sudharsan C 11
Hello all,

I followed all the steps given by trailhead and after the answers given in developer Forum also i can't pass my TestRun in Apex test Execution.
​​​​​​User-added image
The error in Developer Console is:
User-added image
I hope all the permission gave correctly. Can someone help
User-added image
Sudharsan C 12Sudharsan C 12
Hi @Nagendra ,
I am facing error in Apex Test Execution. Please help me out 


User-added image
prabhakar singh 21prabhakar singh 21
I am also getting test fail error , many time i tried 

This image is not available because: You don’t have the privileges to see it, or it has been removed from the system
Salla TeroSalla Tero
Hi all!

I'm facing this error: 
Challenge Not yet complete... here's what's wrong:
We couldn't find the Opportunity record owned by Samantha Cordero with the expected Stage. Please make sure the record exists and it contains the correct values according to the requirements.
User-added image

My Apex Tests pass. 

I have created the opprtunities when logged in as Samantha:
User-added image

I have been stuck here for hours, and have tried all advice from here already.

Please, any help would be highly appreciated!
Br, Salla
Salla TeroSalla Tero
To my previous message. I managed to get a pass. I created a new playground and redid everything. :)
Sarwer teqSarwer teq
Hi all!
I am facing this error:
and I am not able to pass the test class successfully.
 User-added image
Sharing Rule is:
 My Sharing Rule is:

User :
User-added image
Role:

User-added image
Please help me with this

Regards
Sarwer
Shivang Kumar 1Shivang Kumar 1
please help me out
One class is passed but the other is failing and giving me this error. i stuck for long enough. please help me out
Rohit Shah 5Rohit Shah 5
Hi All,
While creating Rule 2, I am not able to see the custom roles/profiles under drop-down menu of Opportunity: owned by members of for Roles and Suboridnates value. Please help/suggest how to populate required values under this list.User-added image
Siva Prakash KadapaSiva Prakash Kadapa
@Nagenda Your solution is working fine, I cleared my challenge.
sasikumar rsasikumar r
Hi,
Could sombody help to resolve the below error pls.
Challenge Not yet complete... here's what's wrong:
We couldn't find the Sharing Rule that shares Opportunities owned by Field Sales users with Inside Sales users. Please check if the setup of this Sharing Rule is correct.

User-added image

Thanks,
Sasikumar
Sean ClarkSean Clark
Hi All, 

I've been having the same issue to others for days and can't resolve it. i have created the roles, profile, opportunities, sharing rules, public group and the user but cant seem to get it to work.

Please help!


User-added image
User-added image
User-added image
User-added image

 
Sean ClarkSean Clark
Not sure what i have done but i have fixed the issue and its now passing :D this is a strange one
Dafina BojaDafina Boja
Can someone tell me how to solve step by step challenge 1 in Security Specialist ???
Thanks
Bhushan BhushanBhushan Bhushan
Hi,

I have tried all the steps but could not pass the test run, also vreated new trailhead twice but no luck, stuck form past 3 days

Could some one please tell be what should be the exact name for Roles,
For Profile I have given the below Names:
1. Field Sales User
2. Inside Sales User
3. Sales Executive User


It will be highly appricate, if you could share the screen for the steps of sharing rules as well.

Thanks in advance.
Bhushan BhushanBhushan Bhushan
Also which option to be selected for is role in below image:
User-added image
Sean ClarkSean Clark
Hello Bhushan,

I have assignes "Users in this role can edit all opportunities associated with accounts that they own, regardless of who owns the opportunities" as opportunity access.

You profile names look the same as mine, so not sure whats going wrong there. 

for the sharing settings, i've include a screenshot below and you need to ensure that 'Opportunity' is set to private.

User-added image
Dafina BojaDafina Boja
Can someone tell me how to solve step by step challenge 1 in Security Specialist ???
Thanks
Sean ClarkSean Clark
Hello Dafina,

If you look on the breif on the Security Specialist Superbadge, youll see it has headings for Field Sales User Requirements, Inside Sales User Requirements and Sales Executive User Requirements. You need to create profiles for each of these (Field Sales User, Inside Sales User and Sales Executive User) then assign the permissions it says under. 

Field Sales User 
  • Creat List Views - TRUE 
  • Create Reports - TRUE 
  • Create Dashboards - TRUE 
  • New Mobile Application - TRUE 
  • Opportunities - Read, Create and Edit
  • Accounts - Read and Edit

Inside Sales User
  • Scroll to the bottom (not in edit mode) and set login hours for Monday, Tuesday, Wednesday, Thursday and Friday to 08:00AM to 18:00PM.
  • Underneath the Login Hours in Login IP Ranges - Set it to 0.0.0.0 for the start and end 
  • New Mobile Application - TRUE 
  • Create Reports - TRUE 
  • Create Dashboards - TRUE 
  • Manage Report Folders - TRUE
  • Manage Dashboard Folders - TRUE 
  • Create and Manage List Views - TRUE
  • Account & Opportunities - View, Create & Edit All 
Sales Executive User
  • Account & Opportunities - View All
  • Create Reports - TRUE 
  • Create Dashboards - TRUE 
  • Create List Views - TRUE 
  • New Mobile Application - TRUE 
Let me know if this works : ) 
 
Bhushan BhushanBhushan Bhushan
Thanks Sean for your feedback!
I have to create the 4th sharing Rule where objects owned by all internal user are shared with Internal Sales user. Also need to pass the test before creating the opportunities owned by Samantha.
Arjun Singh 63Arjun Singh 63
hi, can anyone help me with this.....

System.DmlException: Insert failed. First exception on row 0; first error: REQUIRED_FIELD_MISSING, Required fields are missing: [SolarBot__c]: [SolarBot__c

one of my apex test cases is not running, i would really appreciate if someone could look into this.
Arjun Singh 63Arjun Singh 63
if you want a peek..here is the  ss.!
Chris der NederlandenChris der Nederlanden

@Ahmed Djallel BOUISRI

Thanks so much for pointing me in the right direction.
I had the same error 
Error MessageSystem.QueryException: List has no rows for assignment to SObject
Stack TraceClass.sb_security.BeAwesome.createUser: line 133, column 1
Class.sb_security.BeAwesome.setup: line 125, column 1

Turns out I had named my Inside Sales Role "Inside Sales User" (same for executive), and the APEX specifically looks for the "Inside Sales" role name. This might have been worth pointing out in the instructions or error somewhere.

Amy TAmy T
@Chris der Nederlanden - The renaming of the ROLES was exactly what was holding me back for WEEKS!!!! Thank you for the recommendation to make sure the word 'User" is not in the role names (in the API names too).  Dank je! Dank je!
Benjamin RollemanBenjamin Rolleman
Hello, I have been stuck on this step for weeks and I have no idea how to get through it. as far as I know I have the same solution as some of the earlier commenters . I have the 3 profiles, 3 roles, two sharing rules that uses the Project managers group. I created the user and the two oppertunities but I still get the same error and I'm running out of ideas to try. As far as I know I have everything named correctly. 

The Oh and I did set the OWD as instructed in the first couple of comments. one thing I'm not 100% sure I have correct is the role structure. I have sales executive reporting to CEO, and both inside and field sales reporting to the executive role. Is this correct? I also realized that I forgot to put in some of the profile restrictions such as where the inside sales users are allowed to login from. I could fix this but I'm not sure if doing so would mess this up.

.



 
Developer Account 32Developer Account 32

Hello All,

can anyone help me with the following. I'm facing issues while running the test for security specialist superbatch
System.QueryException: List has no rows for assignment to SObject
(sb_security)
 

Sergio martinez 12Sergio martinez 12
Hello All, I need help with step one. How do I assign two roles to one user?

User-added image
User-added image
Benjamin RollemanBenjamin Rolleman
Hello, You can’t assign 2 roles to a user. Which part of the challenge are you having a hard time with? You don’t need to assign 2 roles to one person.
Gustavo Ducati ButtelliGustavo Ducati Buttelli
Hello, I need a help.

We couldn't find the Sharing Rule that shares Opportunities owned by Field Sales users with Inside Sales users. Please check if the setup of this Sharing Rule is correct.
Madhura Roy 6Madhura Roy 6

Can Someone please help me!!!!!!
I am stuck at Challenge 2.
I cannot find the BeAwesome class. Can someone please tell me the steps from the beginning to end so that I can verify if I have done the right thing???

Thank you so much in advance!!

Developer Account 32Developer Account 32

Hey Madhura,

After creating two Opportunity Records owned by Samantha. and proper assigning roles. 
Navigate to setup
Enter Apex Test Execution 
In all Namespace(prerequisite: You must have to install managed package provided by Trailhead)
then only you'll find BeAwesome class. 

Let me know if this helped
 

 

Madhura Roy 6Madhura Roy 6

Everything is done. Still cannot pass it. :(
 I will tell the steps that I have done.
1) Installed package
2) Created 3 profiles
3) Created Roles
4) Created User Samantha Cordero and assigned proper role and profile.
5) Created Public group "Project manager"
6) Made OWD private for Opportunites
7) Created 2 Opportunity Sharing Rules and 2 Account Sharing rules

---Account Sharing Rules---

Criteria : Owner in Role and Subordinates: Sales Executive User
Shared With Role: Field Sales User
Account and Contract : Read/Write
Contact : Private
Opportunity : Private
Case : Private

Criteria - Owner in Role and Subordinates: Sales Executive User
Share with - Role: Inside Sales User
Account and Contract - Read/Write
Opportunity - Private
Case - Private
Contact - Private

---Opportunity sharing rules---
1)
> Criteria:
- Type equals Existing Customer - Upgrade
- Stage equals Closed Won

>Share with Group: Project Managers
>Opportunity Access: Read Only


2)
Opportunity: owned by members of - Role and Subordinates: Sales Executive
- Share with - Role: Inside_Sales
> Opportunity Access: Read/Write

Apex test Execution
Cannot find BeAwesome class


Please help??

DAN LI 10DAN LI 10
Hi Guys,
I just cleared the challenge 2 and I wanna share 2 tips to you to avoid getting 0/2 resulst in the Apex test.

1.Before you run the Apex test, please create opportunity sharing rules in advance.
2.Please check whether the profile name, role name and user name you created is compeletely the same as the challenge requirement.
Spelling error or any name differentce seem to lead to the 0/2 result too. For example, the required role name is 'Field Sales', if you input 'Field Sales users' for  the role name, it may also not let you pass the Apex test.

Hope you'll clear the challenge soon!
 
Naveen Kumar 964Naveen Kumar 964
Hi,
I am also getting the error like this
System.QueryException: List has no rows for assignment to SObject
 Stack TraceClass.sb_security.BeAwesome.createUser: line 132, column 1
Class.sb_security.BeAwesome.setup: line 124, column 1
here i put the all names are correctly as per requirement
Sudharsan C 12Sudharsan C 12
Hi
I am facing below error. I cant pass the sb_security Awesome Test. Kindly help meUser-added image
 
helen spallhelen spall
Just thought I'd add a bit about finding BeAwesome in the Apex Test Execution .  I could "select tests" by pressing the button at the top of the pane, but then couldn't see the Be Awesome and it looked like there should have been a dropdown below that was not showing the options.  Next to the select tests button there is a developers console button.  Clicking on that brings up a new screen.  File open then allows you to find BeAwesome.

Hope this helps someone.
Carrie Nunemaker 10Carrie Nunemaker 10
I was struggling on this and found this thread very helpful, so I'm posting what finally worked for me. I had to move the Sales Executive up to be under the top level of the hierarchy. I initially had that role under the CEO and was failing. This cleared both tests for me. 
Amlan PatelAmlan Patel
In addition to profiles, create three more roles as below hierarchy 
  • Your Org
    • CEO
      • Sales Executive
        • Field Sales 
        • Inside Sales
and follow steps as written by @Nagendra .. merely the first comment. 
Asheer AshrafAsheer Ashraf
After going through every forum and testing every solution, I finally figured out the missing key to pass the Apex Test.

I'm assuming you've set up all the sharing rules correctly because there are plenty of solutions guiding you. 

If you're still failing the Apex tests like I was, look into how you named your roles. As silly as it sounds, that finally got me to pass my Apex Tests. 

My profiles were named as suggested in Challenge 1. 
Field Sales User, Inside Sales User, and Sales Executive User

I named my roles the same way, which was causing my Apex tests to fail. After changing my roles to 
Field Sales, Inside Sales, and Sales Executive... I was able to pass the Apex Tests. 

P.S. Remember to change both the field name and field label in order to update the roles. 
Talha MemonTalha Memon

User-added image

This is what I am getting as an error!
 
Talha MemonTalha Memon
User-added image

More clear this way!
Shivanand Totar 10Shivanand Totar 10
Thank you so much @Nagendra you saved my time lot ur genious
Vikas Sawant 6Vikas Sawant 6
Thanks Nagendra
Jaya TiwariJaya Tiwari
Hello Everyone, 
I've completed all the requirements of Step 2 and apex tests are not throwing error. I logged in as Samantha(Field sales User ) and created 2 opportunities as per requirement but still getting error "Challenge Not yet complete... here's what's wrong:
We couldn't find the Opportunity record owned by Samantha Cordero with the expected Stage. Please make sure the record exists and it contains the correct values according to the requirements."
I am stuck here since yesterday and not able to resolve. Any suggestions on this or someone experienced the same issue? 
Needed urgent help!!
Trude Rustad 5Trude Rustad 5

Hi, i am also stuck here.

But i am stuck on the test Be Awesome not passing. Maybe we can help each other? 

Did you create the opportunities? Pls take a screen shot ?
Did you also make the PM permission set`s? 

Jaya TiwariJaya Tiwari
@Trude Rustard, I was able complete the badge 4 days ago, i was gettiong error due to some profile issue. I have changed the Playground and started from scratch ,pass the challenge.
Jaya TiwariJaya Tiwari
For PM , I have created permission set for permission 2FA which comes in later steps. For step 2, you need to write criteria based sharing rule for Project Managers.