+ Start a Discussion
Ted Husted NUTed Husted NU 

Missing Some Trailhead badges on linked Success Account

I've earned 22 badges, but only six show. Five were earned early on. Then a recent one was skipped, but the next one after that shows. 

Other people report the same problem. The account is linked but not all of the badges show. 

* https://developer.salesforce.com/forums#!/feedtype=SINGLE_QUESTION_SEARCH_RESULT&id=906F0000000D8gyIAC

One factor might be changing the email address attribute for the Trailhead org, which I might have done, when we link our Success profile to Trialhead, we have to use our email address -- instead of a Trialhead org username (which is weird).

I also tried registering my Trailhead org, where all the badges show, with the Success Community, but it wasn't able to verify the email address. I guess because it was already linked. 

Right now, when you link your badges, this is a link for "Missing Badges", but it just goes to a Trailhead landing page with no contact information.

I'd be happy to take the six badges over, but since they show on the Trialhead side, I can't earn them again. 

I've tried relinking the account several times, but the missing badges stay missing. 

Any help would be appreciated. It seems to me that developer resources are needed, but there doesn't seem to be a mechanism for filing a Trailhead case. 

User-added image

User-added image
Rahul KumarRahul Kumar (Salesforce Developers) 
Hi ted Husted,

May I request you to please refer the below link for reference.  I hope it will be helpful.

Best Regards
Rahul Kumar
 
Ted Husted NUTed Husted NU
Thank you for the reference, Rahul. I am able to link my account, and refreshing the link doesn't help.

My situation is that I naively changed my email address, and now the badges are associated with different emails. 

I also posted a link back to this post for people in the same situation. 

Since making this post, I have been in touch with Team Trailhead (the trick is to use the leave Feedback link).

I'm told that there is no resolution to my problem right now, and the only place where all my badges will show is the Trailhead account itself. 

I'm contnuing to work with Trailhead on the issue, since ISV partners will soon have a stake in connecting with all of our hard-earned badges. 

* https://www.salesforce.com/company/news-press/press-releases/2017/05/170502-2.jsp

 
M.E. 10M.E. 10
I also changed my email address, causing my badges to not show up. I changed it back to the original email address, and now the badges do show up. Also, I found that the "SAVE" button on the edit page for my profile didn't show up just by connecting the badges. I had to change some other field, and then the "SAVE" button would show up.
 
Shilpa SrikantacharShilpa Srikantachar
Hi Ted, 
If the above mentioned issue is still not resolved , I want to explain the similar kind of an issue I faced and steps to resolution . I just wanted to list the steps that i did , so that it might be of help for anybody with the similar problem.

I was trying to show my badges and certificate on Success Community .

The steps that I followed are as below :
1.Log in to the Salesforce Success Community or Partner Community.
2.Click the drop-down arrow next to your profile photo, and then click your name to view your profile.
3.Click Edit, and then click Work & Experience.
4.Scroll to the Certifications & Badges section, and click Link Trailhead account or Link certification account.
5.Enter the email address associated with the account that you use to complete Trailhead challenges or Salesforce certifications.
6.Click Connect Account. We’ll send you an email with a verification code. If you don’t receive the email, check your spam folder or request a new code.
7.After you get the email, go back to the Work & Experience section of your profile.
8.Enter the verification code, and then click Complete Connection.
9.Scroll to the bottom of the page, and then click Save Changes.

Only the Certification showed up after this and not the badges .

The catch here is that they ask you to enter the email address associated with the Trailhead account. I remember that I had created my Trailhead account using Linkedin and not Salesforce Login . 

I thought that the issue was my Trailhead acount was linked through Linkedin and not Salesforce ACCOUNT .

1st STEP : I merged both the accounts as one . From Profile of Trailhead account >Settings >There is an option to merge.
The merger was succesful . 

I again tried linking with the email account which is the same as my username on Trailhead and Salesforce Login >>>DIDN'T work

Now , I realised that the issue might be I have used another mail account of mine which is on Linkedin and not shown on Trailhead account .

2nd STEP : Now , I entered another email address which is actually linked with my Linkedin ACCOUNT and received the verification code and linked the Trailhead account through this mail id .

Voila !! IT WORKED :)

Hope the LENGTHY explanation helps somebody who face similar kind of an issue.

Regards
Shilpa