+ Start a Discussion
Tamojita GuhasarkarTamojita Guhasarkar 

please help Getting conflicting dependency error while while installing force.com IDE for eclips -

Hi Guys, 

Im getting below error while installing force.com IDE for eclips.

Cannot complete the install because of a conflicting dependency.
  Software being installed: Force.com IDE 38.0.0.201701101558 (com.salesforce.ide.feature.feature.group 38.0.0.201701101558)
  Software currently installed: Eclipse IDE for Java Developers 1.3.0.20100617-0520 (epp.package.java 1.3.0.20100617-0520)
  Only one of the following can be installed at once: 
    Compare Support 3.5.100.I20100526-0800 (org.eclipse.compare 3.5.100.I20100526-0800)
    Compare Support 3.5.101.R36x_v20100929-0800 (org.eclipse.compare 3.5.101.R36x_v20100929-0800)
    Compare Support 3.5.600.v20150420-1449 (org.eclipse.compare 3.5.600.v20150420-1449)
  Cannot satisfy dependency:
    From: Force.com IDE 38.0.0.201701101558 (com.salesforce.ide.feature.feature.group 38.0.0.201701101558)
    To: com.salesforce.ide.upgrade [38.0.0.201701101558]
  Cannot satisfy dependency:
    From: Force.com IDE Upgrade 38.0.0.201701101558 (com.salesforce.ide.upgrade 38.0.0.201701101558)
    To: bundle org.eclipse.compare 3.5.600
  Cannot satisfy dependency:
    From: Eclipse IDE for Java Developers 1.3.0.20100617-0520 (epp.package.java 1.3.0.20100617-0520)
    To: org.eclipse.epp.package.java.feature.feature.group [1.3.0.20100617-0520]
  Cannot satisfy dependency:
    From: EPP Java Package 1.3.0.20100617-0520 (org.eclipse.epp.package.java.feature.feature.group 1.3.0.20100617-0520)
    To: org.eclipse.platform.feature.group [3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY]
  Cannot satisfy dependency:
    From: Eclipse Platform 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY (org.eclipse.platform.feature.group 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY)
    To: org.eclipse.compare [3.5.100.I20100526-0800]

now , my Java and eclips both are kept under one separate folder and not in program files in C drive. 

Im using  jdk-8u131-windows-x64 for java
and 
eclipse-java-helios-win32-x86_64 for Eclips. 

Please can someone check and help me to resolve the issue.