+ Start a Discussion
DbjensenDbjensen 

Create Ant_Home path for Windows

Hello, 
I can't get the terminal to recognize my ant path. I get the message "'ant' is not recognized as an internal or external command, operable program or batch file.

I have the apache-ant-1.10.1 and salesforce_ant_39.0 files in this location: C:\Users\DJensen\Ant

My ANT_HOME is set up as: C:\Users\DJensen\Ant\apache-ant-1.10.1

I've tried several different paths, but just can't seem to get it to work. Any help would be greatly appreciated. 

I'm using windows 7.
Best Answer chosen by Dbjensen
Charisse de BelenCharisse de Belen
Hello,

Do you have JDK installed and a JAVA_HOME environment variable configured? Did you add %ANT_HOME%\bin to your PATH environment variable?

Try referring to these instructions: https://www.mkyong.com/ant/how-to-install-apache-ant-on-windows/

All Answers

Charisse de BelenCharisse de Belen
Hello,

Do you have JDK installed and a JAVA_HOME environment variable configured? Did you add %ANT_HOME%\bin to your PATH environment variable?

Try referring to these instructions: https://www.mkyong.com/ant/how-to-install-apache-ant-on-windows/
This was selected as the best answer
DbjensenDbjensen
Hi Charisse - This worked. Thanks so much!
B S REDDYB S REDDY
I have restarted the PC and it is working fine
sanket mahajan 1sanket mahajan 1
Hello All, 

Please go through my blog. I have setup with both Proxy and Non proxy settings.

https://sfdc-concepts.blogspot.com/2019/12/how-to-setup-ant-for-salesforce.html

Hope this will help!

Thanks,
Sanket