+ Start a Discussion
Andrew Jenkins 14Andrew Jenkins 14 

Composite REST API not found? 404

On my developer edition I am able to use the /services/data/v38.0/composite composite API. I seriously LOVE this API, it cuts down on network time and makes life easy.

There is problem however, recently I was trying to integrate with a new customer and to my surprise the composite REST endpoint was 404 not found. The response from SFDC was:

[
  {
    "errorCode": "NOT_FOUND",
    "message": "The requested resource does not exist"
  }
]
Other REST requests on this domain with the same authentication work great... I thought that the composite API was Generally Available. Any ideas? Thanks in advance for the help.
pconpcon
My guess is that either the edition does not support it, or that the feature is not publically available outside of developer instances.  I unfortuantely could not find any documentation to say what editions it exists in or what the release date is
Sankalita Chatterjee 19Sankalita Chatterjee 19
Hello Andrew,

Were you able to solve this? I am facing the same issue so asking. Best Regards
Andrew Jenkins 14Andrew Jenkins 14
Hi Sankalita,

The resolution was to not use the composite API. Even though SFDC claims that it is Generally Available, it is not actually available on several of the Salesforce instances I have worked with.
Lou ChappuieLou Chappuie
I'd like to turn on Composite APIs in my environment (EE) for an integration that requires it, but I can't locate either. Salesforce has said it's under Administrative Permissions, but I'm not seeing it. Does someone have a screenshot of where this should be located? 
ScualScual
This resource is available in API version 42.0 and later
https://developer.salesforce.com/docs/atlas.en-us.api_rest.meta/api_rest/resources_composite.htm
../services/data/v42.0/composite/sobjects

{
    "allOrNone" : false,
    "records" : [{
        "attributes" : {"type" : "Account"},
        "Name" : "example.com",
        "BillingCity" : "San Francisco"
    },{
        "attributes" : {"type" : "Account"},
        "Name" : "example2.com",
        "BillingCity" : "San Francisco"
    }]
}

work on 42 and not on 38 
if this is help you ;)
ARUNMURUGAN ANNADURAIARUNMURUGAN ANNADURAI
It worked for V42.0