+ Start a Discussion
sandip beherasandip behera 

Unable to make a custom field of type date readonly .

I changed to readonly in Field Accessibility and Set Field-Level Security setting of that field. But still I can edit that field
User is Sys Admin. Can anyone explain what I need to do.
Thanks 
NagendraNagendra (Salesforce Developers) 
Hi Sandeep,

I assume your profile is System Administrator so you can edit the field in the page layout. 

Can you check users with Non- Admin profile?

Make sure 'Edit Read Only Fields' is unchecked for non-admin profile otherwise they can edit the field even it is marked as read-only in the page layout.

Below is the navigation for the same:

Your Name ---> Setup --->  Administration Setup ---> Manage Users ---> Profiles ---> Click on the Profile name for which you want to remove 'Edit Read Only Fields' permission ---> System  Permissions

Here click 'Edit' button and uncheck 'Edit Read Only Fields' permission.

Hope this helps.

Please mark this as solved if it's resolved so that it gets removed from the unanswered queue which results in helping others who are encountering a similar issue.

Thanks,
Nagendra.