+ Start a Discussion
Juliane SantosJuliane Santos 

API not triggering a process

Hello! I have an app installed called Yesware and it uses REST API to send 'tasks' over to SFDC when reps make calls or send emails.  Reps also can log calls manually or log emails manually too.  I have various custom fields that are populated through a process. The fields capture the DATE of the last activity on that lead (call/email). So when someone calls John Doe, the task gets logged in John Doe's record and the process fires to udpate a date field on the lead record. This way, we can report on 'last sales touch" for each of our leads without having to run activity reports.  I am having a difficult time getting these custom fields popoulated when tasks are created via this API though. Turns out, it behaves differently than an edit/record creation through the UI. Is there a workaround here so I can trigger that process to run when a record is created via the API? Thanks!!
SalesFORCE_enFORCErSalesFORCE_enFORCEr
Do you have a trigger or process builder to populate these fields?
Juliane SantosJuliane Santos
I have a process builder
SalesFORCE_enFORCErSalesFORCE_enFORCEr
So, are you saying that the builder was not gettting triggered when a task was created? Can you send me a screenshot of your builder?
Juliane SantosJuliane Santos
Sure thing. User-added image 

User-added image

 
Juliane SantosJuliane Santos
It's not getting triggered when the task is created via the API of that yesware application.  Here is the email that was logged with yesware.
The date field is blank. 

But  when i go into the UI and create a task myself under the same lead, the process works fine and now the date is populated. 
SalesFORCE_enFORCErSalesFORCE_enFORCEr
Does the tasks which are getting created from API satisfy the builder criteria? I am talking about the CreatedById and Status fields on the task.
Juliane SantosJuliane Santos
Yes they do. They are not created by Marketo and they are set to completed. perhaps i should test it without the criteria? The process the way it is now does work when i create a task within the UI
Nate MeginnesNate Meginnes
Hi Juliane, did you ever find a fix to this problem? I'm experiencing exactly the same thing right now.