+ Start a Discussion
Anuj Thakur 4Anuj Thakur 4 

Developer console has been stopped working

Hi All,
Suddenly my developer console stopped to opening. It was opening and working fine, suddenly it stopped.
I am using chrome, but I tried in mozila as well but if I am trying to open it, It is started loading and suddenly it will minimize to small window and then will not open at all.

Please give suggestions if anybody come across to related problem.

Thanks in advance..

Regards,
​Anuj
NagendraNagendra (Salesforce Developers) 
Hi Anuj,

The solution would be to reset the IDEWorkspace for the affected user. To do this, please follow the below steps.
  • Open the Developer Console as the affected user.
  • When the error appears, please the "Debug Script" button. If you don't have a "Debug Script" button you'll have to open the Browser's Developer Tools manually (please scroll down to the bottom of this Article for additional information).
  • Move to the 'Network" tab of the browser's Dev Tools.
  • You'll find a number of requests, if you don't, please refresh the browser. We're interested in a request with the following format
User-added image
  • The 'Id' value is the one we are looking for. Please copy that.
  • Open Workbench. Select "Utilities" and then "REST Explorer".
  • Do a GET request for "/services/data/v29.0/tooling/sobjects/IDEWorkspace/1deQ00000004HmJIAU" - remember to replace the "1deQ00000004HmJIAU" parameter with the "Id" relevant to your org that you obtained in step #5.
  • You will see the content of the affected user's IDEWorkspace.User-added image
  • Do a DELETE request.
  • Re-open Developer Console
  • After following these steps the Menus should be available again and the error message should no longer appear.
For more information please check with below link. ​​ Hope this helps.

Please mark this as solved if it's resolved.

Thanks,
Nagendra