+ Start a Discussion
Tech Support 57Tech Support 57 

Apex permission error while installing managed package in professional edition

Hello,
I have built managed package using developer’s edition.
I am using APEX code, classes and triggers in the package to handle certain things.
I have uploaded package as managed-released. The upload was successful.
I then tried installing the package in my Salesforce Professional edition.
I did get below error while installing:

Your request to install package “Package name” was unsuccessful. None of the data or setup information in your salesforce.com organization was affected.

If your install continues to fail, contact Salesforce CRM Support through your normal channels and provide the following information.
Problem:
1. Apex Classes(classes/PhoneNumberFormatTestClass.cls-meta.xml) Missing feature Installing this package requires the following feature and its associated permissions: Apex Classes
2. Apex Triggers(triggers/FormatPhoneNumberForLead.trigger-meta.xml) Missing feature Installing this package requires the following feature and its associated permissions: Apex Triggers
 
When I contacted Salesforce they said:
There are no limitations around apex and professional edition.
There is no restriction on using apex if you start out with an unmanaged package, however the issue is with distribution.
You cannot distribute an unmanaged package through the appexchange. There is no rev share implications.
 
From what I see in their answer the package should work in my Professional edition.
 
Does anyone know or suspect why I cannot install the package?
UC InnovationUC Innovation
Hello,

I'm afraid your app must go through the security review in order to be used in GE/PE.

https://developer.salesforce.com/docs/atlas.en-us.packagingGuide.meta/packagingGuide/dev_packages_apex_ge_pe.htm

You must be an eligible partner with salesforce.com and your app has to pass the security review. The appropriate permissions will automatically be enabled after you pass the security review.

Hope this helps!