+ Start a Discussion
Brian Pedersen 17Brian Pedersen 17 

Battlestation step 2 error - The Battle Station custom object does not contain the correct set of custom fields.

I've followed step 2 step by step.  There should be two fields on th Battle Station Custom object (Project Status and Weapons Status).  I have only completed step 1, and when I go to verify step 2, it states I don't have the correct field count....
User-added image
sfdcMonkey.comsfdcMonkey.com
hi Brlan
look my image
User-added image
create crew member field
Thanks
Mark it best answer if it helps you :)
 
Brian Pedersen 17Brian Pedersen 17
The "Crew Members" field is not requested to be built until step 3 even though the ERD on step 2 shows "Crew members".  This might be a problem with the "Verify Step" on Step 2 where it is looking for the roll-up summary field that doesn't exist.
Prateek Singh SengarPrateek Singh Sengar
Hi Brain,
Can you please post the complete error that you are getting. To complete challenge two you need to do the following:

In Battle station object
1) Create Picklist Project Status
2) Create Picklist Weapon Status

Create new custom object Resource
In Resource object
1) Create Number field Quantity
2) Create Percent field Utilization
3) Create Master Detail field with Battle Station as master

Create new custom object Supplies
In Supplies object
1) Create Number field Quantity
2) Create Currenty field Unit Cost
3) Create formula field Total Cost (Quantity__c * Unit_Cost__c)
4) Create Master Detail field with Battle Station as master


And finally ensure that the correct dev instance is linked to the trailhead for verification.

Hope this helps.

 
Prateek Singh SengarPrateek Singh Sengar
Hi Brian,
You dont need Crew Members to clear step 2, I have cleared the step 2 without creating roll up summary.
Brian Pedersen 17Brian Pedersen 17
Here is the full error:
Challenge Not yet complete... here's what's wrong: 
The Battle Station custom object does not contain the correct set of custom fields. Tip: check for typos in the field names. 
Note: you may run into errors if you've skipped previous steps.

I attached my schema from my dev org.

 User-added image
Prateek Singh SengarPrateek Singh Sengar
Hi Brian,
One thing you can try is enable debug log in your dev org, and try verifying the challenge, this will create a debug log and it might help you in identifying the exact issue. 

BTW, sometimes just disconnecting the org from trailhead and reconnecting again solves such issues as well.
Brian Pedersen 17Brian Pedersen 17
I disconnected both, restarted Chrome and turned on debug logs.  They gave nothing:

30.0 APEX_CODE,DEBUG;APEX_PROFILING,INFO;CALLOUT,INFO;DB,INFO;SYSTEM,DEBUG;VALIDATION,INFO;VISUALFORCE,INFO;WORKFLOW,INFO Execute Anonymous: List<Battle_Station__c> l = [SELECT ID from Battle_Station__c LIMIT 1]; 10:18:57.10 (10387355)|USER_INFO|[EXTERNAL]|005j000000C4xC9|pedersenbrian@gmail.com|Pacific Standard Time|GMT-07:00 10:18:57.10 (10401751)|EXECUTION_STARTED 10:18:57.10 (10405110)|CODE_UNIT_STARTED|[EXTERNAL]|execute_anonymous_apex 10:18:57.10 (11211143)|SOQL_EXECUTE_BEGIN|[1]|Aggregations:0|SELECT ID FROM Battle_Station__c LIMIT 1 10:18:57.10 (13172029)|SOQL_EXECUTE_END|[1]|Rows:0 10:18:57.13 (13259306)|CUMULATIVE_LIMIT_USAGE 10:18:57.13 (13259306)|LIMIT_USAGE_FOR_NS|(default)| Number of SOQL queries: 1 out of 100 Number of query rows: 0 out of 50000 Number of SOSL queries: 0 out of 20 Number of DML statements: 0 out of 150 Number of DML rows: 0 out of 10000 Maximum CPU time: 0 out of 10000 Maximum heap size: 0 out of 6000000 Number of callouts: 0 out of 100 Number of Email Invocations: 0 out of 10 Number of future calls: 0 out of 50 Number of queueable jobs added to the queue: 0 out of 50 Number of Mobile Apex push calls: 0 out of 10 10:18:57.13 (13259306)|CUMULATIVE_LIMIT_USAGE_END 10:18:57.10 (13291829)|CODE_UNIT_FINISHED|execute_anonymous_apex 10:18:57.10 (14809760)|EXECUTION_FINISHED
Steve James 7Steve James 7
Just wanted to follow-up on this issue as I was running into the same error today as I was going through this trailhead. It did simply end up being a typo for me...I was using "Weapon Status" as the field label and realized that it needed to be plural "Weapons Status". After making the change, I was able to verify and move to the next module. Creating a "Crew Members" roll-up is not required.
Laura McKevittLaura McKevitt
For those that get this error and have no apparent issue, delete the "Weapons Status" field and recreate it. Worked for me!
Fatima MasudFatima Masud
Been at it for hours now. I have made the Project Status and Weapons Status fields thrice already along with doing thw whole thing twice. Still no luck. The error is still the same 'Challenge Not yet complete... here's what's wrong: 
The Battle Station custom object does not contain the correct set of custom fields. Tip: check for typos in the field names.'

User-added image

Any help at all would be amazing!
Francis AlegadoFrancis Alegado
I did what Laura mentioned about making 'weapon' plural with the 's' AND I've changed the Related List label name of the Supply object from the default 'Supplies' to 'Supply.  Doing that both worked for me!

Supply Object - Battle Station field screenshot
Manoj Goswami 5Manoj Goswami 5
Here's the workaround that worked for me :
Go into the object manager > Battle Station > Make all custom fileld visible in Field Security settings for all users.
Shivam Govil 40Shivam Govil 40
I also went by Laura's intructions and it worked.
Malli 6Malli 6
I created Crew Members Field in Battle Station Custom Object. Even though it's showing as below,

Step not yet complete in mallik@mpworld.com
The Battle Station custom object does not contain a field called 'Crew_Members__c'. Tip: check for typos in the field name.
Please help me with this.

User-added imageUser-added image
Piedad GarciaPiedad Garcia
Manoj Goswami 5 solution worked for me. Cheers!
Amit Kumar1Amit Kumar1
You haven't set the field-level security of the custom field which were created in Battle Station. Simply set the field-level security to both (Weapons Status and Project Status) to visible o selected profiles you want.
Vaishali Patil 35Vaishali Patil 35
I have created Crew_Members__c field on Battle station custom objects but still I am getting error while completing the challange.

User-added image
Maxim Petrosov 1Maxim Petrosov 1
Hey guys, I have the same issue. Moreover, after deleting and creating the new fields I can verify this challenge, and btw I have the same mistake: instead of Weapons Status, I used Weapon Status.