+ Start a Discussion
Andrew Lewis 9Andrew Lewis 9 

Can't change field level security

Hi all,

This may sound like a dumb question, but I am currently unable to change the field level securities for the Private standard field under Events. I have users in specific regions and one needs to be able to see this field while the other does not want it. When attempting to edit the FLS clicking the check boxes is not an option. Any advice? 
I am on the sytem admin profile and would think I should beable to edit this.

User-added image
Best Answer chosen by Andrew Lewis 9
Prateek Singh SengarPrateek Singh Sengar
Hi Andrew,
Unfortunately you can't change the field visibility from FLS, this is a standard field and doesnt allow admins to change FLS. However you do have an altreante options (workaround)
You can createa a new page layout for event and remove this field from the page layout, now you can assign this page layout to the users who dont want to see this field. Ofcourse this would mean that these users should have a different profile. Like i said its not ideal solution and more like a workaround. Hope it helps.

All Answers

Prateek Singh SengarPrateek Singh Sengar
Hi Andrew,
Unfortunately you can't change the field visibility from FLS, this is a standard field and doesnt allow admins to change FLS. However you do have an altreante options (workaround)
You can createa a new page layout for event and remove this field from the page layout, now you can assign this page layout to the users who dont want to see this field. Ofcourse this would mean that these users should have a different profile. Like i said its not ideal solution and more like a workaround. Hope it helps.
This was selected as the best answer
Andrew Lewis 9Andrew Lewis 9
Hi Prateek,

Thanks for clearing this up. Unfortunately we only have one record type for events in my org and a lot of custom code residing in activities. This would have to be reworked in order to add another page layout as far as I know. 

Thanks again,
Andrew
Marcelo ArredondoMarcelo Arredondo
Hi Andrew,

I found the same issue, and I discovered that it happens if you check the checkbox "Required" when you create/edit a field. If you uncheck the "Required" checkbox, then you are able to establish the field-level security in the next screen.

Regards,
Marcelo
Roger Chang 77Roger Chang 77
@Marcelo - thank you for posting this. I also discovered this today and was confused until I unchecked the Required checkbox. Odd functionality.