+ Start a Discussion
Brendan HeinzBrendan Heinz 

Unable to find Force.com IDE perspective in Eclipse Java Neon

Having some trouble using the Force.com IDE in Eclipse Java Neon and wondering if anyone has seen something similar/can help.  Here is where I'm at:

I've installed Java JDK 1.8.0_101
I've installed Eclipse Neon IDE for Java Developers, as recommended here: https://developer.salesforce.com/page/Force.com_IDE_Installation
Upon opening Eclipse, I've followed the instructions to "Install New Software" and Added the Force.com IDE, and finished installation (it shows in the list in "Installation Details")

However, when I go to Window > Perspective > Open Perspective > Other, it does not show in the list.  I've repeated the above steps a few times and restarted, and still no luck.  Anyone have any ideas?
karthikeyan perumalkarthikeyan perumal
Hello 

Just follow the steps below, 

Step 1: after installation. Window > Perspective > Open Perspective > Other > another window will open like below, in that you have to select Force.com IDE like below, 

User-added image


Setp2: after finishing step 1, Go to FIle>NewProject> its promote another window in that one select force.com Project then click next its ask you to enter your username, password, securitytoken.  then select the metadata. like below

User-added image


if you unable to see the force.com options kinldy make sure that all components related to force.com IDE. 

Hope this will help you. 

Mark Best ANSWER if its work for you. 

Thanks
karthik


 
Brendan HeinzBrendan Heinz
Hello Karthik,

I appreciate the response, but am still having trouble.  I've walked through installing/uninstalling Eclipse and installed all three Force.com IDE Components (Force.com IDE, Force.com IDE Debugger, Force.com Lightning Support), and still am stuck at your Step 1, as the Force.com Perspective does not show in my list.

Any suggestions on why this might be?

Thanks again!
karthikeyan perumalkarthikeyan perumal
kinldy check the step 2 directly from your Eclipse  tool,  and lte me know the result, 

Thanks
karthik
 
Brendan HeinzBrendan Heinz
Karthik,

Upon opening the new project window, the only options I have are General, Gradle, Java, Maven, and Examples - no Force.com Project option here either.
Jayanth ThathapudiJayanth Thathapudi
@Brendan Heinz 

Try to install lower version of Force IDE plugin...I also faced the same issue and tried with lower version of Force IDE and it worked for me.
LakisLakis
Hey @karthikeyan perumal,

I hope you can help me with this one... I can see the Force.com IDE perspective and I can see option to click "New" -> "Force.com Project" as per screenshot below. However, after clicking New Project, nothing is coming up. I should see Salesforce login page but nothing's come up?

I'm using "Eclipse IDE for Java Developers" Version: 2018-09 (4.9.0) | Build id: 20180917-1800.
Java version: javac 11.0.1.

Any ideas?

Best,
Lakis

User-added image

 
karthikeyan perumalkarthikeyan perumal
Hello, 

Have you followed these steps, Have you installed all supported plugin. if not kindly follow the linkes. coz i am not using iOS.  

https://www.forcetalks.com/blog/steps-to-install-the-force-com-ide-plug-in-in-eclipse/

User-added image

Thanks
karthik
 
Marco Zisa 2Marco Zisa 2
I would point out that FORCE.COM plugin will be no longer supported soon... It's better to move to Visual Studio Code as IDE + Salesforce Extension Pack and Salesforce DX CLI.
Another option to MavensMate is Salesforce Org Manager, which is an open source project proposing an org metadata manager like MavensMate, with treeview rendering of the Org's metadata.

Also, Visual Studio Code is not only for scratch org, you may use it for coding to "normal" sanbox or developer Orgs.

Feel free to contact me for any further details.