+ Start a Discussion
victorng8victorng8 

Build an Automated Workshop Management System : Get Started (cannot find "Chapter")

Challenge Not yet complete... here's what's wrong: 
The Campaign object has does not appear to have an Account lookup field called "Chapter". 
Note: you may run into errors if you've skipped previous steps.
This is the error I am getting when trying to verify my step.

This is the link to the trailhead question. 

I did all the steps as it said but I can't get it to pass.

These fields I made are placed in "Campaign" object that I created (there was no existing Campaign object in my env
Above are the fields I created in the "Campaign" custom object. I had to create it because no existing object.

User-added image
As you can see, it does have the lookup field to account.

So why am I still getting the error?
Best Answer chosen by victorng8
SandhyaSandhya (Salesforce Developers) 
Hi victorng8,

Here the challenge is referring standard Campaign object you no need to create a custom object called Campaign.

You can find the Campaign object if you select sales in the drop-down box at the top right corner.

Please see below screenshot

User-added image

Hope this helps you!

Please mark it as Best Answer if my reply was helpful. It will make it available for other as the proper solution.
 
Thanks and Regards
Sandhya

 

All Answers

SandhyaSandhya (Salesforce Developers) 
Hi victorng8,

Here the challenge is referring standard Campaign object you no need to create a custom object called Campaign.

You can find the Campaign object if you select sales in the drop-down box at the top right corner.

Please see below screenshot

User-added image

Hope this helps you!

Please mark it as Best Answer if my reply was helpful. It will make it available for other as the proper solution.
 
Thanks and Regards
Sandhya

 
This was selected as the best answer
Jess BurghJess Burgh
Hey all not sure what I'm doing wrong. When I went to complete this first step I get this message.
User-added image
What are you supposed to put into the Dev Class object? Thanks!
Natia Iremashvili NIRNatia Iremashvili NIR
Hey all
This is the error I am getting when trying to verify the third step.
User-added image

My proces builder and flow seems working good. Campaign members are being added correctly
User-added image
not sure what I'm doing wrong. 

Please help
Jess BurghJess Burgh
Hey Natla. How did you verify the first step? Not sure what I'm doing wrong. Thanks !!
Victor ArchellaVictor Archella

Jess Burgh,

 

What you have to do is add the Dev Class value into the Type picklist, it is an existing picklist already.

mahesh chagantimahesh chaganti
Hi I am Mahesh, under Lighting trail trailhead id : chaganti99@salesforce.com create custom button ,link facing the problem Challenge Not yet complete... here's what's wrong: There was an unexpected error while verifying this challenge. Usually this is due to some pre-existing configuration or code in the challenge Org. We recommend using a new Developer Edition (DE) to check this challenge. If you're using a new DE and seeing this error, please post to the developer forums and reference error id: JENHXMOJ please assist me thanks
mahesh chagantimahesh chaganti
Hi I am Mahesh, under Lighting trail trailhead id : chaganti99@salesforce.com Trail: MAKE THE MOVE TO LIGHTNING EXPERIENCE (BUILD A CUSTOM RECORD PAGE) Challenge Not yet complete... here's what's wrong: Lightning Page named 'New Account Page' does not appear to contain a Chatter tab with a Chatter feed component. In the left side Lightning components, i can see CHATTER, CHATTER FEED, CHATTER PUBLISHER. IN the challenge tab suppose to replace CHATTER FEED, which was given and in return getting above error. I guess Chatter feed is empty so how to solve thanks
Ranil Goonesekera 5Ranil Goonesekera 5
Jess Burgh,

If you still have not resolved this issue, I am going to elaborate what Victor was trying to tell you.  He had it right.  Go to Setup > Object Manager> Campaigns> Fields & Relationships.  Look under Field Label column and click on the "Type" field label.  Scroll down the page and look under Campaign Type Picklist Values.  You need to see Dev Class there under the value column.  If you don't see it there, press the New button and add it.  Be sure that the Field Label column doesn't have another Type field.  If there is one there check that one too to make sure there is a Dev Class type picklist field.  I added the Dev Class to the wrong Type field and the assignment was reading the other Type field.  Hope this helps after more than a year:)
PearlPearl
Ranil,
It helped me.  ;)  Thank you! 
Antonio Diaz Alvarez 5Antonio Diaz Alvarez 5
Solution.
Setup -> Object Manager -> Campaign -> Select from list "type" -> 
Campaign Type Picklist Values "New" -> add "Dev Class" click "save"

Result:
User-added image