+ Start a Discussion
reatlimecoreatlimeco 

Debug log not showing up in developer console

Seems to start when I run a new test then try to run the test again after I update the code.

I get an error back from developer console when I do the rerun that the Id doesn't exist but yet it starts something that seems to run for ever but it also starts the test which completes but the debug log never shows up in the developer console.

I tried to abort the test but it says that I have to wait for the test to finish.

I tried deleting all the debug log under set up and restarting the developer console.  It shows no delog logs.

I tried to uncheck the show only current debug logs and it still shows all the debug logs that I deleted via setup.

But even if I run a new test, I get the test information under the Test tab but nothing shows up under the Log tab.  THis has been going for weeks now.

Anyone else see this problem?  Is there a work around? 

If I come back to it after a week, I can run the new test and get one debug log but if I try to do a rerun I still get the error and get NO MORE debug logs after that.
SandhyaSandhya (Salesforce Developers) 
Hi,

Please refer below links which have similar discussion with different solutions see if that helps you.

https://success.salesforce.com/answers?id=90630000000grv7AAA
 
http://salesforce.stackexchange.com/questions/50493/console-log-is-not-showing-anything
 
http://salesforce.stackexchange.com/questions/16617/debugging-logs-in-developer-console-is-not-working
 
http://salesforce.stackexchange.com/questions/76064/issues-displaying-logs-in-developer-console-possibly-summer-15-related
 
Hope this helps you!

Please mark it as Best Answer if my reply was helpful. It will make it available for other as the proper solution. 
 
Thanks and Regards
Sandhya