+ Start a Discussion
Prabhat Singh 56Prabhat Singh 56 

I would like to know if my API are compatible with TLS 1,1

I would like to know if my API are compatible with TLS 1,1

And since I have some API, in particular intergration with Sharepoint.

I need to know hot to check if is compliant with TLS 1.1

Regards,
Prabhat
SandhyaSandhya (Salesforce Developers) 
Hi,

I think you need to check Sharepoint documentation for this.

Below are some useful links to get more information.

http://stackoverflow.com/questions/30991911/detect-browser-tls-compatibility
 
https://wordpress.org/plugins/tls-1-2-compatibility-test/installation/
 
Below link explains you the steps for integrating salesforce with SharePoint.

https://dzone.com/articles/7-steps-to-integrate-salesforce-with-sharepoint
 
Hope this helps you!

If this helps you please mark it as solved.It will make available for others as a proper solution.

Thanks and Regards
Sandhya
Prabhat Singh 56Prabhat Singh 56
Thanks for your reply.
Prabhat Singh 56Prabhat Singh 56
Hi Sandhya,

You share with me the link: https://wordpress.org/plugins/tls-1-2-compatibility-test/installation/

It's talks about TLS 1.1, not TLS 1.2

Please suggest me.

Regards,
Prabhat

 
Prabhat Singh 56Prabhat Singh 56
Hi Team,

Please share with me the mote details about TLS 1.1, As per the above link "https://wordpress.org/plugins/tls-1-2-compatibility-test/installation/"

The functionality of TLS 1.1 is similar to TLS 1.2?

It's quite urgent for me.

 
Adi SundaramAdi Sundaram

https://help.salesforce.com/articleView?id=000221207&type=1

 

Visualforce Page Controller:
If you are familiar with Visualforce and Apex development, you can check the ApexPages.currentPage().getHeaders().get('CipherSuite') value, if not null, for the ' TLSv1 ' (including the leading and trailing space) substring. If that is present, then TLS 1.0 is being used, and the Visualforce page can display a notice that advises them to either update their web browser settings or upgrade their web browser.